Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026898
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-06-18 17:012014-06-25 01:35
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionb3671e259f50
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026898: In the tree tab view, if a non root node is moved to the root, it disappears until the grid is refreshed.

DescriptionIn the tree tab view, if a non root node is moved to the root, it disappears until the grid is refreshed.
Steps To ReproduceAs F&B Admin:
- Open the Assets window
- Create two assets, one named '1' and one named '2'. Both of them should the 'Summary Level' flag checked to true.
- Open the tree grid view
- Move the asset '2' so it is a child of the asset '1'. This works OK.
- Move the asset '2' to the first position of the tree, to make it a root node. The node '2' dissapears.
- Refresh the grid. The node '2' is now shown as a root
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0026381 closedAugustoMauch In the tree tab view, is a non root node is moved to the root, it dissappears until the grid is refreshed. 

-  Notes
(0068272)
hgbot (developer)
2014-06-24 12:11

Repository: erp/devel/pi
Changeset: b3671e259f502299a2e90b9c3f07af01836fc9ce
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Jun 24 12:10:40 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b3671e259f502299a2e90b9c3f07af01836fc9ce [^]

Fixes issue 26898: Tree node is not hidden after being moved to the root

If a tree node if moved to the root, the tree cache is invalidated to force redrawing it. Otherwise, the new root node is not shown until the tree is manually refreshed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
---
(0068274)
shankarb (developer)
2014-06-24 13:51

Code reviewed and verified in pi changeset f3972fa0041b.
(0068297)
hudsonbot (developer)
2014-06-25 01:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e78ccbaf0186 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-06-18 17:01 caristu New Issue
2014-06-18 17:01 caristu Assigned To => AugustoMauch
2014-06-18 17:01 caristu Modules => Core
2014-06-18 17:01 caristu Triggers an Emergency Pack => No
2014-06-18 17:01 caristu Relationship added related to 0026381
2014-06-18 17:02 caristu Issue Monitored: networkb
2014-06-18 17:02 caristu Relationship deleted related to 0026381
2014-06-18 17:02 caristu Relationship added duplicate of 0026381
2014-06-24 12:08 AugustoMauch Issue Monitored: shankarb
2014-06-24 12:08 AugustoMauch Review Assigned To => shankarb
2014-06-24 12:11 hgbot Checkin
2014-06-24 12:11 hgbot Note Added: 0068272
2014-06-24 12:11 hgbot Status new => resolved
2014-06-24 12:11 hgbot Resolution open => fixed
2014-06-24 12:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b3671e259f502299a2e90b9c3f07af01836fc9ce [^]
2014-06-24 13:51 shankarb Note Added: 0068274
2014-06-24 13:51 shankarb Status resolved => closed
2014-06-24 13:51 shankarb Fixed in Version => PR14Q3
2014-06-25 01:35 hudsonbot Checkin
2014-06-25 01:35 hudsonbot Note Added: 0068297


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker