Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026645
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2014-05-21 14:132014-10-01 16:43
ReporterumartirenaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisionc93fd134778b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP29.4SCM revision 
Review Assigned Toshankarb
Web browserInternet Explorer
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-08-30
Regression introduced in release3.0MP27
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/6b80b8d83087d03767b9fa658b2662923e63ed3b [^]
Triggers an Emergency PackNo
Summary

0026645: Tables and Tabledirs are not working in Internet Explorer 7 and 9

DescriptionFields of reference type Tables and Tabledirs are not working in Internet Explorer 7 and 9, at least.
Internet Explorer versions tested:
 - IE7: Not working
 - IE8: Working
 - IE9: Not working
 - Later ones: Not tested

The issue is happening at least since MP 29.4
Steps To Reproduce - Install Internet Explorer 7.
 - Go to Sales Order window.
 - Add new Header.
 - Add new Line.
 - Display Warehouse Rules combo. Realize that is not possible to select any option.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00245743.0MP27 closedshankarb Filter is not working fine in some special cases 

-  Notes
(0067341)
adrianromero (manager)
2014-05-21 17:59

To reproduce the error IE9, itmust be configured to "IE9 Compatibility Mode"

The javascript error raised is:

SCRIPT5007: Unable to get value of the property 'indexOf': object is null or undefined
ISC_Combined.js, line 9145 character 302

The js line is:

_1.pickValue(_4?null:_5)},isc.A.itemClick=function isc_PickListMenu_itemClick(_1){isc.logWarn("itemClick");if(this.allowMultiSelect){this.multiSelectChanged()}else{var _2=this.formItem,_3=_2.getValueFieldName();var _4=_1[_3];if(isc.PickList.emptyStoredValue&&_4==isc.PickList.emptyStoredValue)_4=null;_2.pickValue(_4)}},isc.A.hide=function isc_PickListMenu_hide(_1,_2,_3,_4){var _5=this.isVisible()&&this.isDrawn();this.invokeSuper(isc.PickListMenu,"hide",_1,_2,_3,_4);if(!this.formItem)return;if(_5&&this.showModal)this.formItem.focusInItem();this.formItem.$19g=null;if(_5)this.formItem.$19h();delete this.formItem.$19i;this.clearLastHilite()},isc.A.show=function isc_PickListMenu_show(){var _1=this.isVisible()&&this.isDrawn();this.generateClickOnEnter=true;this.generateClickOnSpace=this.allowMultiSelect;this.bringToFront();this.Super("show",arguments);if(!_1){this.formItem.$19j()}},isc.A.showClickMask=function isc_PickListMenu_showClickMask(){if(!this.clickMaskUp(this.getID())){var _1=this.Super("showClickMask",arguments);if(this.formItem){var _2=this.formItem.form,_3=isc.EH.clickMaskRegistry.find("ID",_1);if(_3.$li)_3.$li=null}}},isc.A.getCellCSSText=function isc_PickListMenu_getCellCSSText(_1,_2,_3){if(this.selection!=null&&_1==this.selection.getSelectedRecord()){var _4=[];if(this.hiliteColor!=null)
(0067342)
adrianromero (manager)
2014-05-21 18:00

It is supposed that in IE8 if configured to "IE8 Compatibility Mode" it will fail too.
(0067344)
shuehner (administrator)
2014-05-21 18:17

Hi, activating Compatibility View in IE8 (on an XP vm) i can reproduce some js error Using that steps above.
Some JS error is raised as it seems to be calling a function of 'undefined'.
(0067370)
dbaz (developer)
2014-05-22 16:10

The problem with the issue is that, at least in the case described in "Steps to reproduce", the "value" is a string, and this:

https://code.openbravo.com/erp/devel/pi/rev/6b80b8d83087d03767b9fa658b2662923e63ed3b#l2.34 [^]

fails in IE7.

In fact, at least for this case (where 'value' is a string), the code doesn't make any sense. I don't know if there could be cases where "value" be an array os strings.

Offtopic: Surrounding this code, there are several double quotes " that should be single quotes '
(0067373)
hgbot (developer)
2014-05-22 17:10

Repository: erp/devel/pi
Changeset: 1cbe9f023742a2bc78a8b1bac1106106924145b2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu May 22 16:57:06 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1cbe9f023742a2bc78a8b1bac1106106924145b2 [^]

related to issue 26645, related to issue 24574: clean up

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-list.js
---
(0067375)
hgbot (developer)
2014-05-22 17:10

Repository: erp/devel/pi
Changeset: c93fd134778b9a502159d24c011ae8ea436325b0
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu May 22 17:09:58 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c93fd134778b9a502159d24c011ae8ea436325b0 [^]

fixed bug 26645: can't select element in drop down using IE7

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-list.js
---
(0067376)
alostale (developer)
2014-05-22 17:11

The problem was caused because in IE7 this Javascript return undefined: 'abc'[0]
whereas in other versions and browsers 'abc'[0] returns 'a'
(0067386)
shankarb (developer)
2014-05-22 18:17

Code reviewed and verified in pi changeset 45027ccc1bbd.
(0067394)
hudsonbot (developer)
2014-05-23 07:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d0b934adf82b [^]
Maturity status: Test
(0067396)
hudsonbot (developer)
2014-05-23 07:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d0b934adf82b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-21 14:13 umartirena New Issue
2014-05-21 14:13 umartirena Assigned To => AugustoMauch
2014-05-21 14:13 umartirena Web browser => Internet Explorer
2014-05-21 14:13 umartirena Modules => Core
2014-05-21 14:13 umartirena Triggers an Emergency Pack => No
2014-05-21 17:59 adrianromero Note Added: 0067341
2014-05-21 18:00 adrianromero Note Added: 0067342
2014-05-21 18:14 shuehner Issue Monitored: shuehner
2014-05-21 18:17 shuehner Note Added: 0067344
2014-05-22 16:10 dbaz Web browser Internet Explorer => Internet Explorer
2014-05-22 16:10 dbaz Regression level => Production - Confirmed Stable
2014-05-22 16:10 dbaz Regression date => 2013-08-30
2014-05-22 16:10 dbaz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/6b80b8d83087d03767b9fa658b2662923e63ed3b [^]
2014-05-22 16:10 dbaz Note Added: 0067370
2014-05-22 16:10 dbaz Assigned To AugustoMauch => shankarb
2014-05-22 16:46 alostale Assigned To shankarb => alostale
2014-05-22 16:47 alostale Relationship added has duplicate 0024574
2014-05-22 16:47 alostale Relationship replaced related to 0024574
2014-05-22 16:47 alostale Review Assigned To => dbaz
2014-05-22 16:47 alostale Web browser Internet Explorer => Internet Explorer
2014-05-22 17:10 hgbot Checkin
2014-05-22 17:10 hgbot Note Added: 0067373
2014-05-22 17:10 hgbot Checkin
2014-05-22 17:10 hgbot Note Added: 0067375
2014-05-22 17:10 hgbot Status new => resolved
2014-05-22 17:10 hgbot Resolution open => fixed
2014-05-22 17:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c93fd134778b9a502159d24c011ae8ea436325b0 [^]
2014-05-22 17:11 alostale Note Added: 0067376
2014-05-22 18:17 shankarb Review Assigned To dbaz => shankarb
2014-05-22 18:17 shankarb Note Added: 0067386
2014-05-22 18:17 shankarb Status resolved => closed
2014-05-22 18:17 shankarb Fixed in Version => pi
2014-05-23 07:24 hudsonbot Checkin
2014-05-23 07:24 hudsonbot Note Added: 0067394
2014-05-23 07:24 hudsonbot Checkin
2014-05-23 07:24 hudsonbot Note Added: 0067396
2014-10-01 16:43 plujan Web browser Internet Explorer => Internet Explorer
2014-10-01 16:43 plujan Regression introduced in release => 3.0MP27


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker