Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026412
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-04-29 11:462014-05-07 18:12
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisionbdc2ec814d75
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP31.2SCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-12-20
Regression introduced in release
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/b718b3ee2462bdd381bc76b332a779e3d8ecbe3d [^]
Triggers an Emergency PackNo
Summary

0026412: Property fields based on computed columns with a FK fail

DescriptionHaving a computed column which is a FK to another entity. if a property column is defined to show any property of that FK entity, it fails.

In authorize.net module there are examples for this in Payment In > Lines tab. Ex.:

_computedColumns.obautnFinPaymentScheduledetail.active

Steps To Reproduce- Install authorize.net module
- Go to Payment In window, select a record
- Go to Lines -> Error appears
TagsNo tags attached.
Attached Filespng file icon error.png [^] (29,514 bytes) 2014-04-29 11:46

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0024495 closedalostale Lazy computed columns API chage 
related to defect 00252483.0MP31 closedalostale Error after sorting by a computed column 
related to defect 0026432 closedalostale can't select a computed column for a property field. 

-  Notes
(0066712)
hgbot (developer)
2014-04-30 15:50

Repository: erp/devel/pi
Changeset: cc9011c7b09ff1cefd032f2616db3ae0e4404e60
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 30 15:48:32 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cc9011c7b09ff1cefd032f2616db3ae0e4404e60 [^]

fixed bug 26412: property fields based on computed columns with a FK fail

  property fields (sent to backend as additionalProperties) failed because an extra
  unneeded join to _computedColumns was performed

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0066714)
alostale (developer)
2014-04-30 15:51

Tested again all cases defined in 0025248
(0066779)
AugustoMauch (developer)
2014-05-02 09:32

Wrong if condition:

 if (true || !result.isProxy()) {
(0066788)
hgbot (developer)
2014-05-02 12:13

Repository: erp/devel/pi
Changeset: bdc2ec814d75ecd4892096c7d9cda96a86b63bb8
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri May 02 12:03:07 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bdc2ec814d75ecd4892096c7d9cda96a86b63bb8 [^]

Fixes issue 26412: Removes code that was meant just for debugging

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0066789)
AugustoMauch (developer)
2014-05-02 12:16

Code reviewed and verified in pi@bdc2ec814d75
(0066988)
hudsonbot (developer)
2014-05-07 18:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0066993)
hudsonbot (developer)
2014-05-07 18:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-04-29 11:46 caristu New Issue
2014-04-29 11:46 caristu Assigned To => AugustoMauch
2014-04-29 11:46 caristu File Added: error.png
2014-04-29 11:46 caristu Modules => Core
2014-04-29 11:46 caristu Triggers an Emergency Pack => No
2014-04-29 11:46 caristu Issue Monitored: networkb
2014-04-29 11:47 caristu Regression level => Production - Confirmed Stable
2014-04-29 11:47 caristu Relationship added related to 0024495
2014-04-29 11:50 caristu Summary Property field based on computed columns are not working => Property field based on computed columns are not working using the new API
2014-04-29 11:50 caristu Description Updated View Revisions
2014-04-29 11:58 caristu Summary Property field based on computed columns are not working using the new API => Property fields based on computed columns are not working using the new API
2014-04-29 12:10 caristu Severity major => critical
2014-04-30 09:06 caristu Severity critical => minor
2014-04-30 15:38 alostale Review Assigned To => AugustoMauch
2014-04-30 15:38 alostale Regression date => 2013-12-20
2014-04-30 15:38 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/b718b3ee2462bdd381bc76b332a779e3d8ecbe3d [^]
2014-04-30 15:38 alostale Summary Property fields based on computed columns are not working using the new API => Property fields based on computed columns with a FK fail
2014-04-30 15:38 alostale Description Updated View Revisions
2014-04-30 15:38 alostale Steps to Reproduce Updated View Revisions
2014-04-30 15:38 alostale Relationship added related to 0025248
2014-04-30 15:43 alostale Relationship added related to 0026432
2014-04-30 15:46 alostale Assigned To AugustoMauch => alostale
2014-04-30 15:50 hgbot Checkin
2014-04-30 15:50 hgbot Note Added: 0066712
2014-04-30 15:50 hgbot Status new => resolved
2014-04-30 15:50 hgbot Resolution open => fixed
2014-04-30 15:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cc9011c7b09ff1cefd032f2616db3ae0e4404e60 [^]
2014-04-30 15:51 alostale Note Added: 0066714
2014-05-02 09:32 AugustoMauch Note Added: 0066779
2014-05-02 09:32 AugustoMauch Status resolved => new
2014-05-02 09:32 AugustoMauch Resolution fixed => open
2014-05-02 12:13 hgbot Checkin
2014-05-02 12:13 hgbot Note Added: 0066788
2014-05-02 12:13 hgbot Status new => resolved
2014-05-02 12:13 hgbot Resolution open => fixed
2014-05-02 12:13 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/cc9011c7b09ff1cefd032f2616db3ae0e4404e60 [^] => http://code.openbravo.com/erp/devel/pi/rev/bdc2ec814d75ecd4892096c7d9cda96a86b63bb8 [^]
2014-05-02 12:16 AugustoMauch Note Added: 0066789
2014-05-02 12:16 AugustoMauch Status resolved => closed
2014-05-02 12:16 AugustoMauch Fixed in Version => PR14Q2
2014-05-07 18:12 hudsonbot Checkin
2014-05-07 18:12 hudsonbot Note Added: 0066988
2014-05-07 18:12 hudsonbot Checkin
2014-05-07 18:12 hudsonbot Note Added: 0066993


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker