Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026383
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-04-25 11:122015-03-06 12:23
ReporterAugustoMauchView Statuspublic 
Assigned Toinigosanchez 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisionf512f9736b7e
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026383: If the delete toolbar button is pushed in the tree grid view, the deleted record is the one selected in the standard grid view.

DescriptionIf the delete toolbar button is pushed in the tree grid view, the deleted record is the one selected in the standard grid view.
Steps To ReproduceAs F&B Admin:
- Open the Assets window
- Create two assets, one named '1' and one named '2'.
- Make sure no records are selected in the standard grid view
- Open the tree grid view
- Click on the node '1'. The delete toolbar button is not enabled, this is wrong.
- Go back to the standard grid view. Select the node '2'.
- Open the tree grid view, select the node '1', click on the delete toolbar button and refresh.
- The node '2' has been deleted, this is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 00259063.0PR14Q2 closedAugustoMauch Tree Extension Project 
has duplicate defect 0029163 closedAugustoMauch The new and save button disabled on a child tab when using the tree mode on the header if it has been opened without selection 
related to defect 0036611 closedinigosanchez 2nd attempt to 'Delete row' after first delete was stopped does not work and shows 'Deleting ...' forever 
blocks defect 00263843.0PR14Q4 closedinigosanchez The tree grid view is not refreshed after deleting a record 

-  Notes
(0069958)
hgbot (developer)
2014-09-04 10:59

Repository: erp/devel/pi
Changeset: f512f9736b7ec1c3b847e5529803dee3121896de
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Sep 04 10:57:16 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f512f9736b7ec1c3b847e5529803dee3121896de [^]

Fixes issue 26383: If the delete toolbar button is pushed in treeGridView, selected record is not delete properly.

It has been solved by controlling the current view: tree grid view or grid view. Now, it can be possible delete in tree
grid view in normal way.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0069960)
hgbot (developer)
2014-09-04 12:52

Repository: erp/devel/pi
Changeset: 37e6593b3db7167f5b27bd60baa77120ccf28370
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Sep 04 12:51:59 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/37e6593b3db7167f5b27bd60baa77120ccf28370 [^]

Related to issue 26383: Prevents jslint error

The currentGrid attribute was being used without being previously defined.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0069985)
hudsonbot (developer)
2014-09-05 14:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/31b085cc025e [^]
Maturity status: Test
(0069986)
hudsonbot (developer)
2014-09-05 14:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/31b085cc025e [^]
Maturity status: Test
(0070025)
AugustoMauch (developer)
2014-09-08 18:34

Code reviewed and verified in pi@4e439ac1ded2

- Issue History
Date Modified Username Field Change
2014-04-25 11:12 AugustoMauch New Issue
2014-04-25 11:12 AugustoMauch Assigned To => AugustoMauch
2014-04-25 11:12 AugustoMauch Modules => Core
2014-04-25 11:12 AugustoMauch Triggers an Emergency Pack => No
2014-04-25 11:18 AugustoMauch Relationship added blocks 0026384
2014-06-20 12:34 alostale Target Version => PR14Q4
2014-09-04 10:47 inigosanchez Assigned To AugustoMauch => inigosanchez
2014-09-04 10:58 inigosanchez Issue Monitored: AugustoMauch
2014-09-04 10:59 inigosanchez Review Assigned To => AugustoMauch
2014-09-04 10:59 hgbot Checkin
2014-09-04 10:59 hgbot Note Added: 0069958
2014-09-04 10:59 hgbot Status new => resolved
2014-09-04 10:59 hgbot Resolution open => fixed
2014-09-04 10:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f512f9736b7ec1c3b847e5529803dee3121896de [^]
2014-09-04 12:52 hgbot Checkin
2014-09-04 12:52 hgbot Note Added: 0069960
2014-09-05 14:52 hudsonbot Checkin
2014-09-05 14:52 hudsonbot Note Added: 0069985
2014-09-05 14:52 hudsonbot Checkin
2014-09-05 14:52 hudsonbot Note Added: 0069986
2014-09-08 18:34 AugustoMauch Note Added: 0070025
2014-09-08 18:34 AugustoMauch Status resolved => closed
2014-09-08 18:34 AugustoMauch Fixed in Version => 3.0PR14Q4
2015-03-06 11:08 AugustoMauch Relationship added has duplicate 0029163
2015-03-06 12:22 AugustoMauch Relationship added has duplicate 0029166
2015-03-06 12:23 AugustoMauch Relationship added caused by 0025906
2017-09-12 10:17 alostale Relationship added related to 0036611


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker