Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026231
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalhave not tried2014-04-09 22:062014-05-07 18:11
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision983d21838275
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026231: Auxiliary Inputs are not being computed in the Tree Grid View

DescriptionWhen a record is selected in the tree grid view, its auxiliary inputs and session attributes are not being computed. This means that if there are subtabs with display logic that uses these attributes, the display logic is not going to work
Steps To Reproduce- Create this auxiliary input for the header tab of the Organization window:
   * Name: TestAuxiliaryInput
   * Validation Code: @SQL=SELECT ad_org_id FROM ad_org WHERE ad_org_id=@AD_ORG_ID@
- Adds this display logic to the Period tab of the organization window:
   * Display Logic: @TestAuxiliaryInput@='B843C30461EA4501935CB1D125C9C25A'
With this display logic, the Period Tab should only be shown if the 'F&B EspaƱa, S.A' organization is selected.
- Check that the display logic works if the record is selected in the standard grid view, but not in the tree grid view.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0066286)
hgbot (developer)
2014-04-09 22:17

Repository: erp/devel/pi
Changeset: bf51ff460dc8bebae81a10d58c39b60b38b1674c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Apr 09 22:15:13 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bf51ff460dc8bebae81a10d58c39b60b38b1674c [^]

Fixes issue 26231: Auxiliary Inputs are not computed in the Tree Grid View

Now when a record is selected in the tree grid view, the toolBar.updateButtonState() is called. This results in a FIC call in SETSESSION mode, that loads the auxiliary inputs and session attributes.

Also some changes have been done to ensure that if the tree grid view is shown, its selected record is used instead of the record selected in the standard grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0066333)
hgbot (developer)
2014-04-10 18:42

Repository: erp/devel/pi
Changeset: b72329997994bd2c527e2dc228b79f5d44dfaadc
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Apr 10 18:41:31 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b72329997994bd2c527e2dc228b79f5d44dfaadc [^]

Related to issue 26231: getParentRecord returns the proper record

The getParentRecord was returning the record selected in the standard grid view of the parent tab, even if it was showing the tree view grid. This resulted in that if the subtab had only one record, the tab display logic was not working properly.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0066413)
shankarb (developer)
2014-04-15 09:41

Code reviewed and verified in pi changeset 4bce276a5b06
(0066422)
AugustoMauch (manager)
2014-04-15 10:53

Reopened because it is not working. This error is shown in the console instead of calling the FIC to retrieve the auxiliary inputs:

 Cannot call method 'updateButtonState' of undefined
(0066446)
hgbot (developer)
2014-04-15 13:36

Repository: erp/devel/pi
Changeset: 983d21838275810b0433b345e72e75a941bb27bd
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Apr 15 13:34:54 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/983d21838275810b0433b345e72e75a941bb27bd [^]

Fixes issue 26231: Fixes bug that provoked a js error before calling the FIC

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0066468)
shankarb (developer)
2014-04-15 21:33

Code reviewed and verified in pi changeset c25c56618b6d.
(0066910)
hudsonbot (developer)
2014-05-07 18:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0066921)
hudsonbot (developer)
2014-05-07 18:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0066935)
hudsonbot (developer)
2014-05-07 18:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-04-09 22:06 AugustoMauch New Issue
2014-04-09 22:06 AugustoMauch Assigned To => AugustoMauch
2014-04-09 22:06 AugustoMauch Modules => Core
2014-04-09 22:06 AugustoMauch Triggers an Emergency Pack => No
2014-04-09 22:06 AugustoMauch Issue Monitored: shankarb
2014-04-09 22:07 AugustoMauch Review Assigned To => shankarb
2014-04-09 22:17 hgbot Checkin
2014-04-09 22:17 hgbot Note Added: 0066286
2014-04-09 22:17 hgbot Status new => resolved
2014-04-09 22:17 hgbot Resolution open => fixed
2014-04-09 22:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bf51ff460dc8bebae81a10d58c39b60b38b1674c [^]
2014-04-10 18:42 hgbot Checkin
2014-04-10 18:42 hgbot Note Added: 0066333
2014-04-15 09:41 shankarb Note Added: 0066413
2014-04-15 09:41 shankarb Status resolved => closed
2014-04-15 09:41 shankarb Fixed in Version => PR14Q2
2014-04-15 10:53 AugustoMauch Note Added: 0066422
2014-04-15 10:53 AugustoMauch Status closed => new
2014-04-15 10:53 AugustoMauch Resolution fixed => open
2014-04-15 10:53 AugustoMauch Fixed in Version PR14Q2 =>
2014-04-15 13:36 hgbot Checkin
2014-04-15 13:36 hgbot Note Added: 0066446
2014-04-15 13:36 hgbot Status new => resolved
2014-04-15 13:36 hgbot Resolution open => fixed
2014-04-15 13:36 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/bf51ff460dc8bebae81a10d58c39b60b38b1674c [^] => http://code.openbravo.com/erp/devel/pi/rev/983d21838275810b0433b345e72e75a941bb27bd [^]
2014-04-15 21:33 shankarb Note Added: 0066468
2014-04-15 21:33 shankarb Status resolved => closed
2014-04-15 21:33 shankarb Fixed in Version => PR14Q2
2014-05-07 18:11 hudsonbot Checkin
2014-05-07 18:11 hudsonbot Note Added: 0066910
2014-05-07 18:11 hudsonbot Checkin
2014-05-07 18:11 hudsonbot Note Added: 0066921
2014-05-07 18:11 hudsonbot Checkin
2014-05-07 18:11 hudsonbot Note Added: 0066935


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker