Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025773
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-02-19 18:102014-03-03 10:00
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchpiFixed in SCM revisionac5a01fde1a7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP28.5SCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-07-19
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7d6d644b9b9e3b9ca55c7be357af7bb86a257263 [^]
Triggers an Emergency PackNo
Summary

0025773: Error thrown in web services if the request includes a field that references a computed column

DescriptionThe following error is thrown when trying to create a new business entity and if we include in the request a field that references a computed column (attached is an example):

<ob:error xmlns:ob="http://www.openbravo.com"><message>org.openbravo.service.web.InvalidContentException: [^] Exception when parsing entity MaterialMgmtShipmentInOut (null):null
Caused by: Exception when parsing entity EntityName (null):null</message></ob:error>

Steps To ReproduceIn description
TagsNo tags attached.
Attached Filesxml file icon ws.xml [^] (2,605 bytes) 2014-02-19 18:12

- Relationships Relation Graph ] Dependency Graph ]
duplicate of design defect 00241043.0MP27 closedalostale Unnecessary evaluation of computed columns 
related to defect 0025862 closedalostale get_computedColumns() method returns null under some circumstances 
related to defect 0036624 closedplatform Error thrown in web services if the URL includes a where parameter that references a computed column 

-  Notes
(0064457)
hgbot (developer)
2014-02-20 17:20

Repository: erp/devel/pi
Changeset: ac5a01fde1a7b212090eec0fae96562b6f24d806
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Feb 20 17:19:02 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ac5a01fde1a7b212090eec0fae96562b6f24d806 [^]

fixed bug 25773: error in xml REST ws when adding a row with a computed column

---
M src/org/openbravo/dal/xml/XMLEntityConverter.java
---
(0064470)
hudsonbot (developer)
2014-02-21 00:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/75835cd7cac8 [^]
Maturity status: Test
(0064471)
hgbot (developer)
2014-02-21 08:57

Repository: erp/devel/pi
Changeset: ec0c56f1c84757693a4eabcaf5f61c6c4cc8a1d8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Feb 21 08:56:43 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ec0c56f1c84757693a4eabcaf5f61c6c4cc8a1d8 [^]

related to issue 25773: added test cases to cover the issue using XML and JSON

---
M src-test/org/openbravo/test/AllWebserviceTests.java
M src-test/org/openbravo/test/webservice/BaseWSTest.java
A src-test/org/openbravo/test/webservice/WSAddRecordWithComputedColumns.java
---
(0064472)
alostale (developer)
2014-02-21 08:59

Test plan: check it is possible to insert records that include computed columns in their request content using both XML and JSON web services.

Test plan automatized using jUnit: src-test/org/openbravo/test/webservice/WSAddRecordWithComputedColumns.java
(0064495)
dmitry_mezentsev (developer)
2014-02-21 16:27

Asier,

Could you update Regression fields please?
(0064498)
hudsonbot (developer)
2014-02-21 16:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b309487a3fb6 [^]
Maturity status: Test
(0064501)
alostale (developer)
2014-02-21 16:54

Regression present since mp27
(0064564)
shankarb (developer)
2014-02-25 14:03

Code reviewed and tested in pi changeset 7feaacbc88b1.
(0064711)
alostale (developer)
2014-03-03 09:59

Downgraded severity to minor:

The walkaround to this issue would be not including in the property field in the XML. It does not make any sense to include them in PUT/POST operations, because all property fields are read only.

- Issue History
Date Modified Username Field Change
2014-02-19 18:10 caristu New Issue
2014-02-19 18:10 caristu Assigned To => AugustoMauch
2014-02-19 18:10 caristu Modules => Core
2014-02-19 18:10 caristu Triggers an Emergency Pack => No
2014-02-19 18:10 caristu Regression level => Production - Confirmed Stable
2014-02-19 18:11 caristu Issue Monitored: networkb
2014-02-19 18:12 caristu File Added: ws.xml
2014-02-19 18:13 caristu version 3.0MP30.3 => 3.0MP28.5
2014-02-20 15:45 alostale Assigned To AugustoMauch => alostale
2014-02-20 17:19 alostale Review Assigned To => shankarb
2014-02-20 17:20 hgbot Checkin
2014-02-20 17:20 hgbot Note Added: 0064457
2014-02-20 17:20 hgbot Status new => resolved
2014-02-20 17:20 hgbot Resolution open => fixed
2014-02-20 17:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ac5a01fde1a7b212090eec0fae96562b6f24d806 [^]
2014-02-21 00:45 hudsonbot Checkin
2014-02-21 00:45 hudsonbot Note Added: 0064470
2014-02-21 08:57 hgbot Checkin
2014-02-21 08:57 hgbot Note Added: 0064471
2014-02-21 08:59 alostale Note Added: 0064472
2014-02-21 16:27 dmitry_mezentsev Note Added: 0064495
2014-02-21 16:28 hudsonbot Checkin
2014-02-21 16:28 hudsonbot Note Added: 0064498
2014-02-21 16:52 alostale Status resolved => new
2014-02-21 16:52 alostale Resolution fixed => open
2014-02-21 16:53 alostale Regression date => 2013-07-19
2014-02-21 16:53 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7d6d644b9b9e3b9ca55c7be357af7bb86a257263 [^]
2014-02-21 16:53 alostale Status new => scheduled
2014-02-21 16:53 alostale fix_in_branch => pi
2014-02-21 16:53 alostale Status scheduled => resolved
2014-02-21 16:53 alostale Resolution open => fixed
2014-02-21 16:54 alostale Note Added: 0064501
2014-02-25 14:03 shankarb Note Added: 0064564
2014-02-25 14:03 shankarb Status resolved => closed
2014-02-25 14:03 shankarb Fixed in Version => 3.0MP32
2014-03-03 09:57 alostale Status closed => new
2014-03-03 09:57 alostale Resolution fixed => open
2014-03-03 09:58 alostale Fixed in Version 3.0MP32 =>
2014-03-03 09:58 alostale Relationship added related to 0025862
2014-03-03 09:59 alostale Relationship added duplicate of 0024104
2014-03-03 09:59 alostale Note Added: 0064711
2014-03-03 09:59 alostale Severity major => minor
2014-03-03 09:59 alostale fix_in_branch pi =>
2014-03-03 10:00 alostale Status new => scheduled
2014-03-03 10:00 alostale fix_in_branch => pi
2014-03-03 10:00 alostale Status scheduled => resolved
2014-03-03 10:00 alostale Resolution open => fixed
2014-03-03 10:00 alostale Status resolved => closed
2014-03-03 10:00 alostale Fixed in Version => 3.0MP32
2017-08-08 11:28 JONHM Relationship added related to 0036624


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker