Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025278
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-12-05 11:022015-05-28 01:10
ReporteregoitzView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionf89eff26d185
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025278: Long time to update a warehouse if it has thousends of locators

DescriptionON an environment with 60.000 locators for one of the warehouse, when updating a field of the warehouse it takes a long time to save the record
Steps To Reproduce-Create 60.000 locators for one of the warehouses.
-Access to the application and go to the warehouse window
-Open the warehouse where you have created the locators on form view.
-Change the description and save.
*It takes many seconds (around 40) to finish the saving.

TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0029947 acknowledgedplatform Wrong query launched when OBDal.getInstance.getSession.refresh(Object) 

-  Notes
(0077610)
jorge-garcia (developer)
2015-05-21 09:35

Test Plan

-Create 60.000 locators for one of the warehouses.
-Access to the application and go to the warehouse window
-Open the warehouse where you have created the locators on form view.
-Change the description and save.
* These performance improved has two parts (see related issue)
(0077829)
vmromanos (developer)
2015-05-27 17:11

Performance results can be found at https://docs.google.com/spreadsheets/d/1U7UPXZ8DXRVVgEVW19k7QOZVbGoVP_VHmGn_vaqcyLk/edit?usp=sharing [^] (from 23 seconds to 0)

Note that the issue 0029947 still heavily affects performance
(0077830)
hgbot (developer)
2015-05-27 17:15

Repository: erp/devel/pi
Changeset: f89eff26d1859e13fd9c86ed597bd4696963b36a
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed May 20 18:17:08 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f89eff26d1859e13fd9c86ed597bd4696963b36a [^]

Fixed issue 25278: Long time to update a warehouse with thousends of locators

On an environment with 60.000 locators for one of the warehouse, when updating
a field of the warehouse it takes a long time to save the record.

Part of the problem is the update of the m_warehouse table. When updated, the
trigger launch an update of the organization id for M_LOCATOR and
M_WAREHOUSE_ACCT tables.

The solution is to check if the organization has changed and, if not, avoid the
unnecessary update of those tables.

---
M src-db/database/model/triggers/M_WAREHOUSE_TRG.xml
---
(0077831)
hgbot (developer)
2015-05-27 17:15

Repository: erp/devel/pi
Changeset: ef5da8dc7f3847819dea9a18de03250c4d46f35a
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed May 27 17:14:52 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ef5da8dc7f3847819dea9a18de03250c4d46f35a [^]

Related to issue 25278: updated copyright and fixed indentation

---
M src-db/database/model/triggers/M_WAREHOUSE_TRG.xml
---
(0077832)
vmromanos (developer)
2015-05-27 17:17

Code review + testing OK
(0077847)
hudsonbot (developer)
2015-05-28 01:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae25da3bd47f [^]
Maturity status: Test
(0077848)
hudsonbot (developer)
2015-05-28 01:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae25da3bd47f [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-12-05 11:02 egoitz New Issue
2013-12-05 11:02 egoitz Assigned To => AugustoMauch
2013-12-05 11:02 egoitz Modules => Core
2013-12-05 11:02 egoitz Triggers an Emergency Pack => No
2014-01-14 13:52 alostale Tag Attached: Performance
2014-01-14 13:52 alostale Assigned To AugustoMauch => dmiguelez
2014-01-15 09:00 shuehner Issue Monitored: shuehner
2014-01-24 14:53 dmiguelez Assigned To dmiguelez => jonalegriaesarte
2014-03-12 10:42 jonalegriaesarte Regression date => 2014-03-20
2014-03-12 13:40 jonalegriaesarte Regression date 2014-03-20 =>
2014-03-13 12:43 jonalegriaesarte Assigned To jonalegriaesarte => egoitz
2014-09-22 16:36 jonalegriaesarte Target Version => 3.0PR15Q1
2014-09-22 16:37 jonalegriaesarte Target Version 3.0PR15Q1 => 3.0PR14Q4
2014-09-29 16:12 jonalegriaesarte Target Version 3.0PR14Q4 => 3.0PR15Q1
2014-12-22 12:50 jonalegriaesarte Target Version 3.0PR15Q1 => 3.0PR15Q2
2015-03-13 10:33 jonalegriaesarte Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-05-13 09:50 egoitz Assigned To egoitz => Triage Finance
2015-05-20 10:50 jorge-garcia Status new => scheduled
2015-05-20 10:50 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-05-20 17:56 jorge-garcia Relationship added related to 0029947
2015-05-21 09:35 jorge-garcia Note Added: 0077610
2015-05-27 17:11 vmromanos Note Added: 0077829
2015-05-27 17:15 hgbot Checkin
2015-05-27 17:15 hgbot Note Added: 0077830
2015-05-27 17:15 hgbot Status scheduled => resolved
2015-05-27 17:15 hgbot Resolution open => fixed
2015-05-27 17:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f89eff26d1859e13fd9c86ed597bd4696963b36a [^]
2015-05-27 17:15 hgbot Checkin
2015-05-27 17:15 hgbot Note Added: 0077831
2015-05-27 17:17 vmromanos Review Assigned To => vmromanos
2015-05-27 17:17 vmromanos Note Added: 0077832
2015-05-27 17:17 vmromanos Status resolved => closed
2015-05-28 01:10 hudsonbot Checkin
2015-05-28 01:10 hudsonbot Note Added: 0077847
2015-05-28 01:10 hudsonbot Checkin
2015-05-28 01:10 hudsonbot Note Added: 0077848


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker