Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025158
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-11-14 14:372013-12-22 19:41
ReporterjonalegriaesarteView Statuspublic 
Assigned Todbaz 
PrioritynormalResolutionfixedFixed in Version3.0MP31
StatusclosedFix in branchFixed in SCM revisiona0194e74f446
ProjectionnoneETAnoneTarget Version3.0MP31
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-02-15
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/57378b7ff2bd [^]
Triggers an Emergency PackNo
Summary

0025158: Uploaded image cannot be deleted

DescriptionIf in a record with image reference, you upload an image, you cannot delete it in the record
Steps To Reproduce    As "Openbravo Admin"
* Go to "Product" window
* Select any existing record (in form view)
* Click in the "upload" button of the image
* Upload any file
* Save the record
* Close the record (go back to grid mode)
* Open again the record in form view
* Click the delete button of the image input
* Save the record
* Close the record (go back to grid mode)
* Open again the record in form view

The image is still there.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0023600 acknowledgedplatform Image selector is not properly updated/cleared when organization field changes 
has duplicate defect 0023599 closedAugustoMauch Uploaded image cannot be deleted 
related to defect 00262533.0PR14Q3 closedguillermogil Trash button in product window, image field is not removing the image from database 

-  Notes
(0063035)
dbaz (developer)
2013-12-20 22:55
edited on: 2013-12-20 22:59

The following changeset:

https://code.openbravo.com/erp/devel/pi/rev/57378b7ff2bd [^]

indirectly caused this issue.

The point is that when an image is deleted, the image selector internal value becomes "undefined" and then, due to this line:

https://code.openbravo.com/erp/devel/pi/file/57378b7ff2bd/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js#l254 [^]

in this function

https://code.openbravo.com/erp/devel/pi/file/57378b7ff2bd/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js#l863 [^]

This "null" value was converted to ''

Since the 19684 changeset, this doesn't happen anymore, since the original object never reach the OB.Utilities.fixNull250 function but a clone.

The fix to this issue is just ensure that if the image is deleted, the image selector internal value is '' instead of "undefined"

(0063036)
hgbot (developer)
2013-12-20 23:01

Repository: erp/devel/pi
Changeset: a0194e74f44635dba9cb6661f0daa101c0f2a1b5
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Fri Dec 20 23:00:59 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a0194e74f44635dba9cb6661f0daa101c0f2a1b5 [^]

Fixed issue 25158: Now 'images' can be deleted again in form view

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0063042)
hudsonbot (developer)
2013-12-21 09:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a0194e74f446 [^]

Maturity status: Test
(0063046)
AugustoMauch (developer)
2013-12-22 19:41

Code reviewed and verified in pi@a0194e74f446

- Issue History
Date Modified Username Field Change
2013-11-14 14:37 jonalegriaesarte New Issue
2013-11-14 14:37 jonalegriaesarte Assigned To => AugustoMauch
2013-11-14 14:37 jonalegriaesarte Modules => Core
2013-11-14 14:37 jonalegriaesarte Triggers an Emergency Pack => No
2013-11-14 14:38 jonalegriaesarte Relationship added has duplicate 0023599
2013-11-14 14:38 jonalegriaesarte Relationship added related to 0023600
2013-12-19 09:13 alostale Assigned To AugustoMauch => dbaz
2013-12-20 22:09 dbaz Regression level => Production - Confirmed Stable
2013-12-20 22:09 dbaz Regression date => 2013-02-15
2013-12-20 22:09 dbaz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/57378b7ff2bd [^]
2013-12-20 22:55 dbaz Note Added: 0063035
2013-12-20 22:59 dbaz Note Edited: 0063035 View Revisions
2013-12-20 23:01 hgbot Checkin
2013-12-20 23:01 hgbot Note Added: 0063036
2013-12-20 23:01 hgbot Status new => resolved
2013-12-20 23:01 hgbot Resolution open => fixed
2013-12-20 23:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a0194e74f44635dba9cb6661f0daa101c0f2a1b5 [^]
2013-12-21 09:38 hudsonbot Checkin
2013-12-21 09:38 hudsonbot Note Added: 0063042
2013-12-22 19:41 AugustoMauch Review Assigned To => AugustoMauch
2013-12-22 19:41 AugustoMauch Note Added: 0063046
2013-12-22 19:41 AugustoMauch Status resolved => closed
2013-12-22 19:41 AugustoMauch Fixed in Version => 3.0MP31
2014-04-11 13:35 AugustoMauch Relationship added related to 0026253


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker