Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025127
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2013-11-11 18:262020-06-24 09:17
ReportershuehnerView Statuspublic 
Assigned Tocberner 
PrioritynormalResolutionfixedFixed in VersionPR20Q3
StatusclosedFix in branchFixed in SCM revision257c9c196011
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025127: When updating core files removes in the 'referencedata' folder by the update are not removing in the instance

DescriptionWhen installing a core update via the MMC then first the old core-files backed up and then the old-core files are deleted before the new files are unpacked.
By this files deleted in the updated core are deleted from the instance.

However files in the 'referencedata' subfolder are not deleted by this process as that folder is missing in the hard-coded list of folders in the ModuleUtiltiy.getCore function.

Impact: with the new sampledata work pushed a few mp's back this means that the 2 big (100mb in total) old referencedata.xml files are not deleted on updated.

That makes every install 100mb bigger and also puts that useless weight into every backup.
Steps To ReproduceInstall 3.0MP25 which contains old sampledata impl.
Updated via MMC to at least 3.0MP26
Check that the two xml files directly in the referencedata/sampledata folder have not been deleted.
They should have been deleted, as they are not in the new core obx.
Proposed SolutionExtend getCore function to also include the referencedata folder.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0065427)
alostale (developer)
2014-03-25 14:21

directory missing in ModuleUtility.getCore method
(0065428)
shuehner (administrator)
2014-03-25 14:59

Open items:
- import/export client use referencedata folder also. so userdata may be present. Could be handled by restricting deletion to referencedata/sampledata & referencedata/standard
- export sampledata/import-sampledata user may have run that and have files in referencedata/sampledata should those be deleted? or not?
 Maybe restrict to the 4 known files/folders in sampledata which are present in the distribution and just delete those?
(0120738)
shuehner (administrator)
2020-06-08 13:14

Updating topic as that has more bad side-effects.
Discovered in updating demo-master instance.
Which was created long time ago using only MMC to be updated + now wants a install.source run.

[importsampledata] Caused by: org.postgresql.util.PSQLException: ERROR: insert or update on table "ad_pinstance" violates foreign key constraint "ad_pinstanc
[importsampledata] Detail: Key (ad_process_id)=(800085) is not present in table "ad_process".

Failed as referencedata/sampledata still had 5 files present which were removed years ago:
-rw-r--r-- 1 openbravo openbravo 1487443 Sep 11 2015 ./FB/AD_PINSTANCE_PARA.xml
-rw-r--r-- 1 openbravo openbravo 3247649 Sep 11 2015 ./FB/AD_PINSTANCE.xml
-rw-r--r-- 1 openbravo openbravo 126742 Jul 2 2019 ./FB/FIN_RECLINE_TEMP.xml
-rw-r--r-- 1 openbravo openbravo 916 Feb 22 2018 ./QA_Testing/OBUIAPP_GC_FIELD.xml
-rw-r--r-- 1 openbravo openbravo 840 Feb 22 2018 ./QA_Testing/OBUIAPP_GC_TAB.xml

Same cause that getCore is missing those folders so any old files stays in there forever.
(0120834)
cberner (developer)
2020-06-12 15:03

Merge Request: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/86 [^]
(0120855)
hgbot (developer)
2020-06-16 08:42

Repository: erp/devel/pi
Changeset: 257c9c19601190d8b10df8b54daac21441eb5914
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Fri Jun 12 14:55:02 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/257c9c19601190d8b10df8b54daac21441eb5914 [^]

Fixes ISSUE-25127: Fixes updates via MMC with old referencedata

Adds referencedata folder to core folders, so when updating via MMC
those old files get deleted and updated correctly, not keeping old files
that generate errors in future installations.

---
M src/org/openbravo/erpCommon/modules/ModuleUtiltiy.java
---

- Issue History
Date Modified Username Field Change
2013-11-11 18:26 shuehner New Issue
2013-11-11 18:26 shuehner Assigned To => AugustoMauch
2013-11-11 18:26 shuehner Modules => Core
2013-11-11 18:26 shuehner Triggers an Emergency Pack => No
2014-03-25 14:21 alostale Note Added: 0065427
2014-03-25 14:59 shuehner Note Added: 0065428
2015-03-11 13:53 alostale Status new => acknowledged
2015-03-17 14:37 alostale Assigned To AugustoMauch => platform
2020-06-08 13:14 shuehner Note Added: 0120738
2020-06-12 15:03 cberner Assigned To platform => cberner
2020-06-12 15:03 cberner Note Added: 0120834
2020-06-16 08:19 cberner Review Assigned To => alostale
2020-06-16 08:22 cberner Status acknowledged => scheduled
2020-06-16 08:42 hgbot Checkin
2020-06-16 08:42 hgbot Note Added: 0120855
2020-06-16 08:42 hgbot Status scheduled => resolved
2020-06-16 08:42 hgbot Resolution open => fixed
2020-06-16 08:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/257c9c19601190d8b10df8b54daac21441eb5914 [^]
2020-06-24 09:17 alostale Status resolved => closed
2020-06-24 09:17 alostale Fixed in Version => 3.0PR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker