Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024954
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalrandom2013-10-16 12:512013-10-18 10:19
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP29
StatusclosedFix in branchFixed in SCM revisiondd9eab1adea0
ProjectionnoneETAnoneTarget Version3.0MP29
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2013-07-22
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f796eda7fdee3d278f41e15e16c6a6d42bd94ecb [^]
Triggers an Emergency PackNo
Summary

0024954: The insert on grid view does not work after get an error on a previous insert

DescriptionThe insert on grid view does not work after get an error on a previous insert.
That problem does not happen always.

Seems to be related with grid or window personalization.
Steps To Reproduce-Go to the Tables and Columns window
-Add a new line on grid view with this data:
   * Data package: org.openbravo.model.ad.alert
   * Name: ADAlert1
   * DB Table Name: AD_Alert1
   * Leave Java Class Name empty
- Try to save, you will get an error
- Enter ADAlert1 in the Java Class Name, and save. That will work
- Create a new record in the grid view:
   * Data package: org.openbravo.model.ad.alert
   * Name: ADAlert2
   * DB Table Name: AD_Alert2
   * Java Class Name: ADAlert2
-You will get an error
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0024863 closedAugustoMauch Not possible to save a row on grid having a window personalization 

-  Notes
(0061717)
hgbot (developer)
2013-10-16 16:04

Repository: erp/devel/pi
Changeset: dd9eab1adea06e284d6a77e9ebacf3f45a2d6d92
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 16 15:54:59 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dd9eab1adea06e284d6a77e9ebacf3f45a2d6d92 [^]

Fixes bug 24954: Inserting a new recort not working a previous insert error

The problem was that the view._savingNewRecord was not being reset after the a new record request to the datasource coming from the grid resulted in an error. Now this case in handled in the editFailed function of ob-view-grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0061764)
shankarb (developer)
2013-10-17 10:01

Code reviewed and tested in pi changeset 89268df786de.
(0061774)
hudsonbot (developer)
2013-10-17 18:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/121b38a3673a [^]

Maturity status: Test
(0061797)
AugustoMauch (developer)
2013-10-18 10:19

Note:

In order to reproduce it, you have to first set the Core module in development

- Issue History
Date Modified Username Field Change
2013-10-16 12:51 egoitz New Issue
2013-10-16 12:51 egoitz Assigned To => AugustoMauch
2013-10-16 12:51 egoitz Modules => Core
2013-10-16 12:51 egoitz Triggers an Emergency Pack => No
2013-10-16 12:52 egoitz Regression level => Production - QA Approved
2013-10-16 12:52 egoitz Regression date => 2013-07-22
2013-10-16 12:52 egoitz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f796eda7fdee3d278f41e15e16c6a6d42bd94ecb [^]
2013-10-16 12:53 egoitz Relationship added depends on 0024863
2013-10-16 15:55 AugustoMauch Issue Monitored: shankarb
2013-10-16 15:55 AugustoMauch Review Assigned To => shankarb
2013-10-16 16:03 AugustoMauch Steps to Reproduce Updated View Revisions
2013-10-16 16:04 hgbot Checkin
2013-10-16 16:04 hgbot Note Added: 0061717
2013-10-16 16:04 hgbot Status new => resolved
2013-10-16 16:04 hgbot Resolution open => fixed
2013-10-16 16:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dd9eab1adea06e284d6a77e9ebacf3f45a2d6d92 [^]
2013-10-17 10:01 shankarb Note Added: 0061764
2013-10-17 10:01 shankarb Status resolved => closed
2013-10-17 10:01 shankarb Fixed in Version => 3.0MP29
2013-10-17 18:21 hudsonbot Checkin
2013-10-17 18:21 hudsonbot Note Added: 0061774
2013-10-18 10:19 AugustoMauch Note Added: 0061797


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker