Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024848
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2013-09-30 18:052014-05-26 14:28
ReportermaiteView Statuspublic 
Assigned Topramakrishnan 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision0a17f1fe4f0c
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomaite
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024848: "Closed period" verification should not be performed when trying to process a document not configured to generate accounting

Description"Closed period" verification should not be performed when trying to process a document not configured to generate accounting
Steps To Reproduce1. Set "reconciliation" table as Not Active for posting for a General Ledger Configuration
2. Configure Financial Account for not posting Reconciliation event.
3. Close current period
4. Access Cash or Caja Financial Account, press "Reconcile" button and select any transaction of current period. Press "Reconcile" button and following error will be raised 'The reconciliation cannot be completed because it contains one or more items in a closed period.
The period of the cleared item (%s) is not open or available.'

This verification should not be performed when document is not available for accounting
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061814)
hgbot (developer)
2013-10-21 11:07

Repository: erp/devel/pi
Changeset: 7194ff6bfb769de53cbce0bad3f960a98819ca0e
Author: Pandeeswari Ramakrishnan <pandeeswari.ramakrishnan <at> openbravo.com>
Date: Wed Oct 16 20:27:37 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/7194ff6bfb769de53cbce0bad3f960a98819ca0e [^]

Fixes Issue 24848: Closed period verification should not be performed

when trying to process a document not configured to generate accounting, closed period verification should not be performed.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_ReconciliationProcess.java
---
(0061829)
hudsonbot (developer)
2013-10-21 22:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5111ac3f94f0 [^]

Maturity status: Test
(0061927)
hgbot (developer)
2013-10-29 07:19

Repository: erp/devel/pi
Changeset: e586785fbceb0ae0d833dda63ab7d10cadde7347
Author: Pandeeswari Ramakrishnan <pandeeswari.ramakrishnan <at> openbravo.com>
Date: Tue Oct 29 11:48:39 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/e586785fbceb0ae0d833dda63ab7d10cadde7347 [^]

Backout Issue 24848: Closed period verification should not be performed

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_ReconciliationProcess.java
---
(0061950)
hudsonbot (developer)
2013-10-29 17:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f1ae0e6fd033 [^]

Maturity status: Test
(0062414)
jonalegriaesarte (reporter)
2013-11-27 13:31

Issue moved to MP31, because it is quite risky and needs to be tested in depth. Anyway a workaround has been provided to the customer
(0066079)
hgbot (developer)
2014-04-02 15:43

Repository: erp/devel/pi
Changeset: 0a17f1fe4f0cae9f9fcc1b4d9fcf41b2657925fb
Author: Pandeeswari Ramakrishnan <pandeeswari.ramakrishnan <at> openbravo.com>
Date: Wed Apr 02 17:57:02 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/0a17f1fe4f0cae9f9fcc1b4d9fcf41b2657925fb [^]

Fixes Issue 24848: Closed period verification should not be performed
when trying to process a document not configured to generate accounting, closed period verification should not be performed.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/AddPaymentFromInvoice.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/AddTransaction.html
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/Reconciliation.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_TransactionProcess.java
---
(0066879)
hudsonbot (developer)
2014-05-07 18:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0067452)
jonalegriaesarte (reporter)
2014-05-26 14:28

Verified and working fine

- Issue History
Date Modified Username Field Change
2013-09-30 18:05 maite New Issue
2013-09-30 18:05 maite Assigned To => dmiguelez
2013-09-30 18:05 maite Modules => Advanced Payables and Receivables Mngmt
2013-09-30 18:05 maite Triggers an Emergency Pack => No
2013-09-30 18:05 maite Issue Monitored: networkb
2013-10-02 18:21 dmiguelez Assigned To dmiguelez => jonalegriaesarte
2013-10-03 10:19 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2013-10-21 06:07 pramakrishnan Review Assigned To => maite
2013-10-21 06:07 pramakrishnan Status new => scheduled
2013-10-21 11:07 hgbot Checkin
2013-10-21 11:07 hgbot Note Added: 0061814
2013-10-21 11:07 hgbot Status scheduled => resolved
2013-10-21 11:07 hgbot Resolution open => fixed
2013-10-21 11:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7194ff6bfb769de53cbce0bad3f960a98819ca0e [^]
2013-10-21 22:08 hudsonbot Checkin
2013-10-21 22:08 hudsonbot Note Added: 0061829
2013-10-29 07:19 hgbot Checkin
2013-10-29 07:19 hgbot Note Added: 0061927
2013-10-29 07:20 pramakrishnan Status resolved => new
2013-10-29 07:20 pramakrishnan Resolution fixed => open
2013-10-29 17:53 hudsonbot Checkin
2013-10-29 17:53 hudsonbot Note Added: 0061950
2013-10-31 13:04 maite Target Version 3.0MP29 => 3.0MP30
2013-11-19 05:31 pramakrishnan Status new => scheduled
2013-11-19 05:31 pramakrishnan fix_in_branch => pi
2013-11-27 13:31 jonalegriaesarte Note Added: 0062414
2013-11-27 13:31 jonalegriaesarte Severity major => minor
2013-11-27 13:31 jonalegriaesarte Target Version 3.0MP30 => 3.0MP31
2013-11-27 13:31 jonalegriaesarte fix_in_branch pi =>
2014-01-02 12:38 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-03-31 16:17 jonalegriaesarte Target Version PR14Q2 => PR14Q3
2014-04-02 15:43 hgbot Checkin
2014-04-02 15:43 hgbot Note Added: 0066079
2014-04-02 15:43 hgbot Status scheduled => resolved
2014-04-02 15:43 hgbot Resolution open => fixed
2014-04-02 15:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/7194ff6bfb769de53cbce0bad3f960a98819ca0e [^] => http://code.openbravo.com/erp/devel/pi/rev/0a17f1fe4f0cae9f9fcc1b4d9fcf41b2657925fb [^]
2014-05-07 18:10 hudsonbot Checkin
2014-05-07 18:10 hudsonbot Note Added: 0066879
2014-05-26 14:28 jonalegriaesarte Note Added: 0067452
2014-05-26 14:28 jonalegriaesarte Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker