Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024812
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2013-09-23 12:472013-09-27 03:11
ReporterngarciaView Statuspublic 
Assigned Topramakrishnan 
PriorityimmediateResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revisione81e664209d1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tongarcia
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-06-10
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2c1353055359a2e3d490adc65a16c5376f533c79 [^]
Triggers an Emergency PackNo
Summary

0024812: Wrong warehouse could be selected in orders and goods shipments/receipts

DescriptionWrong warehouse could be selected in orders and goods shipments/receipts
Steps To ReproduceAs group admin role:
   Create a sales order for F&B España - Región Norte
   Check that the warehouse selected is España Región Norte
   Change the Organization to F&B US West Coast
   Notice that the same warehouse remains selected, which is not accessible by the organization
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0019974 acknowledgedplatform When changing Organization, it shows the previously selected Business Partner. 
related to defect 00237863.0MP25 closedioritzCia POS order: book action is not working correctly when the warehouses are not properly configured 

-  Notes
(0061368)
alostale (developer)
2013-09-24 16:08
edited on: 2013-09-24 16:10

The regression was introduced in MP25 by fix for issue 0023786 where reference of c_order.m_warehouse_id column is changed from table to selector.

It is a known issue (0019974) this misbehavior in selectors, but due to its potential risk it cannot be addressed as an immediate issue for MP28.

Reassigning it to functional team them to take a decision on the short term solution.

(0061403)
hgbot (developer)
2013-09-26 08:45

Repository: erp/devel/pi
Changeset: e81e664209d16e2f6a45a532b81a64b5d140740d
Author: Pandeeswari Ramakrishnan <pandeeswari.ramakrishnan <at> openbravo.com>
Date: Thu Sep 26 12:06:20 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/e81e664209d16e2f6a45a532b81a64b5d140740d [^]

Fixes Issue 24812: Wrong warehouse could be selected in orders,shipments

---
M src-db/database/model/functions/C_ORDER_POST1.xml
M src-db/database/model/functions/M_INOUT_POST.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0061432)
hudsonbot (developer)
2013-09-27 03:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/71a3ba7a4af8 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-23 12:47 ngarcia New Issue
2013-09-23 12:47 ngarcia Assigned To => dmiguelez
2013-09-23 12:47 ngarcia Modules => Core
2013-09-23 12:47 ngarcia Triggers an Emergency Pack => No
2013-09-23 12:49 ngarcia Regression level => Production - Confirmed Stable
2013-09-23 12:49 ngarcia Assigned To dmiguelez => pramakrishnan
2013-09-24 09:35 pramakrishnan Relationship added related to 0019974
2013-09-24 09:35 pramakrishnan Assigned To pramakrishnan => AugustoMauch
2013-09-24 16:04 alostale Regression date => 2013-06-10
2013-09-24 16:04 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2c1353055359a2e3d490adc65a16c5376f533c79 [^]
2013-09-24 16:05 alostale Relationship added related to 0023786
2013-09-24 16:08 alostale Note Added: 0061368
2013-09-24 16:10 alostale Note Edited: 0061368 View Revisions
2013-09-24 16:10 alostale Assigned To AugustoMauch => dmiguelez
2013-09-26 07:59 pramakrishnan Assigned To dmiguelez => pramakrishnan
2013-09-26 08:01 pramakrishnan Status new => scheduled
2013-09-26 08:01 pramakrishnan fix_in_branch => pi
2013-09-26 08:01 pramakrishnan Review Assigned To => ngarcia
2013-09-26 08:01 pramakrishnan fix_in_branch pi =>
2013-09-26 08:45 hgbot Checkin
2013-09-26 08:45 hgbot Note Added: 0061403
2013-09-26 08:45 hgbot Status scheduled => resolved
2013-09-26 08:45 hgbot Resolution open => fixed
2013-09-26 08:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e81e664209d16e2f6a45a532b81a64b5d140740d [^]
2013-09-26 17:11 ngarcia Status resolved => closed
2013-09-26 17:11 ngarcia Fixed in Version => 3.0MP28
2013-09-27 03:11 hudsonbot Checkin
2013-09-27 03:11 hudsonbot Note Added: 0061432


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker