Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024645
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2013-09-02 09:292013-09-02 18:18
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP27
StatusclosedFix in branchFixed in SCM revisionaf8eea02fadc
ProjectionnoneETAnoneTarget Version3.0MP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-06-16
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4060f2b5e6bd [^]
Triggers an Emergency PackYes
Summary

0024645: A record can not be saved twice in edit mode

DescriptionA record can not be saved twice in edit mode without refreshing it before saving it for the second time.
Steps To Reproduce- Open any window
- Open any not read-only record in form view
- Make a change and save
- Make another change to the same record and save
- The second save will fail and this error message will be shown: "Saving failed. The record you are saving has already been changed by another user or process. Cancel your changes and refresh the data by clicking the refresh button"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0024537 closedAugustoMauch Business Partner/Bank Account -> Change and Save an account multiple times -> Error Saving failed ... 

-  Notes
(0060852)
hgbot (developer)
2013-09-02 09:48

Repository: erp/devel/pi
Changeset: af8eea02fadc96dabaf5341b7e6c1013a0bd0a64
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Sep 02 09:43:20 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/af8eea02fadc96dabaf5341b7e6c1013a0bd0a64 [^]

Fixes issue 24645: Records can be saved several times in form view

This issue was caused by this changeset [1]. This happens because when the record is changed after receiving the response of the datasource (when a record is edited the 'updated' column is always changed), the property textField._textChanged remains true, when it should be deleted after the change has been done.

[1] https://code.openbravo.com/erp/devel/pi/rev/4060f2b5e6bd [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-date.js
---
(0060858)
shankarb (developer)
2013-09-02 12:44

Code reviewed and tested in pi changeset 6e5c3a83e2b5.
(0060873)
hudsonbot (developer)
2013-09-02 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/58951728ad3a [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-02 09:29 AugustoMauch New Issue
2013-09-02 09:29 AugustoMauch Assigned To => AugustoMauch
2013-09-02 09:29 AugustoMauch Modules => Core
2013-09-02 09:29 AugustoMauch Triggers an Emergency Pack => No
2013-09-02 09:31 AugustoMauch Regression level => Production - Confirmed Stable
2013-09-02 09:31 AugustoMauch Regression date => 2013-06-16
2013-09-02 09:31 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4060f2b5e6bd [^]
2013-09-02 09:31 AugustoMauch Triggers an Emergency Pack No => Yes
2013-09-02 09:43 AugustoMauch Issue Monitored: shankarb
2013-09-02 09:43 AugustoMauch Review Assigned To => shankarb
2013-09-02 09:48 hgbot Checkin
2013-09-02 09:48 hgbot Note Added: 0060852
2013-09-02 09:48 hgbot Status new => resolved
2013-09-02 09:48 hgbot Resolution open => fixed
2013-09-02 09:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/af8eea02fadc96dabaf5341b7e6c1013a0bd0a64 [^]
2013-09-02 12:44 shankarb Note Added: 0060858
2013-09-02 12:44 shankarb Status resolved => closed
2013-09-02 12:44 shankarb Fixed in Version => 3.0MP27
2013-09-02 18:18 hudsonbot Checkin
2013-09-02 18:18 hudsonbot Note Added: 0060873
2013-12-09 12:12 AugustoMauch Relationship added has duplicate 0024537


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker