Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024488
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 06. Material requirement planning (MRP)minoralways2013-08-06 11:002014-03-17 10:37
ReportermaiteView Statuspublic 
Assigned Toshankarb 
PriorityhighResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchpiFixed in SCM revision30526fccbd10
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024488: It is not possible to filter by "Parent" field in Manufacturing Plan Lines tab

DescriptionIt is not possible to filter by "Parent" field in Manufacturing Plan Lines tab
Steps To Reproduce1. Follow How-to MRP document to generate Manufacturing Plan: http://wiki.openbravo.com/wiki/ERP_2.50:How-to_MRP [^]
2. Once you have data in Manufacturing Plan Lines tab try to filter by "Parent" field and realize that is not working
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00249223.0MP30 closedshankarb Fields that use a table reference extension are not displayed properly in grid view 

-  Notes
(0065117)
hgbot (developer)
2014-03-13 10:49

Repository: erp/devel/pi
Changeset: 30526fccbd1047e2dfd2a9b61ccb78e5ce4045ea
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Tue Mar 11 15:31:35 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/30526fccbd1047e2dfd2a9b61ccb78e5ce4045ea [^]

Fixes issue 24488: It is not possible to filter by "Parent" field in Manufacturing Plan Lines tab

Changed table reference to UI Selector.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_REFERENCE.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0065127)
hgbot (developer)
2014-03-13 12:17

Repository: erp/devel/pi
Changeset: 7858157f0182e8bbfb8a14d95a0e2bdf639f3239
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Mar 13 16:45:59 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/7858157f0182e8bbfb8a14d95a0e2bdf639f3239 [^]

Related to issue 24488 : Synchronized selector fields

---
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0065148)
AugustoMauch (manager)
2014-03-13 19:37

Code reviewed and verified in pi@eb415e9bc94f

Not only the problem was solved, also the calendar is now translated to japanese.
(0065149)
AugustoMauch (manager)
2014-03-13 19:37

The issue was closed by mistake.
(0065151)
shankarb (developer)
2014-03-14 05:37

When using table reference with display column other than identifier, grid filtering is not working in some cases. There is a separate issue logged on that[1]. For solving this issue and for performance improvement, the table reference has been changed to UI selector.

https://issues.openbravo.com/view.php?id=25982 [^]
(0065179)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065180)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065206)
AugustoMauch (manager)
2014-03-17 10:37

Code reviewed and verified in pi@09baf685138e

- Issue History
Date Modified Username Field Change
2013-08-06 11:00 maite New Issue
2013-08-06 11:00 maite Assigned To => dmiguelez
2013-08-06 11:00 maite Modules => Core
2013-08-06 11:00 maite Triggers an Emergency Pack => No
2013-08-06 11:00 maite Issue Monitored: networkb
2013-08-12 08:50 dmiguelez Assigned To dmiguelez => jonalegriaesarte
2013-09-16 13:29 jonalegriaesarte Target Version 3.0MP28 => 3.0MP29
2013-10-07 16:31 jonalegriaesarte Target Version 3.0MP29 => 3.0MP30
2013-11-06 09:29 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2013-11-07 13:09 maite Relationship added related to 0024922
2013-11-07 13:10 maite Assigned To pramakrishnan => AugustoMauch
2013-11-20 05:09 shankarb Assigned To AugustoMauch => shankarb
2013-11-27 11:43 alostale Target Version 3.0MP30 => 3.0MP31
2014-01-02 12:38 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-03-10 17:29 jonalegriaesarte Resolution time => 1395270000
2014-03-13 10:47 shankarb Review Assigned To => AugustoMauch
2014-03-13 10:48 shankarb Issue Monitored: AugustoMauch
2014-03-13 10:49 hgbot Checkin
2014-03-13 10:49 hgbot Note Added: 0065117
2014-03-13 10:49 hgbot Status new => resolved
2014-03-13 10:49 hgbot Resolution open => fixed
2014-03-13 10:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/30526fccbd1047e2dfd2a9b61ccb78e5ce4045ea [^]
2014-03-13 12:17 hgbot Checkin
2014-03-13 12:17 hgbot Note Added: 0065127
2014-03-13 19:37 AugustoMauch Note Added: 0065148
2014-03-13 19:37 AugustoMauch Status resolved => closed
2014-03-13 19:37 AugustoMauch Fixed in Version => PR14Q2
2014-03-13 19:37 AugustoMauch Note Added: 0065149
2014-03-13 19:37 AugustoMauch Status closed => new
2014-03-13 19:37 AugustoMauch Resolution fixed => open
2014-03-13 19:37 AugustoMauch Fixed in Version PR14Q2 =>
2014-03-13 19:37 AugustoMauch Status new => scheduled
2014-03-13 19:37 AugustoMauch fix_in_branch => pi
2014-03-13 19:37 AugustoMauch Status scheduled => resolved
2014-03-13 19:37 AugustoMauch Resolution open => fixed
2014-03-14 05:37 shankarb Note Added: 0065151
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065179
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065180
2014-03-17 10:37 AugustoMauch Note Added: 0065206
2014-03-17 10:37 AugustoMauch Status resolved => closed
2014-03-17 10:37 AugustoMauch Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker