Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024449
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POStrivialalways2013-07-31 08:142013-07-31 15:14
ReportersureshbabuView Statuspublic 
Assigned Toguilleaer 
PrioritylowResolutionfixedFixed in VersionRMP25
StatusclosedFix in branchpiFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024449: RMP25: when i reopen the receipt( gross amount:0.00), Paid label wrongly appears as PAID(on credit)

Descriptionwhen i reopen the receipt for which overall gross amount is zero( gross amount:0.00), Paid label wrongly appears as PAID(on credit)
Steps To Reproduce1) Create a receipt with any product, and change the product price to 0.00 so that overall gross amount will be zero.
2) Complete the receipt.
3) From webpos, reopen the receipt one can find instead of label Paid, right now it shows PAID(on credit)
TagsNo tags attached.
Attached Filespng file icon when i reopen the receipt for which over all gross amount is zero, Paid label wrongly appears as PAID(on credit).png [^] (299,700 bytes) 2013-07-31 08:14

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0024426RMP26 closedmarvintm The tickets paid in credit should not be displayed as paid 
related to defect 0023878RMP26 closedmarvintm Text paid wrongly appears when i reopen the receipt which is paid using credit option 

-  Notes
(0060407)
guilleaer (developer)
2013-07-31 13:00

resolved by this commit
http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/691c0c47b4340f6935bf948edb042ae739e4a122 [^]
(0060410)
guilleaer (developer)
2013-07-31 13:05

This commit also is needed to a complete fix
http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a6fd869b475c59c62b4ba693703ab26c6f916f84 [^]
(0060427)
migueldejuana (developer)
2013-07-31 15:14

Tested and reviewed in ee6a7557292a

- Issue History
Date Modified Username Field Change
2013-07-31 08:14 sureshbabu New Issue
2013-07-31 08:14 sureshbabu Assigned To => guilleaer
2013-07-31 08:14 sureshbabu File Added: when i reopen the receipt for which over all gross amount is zero, Paid label wrongly appears as PAID(on credit).png
2013-07-31 08:39 guilleaer Note Added: 0060390
2013-07-31 08:39 guilleaer Status new => closed
2013-07-31 10:39 guilleaer Status closed => new
2013-07-31 10:39 guilleaer Note Deleted: 0060390
2013-07-31 10:40 guilleaer Relationship added related to 0023878
2013-07-31 13:00 guilleaer Status new => scheduled
2013-07-31 13:00 guilleaer fix_in_branch => pi
2013-07-31 13:00 guilleaer Note Added: 0060407
2013-07-31 13:00 guilleaer Relationship added duplicate of 0024426
2013-07-31 13:00 guilleaer Status scheduled => resolved
2013-07-31 13:00 guilleaer Fixed in Version => RMP25
2013-07-31 13:00 guilleaer Resolution open => fixed
2013-07-31 13:05 guilleaer Note Added: 0060410
2013-07-31 15:14 migueldejuana Review Assigned To => migueldejuana
2013-07-31 15:14 migueldejuana Note Added: 0060427
2013-07-31 15:14 migueldejuana Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker