Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024389
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-07-22 12:382013-09-10 10:02
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP27
StatusclosedFix in branchFixed in SCM revision349a5325fc81
ProjectionnoneETAnoneTarget VersionRMP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024389: Problems with stock reservation and web POS

DescriptionProblems with stock reservation and web POS
Steps To Reproduce-Enable stock reservation http://wiki.openbravo.com/wiki/Stock_Reservation [^]

-Create a stock for one product with qty on hand 10
-Create a stock reservation of 9 units

-Go to web POS and create a ticket with qty=2 and same product

Verify that the order goes to "errors while importing pos data" due to a trigger M_transaction_trg2 lines
IF (v_onhand - v_reserved < ABS(NEW.movementqty)) THEN
  RAISE EXCEPTION '%', '@CannotTakeOutReservedStock@'; --OBTG:-20000--
END IF;
TagsNo tags attached.
Attached Filesdiff file icon diffIssue24389_v1.diff [^] (3,907 bytes) 2013-08-21 23:56 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060574)
hgbot (developer)
2013-08-12 14:33

Repository: erp/devel/pi
Changeset: ca15098edeb034654a92bc392dc55bcc129d0216
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Aug 12 14:30:33 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ca15098edeb034654a92bc392dc55bcc129d0216 [^]

fixed issue 24389: [core part] Added a column to skip stock reservations when a transaction is added

---
M src-db/database/model/tables/M_TRANSACTION.xml
M src-db/database/model/triggers/M_TRANSACTION_TRG2.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
---
(0060575)
hgbot (developer)
2013-08-12 14:39

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b526b6602b40dabeed1b3675de475d3d21943d47
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Aug 12 14:37:22 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b526b6602b40dabeed1b3675de475d3d21943d47 [^]

fixed issue 24389: [retail part] Stock reservation check is skiped when a transaction is created from order loader

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060578)
hgbot (developer)
2013-08-12 19:01

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7c16e85e243d587c554f2aded13b1821cd0be008
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Aug 12 17:54:23 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7c16e85e243d587c554f2aded13b1821cd0be008 [^]

realted to issue 24389: to maintain compatibility, set property using set intead of seter

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060581)
hgbot (developer)
2013-08-12 19:04

Repository: erp/devel/pi
Changeset: 4080460baf195097717658087cabdede6e8581ae
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Aug 12 19:03:16 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4080460baf195097717658087cabdede6e8581ae [^]

related to issue 24389: remove log from trigger

---
M src-db/database/model/triggers/M_TRANSACTION_TRG2.xml
---
(0060584)
hgbot (developer)
2013-08-13 08:50

Repository: erp/devel/pi
Changeset: 21d0baeb6c99f9d3854b9aeecf6adf0c19d9ca06
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 13 08:49:20 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/21d0baeb6c99f9d3854b9aeecf6adf0c19d9ca06 [^]

related to issue 24389: return NEW is not needed in this case

---
M src-db/database/model/triggers/M_TRANSACTION_TRG2.xml
---
(0060650)
hudsonbot (developer)
2013-08-16 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/59a1180e7f4f [^]

Maturity status: Test
(0060651)
hudsonbot (developer)
2013-08-16 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/59a1180e7f4f [^]

Maturity status: Test
(0060652)
hudsonbot (developer)
2013-08-16 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/59a1180e7f4f [^]

Maturity status: Test
(0060675)
hgbot (developer)
2013-08-20 12:37

Repository: erp/devel/pi
Changeset: 55c000c9189778b7c6416ca834f56d43c2f846ac
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:33:47 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/55c000c9189778b7c6416ca834f56d43c2f846ac [^]

related to issue 24389: backed out changeset 21d0baeb6c99

---
M src-db/database/model/triggers/M_TRANSACTION_TRG2.xml
---
(0060676)
hgbot (developer)
2013-08-20 12:37

Repository: erp/devel/pi
Changeset: 8d3f43817c4f620385d6df2c5609f91e173edb9e
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:37:09 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8d3f43817c4f620385d6df2c5609f91e173edb9e [^]

related to issue 24389: Backed out changesets 4080460baf19 and ca15098edeb0

---
M src-db/database/model/tables/M_TRANSACTION.xml
M src-db/database/model/triggers/M_TRANSACTION_TRG2.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
---
(0060677)
hgbot (developer)
2013-08-20 12:45

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: ae2c43d80a846844f818faa9da4b62c2ff0c241d
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:40:47 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/ae2c43d80a846844f818faa9da4b62c2ff0c241d [^]

related to issue 24389: backed out changeset 7c16e85e243d

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060678)
hgbot (developer)
2013-08-20 12:45

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 6cabfefbeba0dd555d51d3460d482e94c88f51fa
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:41:32 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6cabfefbeba0dd555d51d3460d482e94c88f51fa [^]

related to issue 24389: backed out changeset b526b6602b40

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060680)
guilleaer (developer)
2013-08-20 13:01

A new fix will be implemented
(0060691)
hgbot (developer)
2013-08-21 08:31

Repository: erp/pmods/org.openbravo.retail.posterminal-rds
Changeset: ae2c43d80a846844f818faa9da4b62c2ff0c241d
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:40:47 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-rds/rev/ae2c43d80a846844f818faa9da4b62c2ff0c241d [^]

related to issue 24389: backed out changeset 7c16e85e243d

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060692)
hgbot (developer)
2013-08-21 08:31

Repository: erp/pmods/org.openbravo.retail.posterminal-rds
Changeset: 6cabfefbeba0dd555d51d3460d482e94c88f51fa
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Aug 20 09:41:32 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-rds/rev/6cabfefbeba0dd555d51d3460d482e94c88f51fa [^]

related to issue 24389: backed out changeset b526b6602b40

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060696)
hgbot (developer)
2013-08-21 09:01

Repository: erp/devel/api-checks
Changeset: 0837378afd54cc0068a54caa4e4f8a9a30c65578
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Aug 21 09:00:24 2013 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/0837378afd54cc0068a54caa4e4f8a9a30c65578 [^]

reverted previous change in the api due to backout of issue 24389

---
M java/reference/java.japi.gz
---
(0060698)
hgbot (developer)
2013-08-21 10:40

Repository: erp/devel/api-checks
Changeset: ea811632fdf2cbe35f91898f27ce7a009248f976
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Aug 21 10:39:56 2013 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/ea811632fdf2cbe35f91898f27ce7a009248f976 [^]

reverted previous change in the api due to backout of issue 24389 - Using 4186 instead of 4180

---
M java/reference/java.japi.gz
---
(0060715)
hudsonbot (developer)
2013-08-21 18:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5a759279dc34 [^]

Maturity status: Test
(0060716)
hudsonbot (developer)
2013-08-21 18:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5a759279dc34 [^]

Maturity status: Test
(0060722)
guilleaer (developer)
2013-08-21 23:56

Attached you can find the first version of the final patch which will be included in RMP27.
(0060835)
hgbot (developer)
2013-08-30 11:29

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 349a5325fc81966203ab76aab4c0978bb139b92d
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Aug 30 11:22:44 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/349a5325fc81966203ab76aab4c0978bb139b92d [^]

fixed issue 24389: Inventory is updated manually calling to M_UPDATE_INVENTORY. M_Transaction triggers are not executed.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060993)
hgbot (developer)
2013-09-10 09:54

Repository: erp/pmods/org.openbravo.retail.posterminal-levelpricing
Changeset: 349a5325fc81966203ab76aab4c0978bb139b92d
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Aug 30 11:22:44 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-levelpricing/rev/349a5325fc81966203ab76aab4c0978bb139b92d [^]

fixed issue 24389: Inventory is updated manually calling to M_UPDATE_INVENTORY. M_Transaction triggers are not executed.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0061047)
guilleaer (developer)
2013-09-10 10:02

reclosed

- Issue History
Date Modified Username Field Change
2013-07-22 12:38 jecharri New Issue
2013-07-22 12:38 jecharri Assigned To => marvintm
2013-08-08 03:45 eintelau Issue Monitored: eintelau
2013-08-12 14:33 hgbot Checkin
2013-08-12 14:33 hgbot Note Added: 0060574
2013-08-12 14:33 hgbot Status new => resolved
2013-08-12 14:33 hgbot Resolution open => fixed
2013-08-12 14:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ca15098edeb034654a92bc392dc55bcc129d0216 [^]
2013-08-12 14:39 hgbot Checkin
2013-08-12 14:39 hgbot Note Added: 0060575
2013-08-12 14:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/ca15098edeb034654a92bc392dc55bcc129d0216 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b526b6602b40dabeed1b3675de475d3d21943d47 [^]
2013-08-12 19:01 hgbot Checkin
2013-08-12 19:01 hgbot Note Added: 0060578
2013-08-12 19:04 hgbot Checkin
2013-08-12 19:04 hgbot Note Added: 0060581
2013-08-13 08:50 hgbot Checkin
2013-08-13 08:50 hgbot Note Added: 0060584
2013-08-16 20:33 hudsonbot Checkin
2013-08-16 20:33 hudsonbot Note Added: 0060650
2013-08-16 20:33 hudsonbot Checkin
2013-08-16 20:33 hudsonbot Note Added: 0060651
2013-08-16 20:33 hudsonbot Checkin
2013-08-16 20:33 hudsonbot Note Added: 0060652
2013-08-20 12:37 hgbot Checkin
2013-08-20 12:37 hgbot Note Added: 0060675
2013-08-20 12:37 hgbot Checkin
2013-08-20 12:37 hgbot Note Added: 0060676
2013-08-20 12:45 hgbot Checkin
2013-08-20 12:45 hgbot Note Added: 0060677
2013-08-20 12:45 hgbot Checkin
2013-08-20 12:45 hgbot Note Added: 0060678
2013-08-20 13:01 guilleaer Note Added: 0060680
2013-08-20 13:01 guilleaer Status resolved => new
2013-08-20 13:01 guilleaer Resolution fixed => open
2013-08-20 13:01 guilleaer Triggers an Emergency Pack => No
2013-08-20 13:01 guilleaer Target Version RMP26 => RMP27
2013-08-21 08:31 hgbot Checkin
2013-08-21 08:31 hgbot Note Added: 0060691
2013-08-21 08:31 hgbot Checkin
2013-08-21 08:31 hgbot Note Added: 0060692
2013-08-21 09:01 hgbot Checkin
2013-08-21 09:01 hgbot Note Added: 0060696
2013-08-21 10:40 hgbot Checkin
2013-08-21 10:40 hgbot Note Added: 0060698
2013-08-21 18:59 hudsonbot Checkin
2013-08-21 18:59 hudsonbot Note Added: 0060715
2013-08-21 18:59 hudsonbot Checkin
2013-08-21 18:59 hudsonbot Note Added: 0060716
2013-08-21 23:56 guilleaer File Added: diffIssue24389_v1.diff
2013-08-21 23:56 guilleaer Note Added: 0060722
2013-08-30 11:29 hgbot Checkin
2013-08-30 11:29 hgbot Note Added: 0060835
2013-08-30 11:29 hgbot Status new => resolved
2013-08-30 11:29 hgbot Resolution open => fixed
2013-08-30 11:29 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b526b6602b40dabeed1b3675de475d3d21943d47 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/349a5325fc81966203ab76aab4c0978bb139b92d [^]
2013-09-02 12:14 marvintm Review Assigned To => marvintm
2013-09-02 12:14 marvintm Status resolved => closed
2013-09-10 09:54 hgbot Checkin
2013-09-10 09:54 hgbot Note Added: 0060993
2013-09-10 09:54 hgbot Status closed => resolved
2013-09-10 09:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/349a5325fc81966203ab76aab4c0978bb139b92d [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-levelpricing/rev/349a5325fc81966203ab76aab4c0978bb139b92d [^]
2013-09-10 10:02 guilleaer Note Added: 0061047
2013-09-10 10:02 guilleaer Status resolved => closed
2013-09-10 10:02 guilleaer Fixed in Version => RMP27


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker