Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024379
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersminoralways2013-07-18 22:422013-08-28 12:00
ReporterjecharriView Statuspublic 
Assigned Toguilleaer 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision
ProjectionnoneETAnoneTarget VersionRMP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojecharri
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024379: Impossible to do a gift card return

DescriptionImpossible to do a gift card return

You can do a gift card sale but you can not return one gift card.

The problem is that we allow to create a return ticket with one gift card but we can not select or remove existing gift card, so it has not got sense to allow return or better it has not got sense that user can not choose one gift card to retun it
Steps To Reproduce-mark one ticket to be returned.

-It is impossible to return an existing gift card. You need to create a new one and this has not got sense because you are creating one new return gift card.

Proposed Solution-You should be able to choose an existing gift card (only if it has not got transactions associated) and return it

When you return it, the gift card should be removed from window "Gift card instances"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060587)
adrianromero (manager)
2013-08-13 14:26
edited on: 2013-08-13 14:26

Resolved in version 1.1.503. This is from the technical point of view a new functionality in Gift cards so several change sets resolve this issue. In changeset https://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/cd71b664b2b8 [^] the functionality is finished.


- Issue History
Date Modified Username Field Change
2013-07-18 22:42 jecharri New Issue
2013-07-18 22:42 jecharri Assigned To => guilleaer
2013-07-18 22:50 anherzog Issue Monitored: anherzog
2013-08-01 08:46 guilleaer Triggers an Emergency Pack => No
2013-08-01 08:46 guilleaer Category Web POS => Gift cards and gift vouchers
2013-08-02 13:43 dmitry_mezentsev Target Version RMP25 => RMP26
2013-08-02 14:10 jecharri Severity major => minor
2013-08-02 14:10 jecharri Target Version RMP26 => RMP27
2013-08-13 14:24 adrianromero Status new => scheduled
2013-08-13 14:24 adrianromero fix_in_branch => pi
2013-08-13 14:26 adrianromero Note Added: 0060587
2013-08-13 14:26 adrianromero Status scheduled => resolved
2013-08-13 14:26 adrianromero Resolution open => fixed
2013-08-13 14:26 adrianromero Note Edited: 0060587 View Revisions
2013-08-28 12:00 jecharri Review Assigned To => jecharri
2013-08-28 12:00 jecharri Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker