Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024363
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-07-18 09:322013-08-07 11:49
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP25
StatusclosedFix in branchFixed in SCM revisionec136579fce5
ProjectionnoneETAnoneTarget VersionRMP25
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024363: Discounts and promotions are not working fine with pricing without taxes

DescriptionDiscounts and promotions are not working fine with pricing without taxes
Steps To Reproduce-Configure one POS terminale to work with one price list without taxes
-Go to window discount and promotions and create a "discretionary fixed percentaje" discount. For example 50% of idscount

-Login in web POS and a product to the ticket

-In my case the product price is 2.64 and I have a tax rate of 6%
2.64*1.06=2.7984 ~ 2.80

-If I apply the discount of 50% the expected value is 1.4 but we will get 1.32 why?

2.64*1.06=2.80 --> 2.80*0.5=1.4 --> (2.64-1.4)*1.06= 1.3144 ~ 1.31
TagsNo tags attached.
Attached Filespng file icon discounts.png [^] (143,724 bytes) 2013-07-18 09:32

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060092)
marvintm (developer)
2013-07-18 11:15

The problem is only happening on discretionary discounts, when using pricing without included taxes. It seems other types of discounts are not affected.
(0060093)
hgbot (developer)
2013-07-18 11:19

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: ec136579fce5678457076fc9979d65a54e331e23
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 18 11:18:50 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/ec136579fce5678457076fc9979d65a54e331e23 [^]

Fixed issue 24363. Discretionary discounts will work correctly with prices which do not include taxes

---
M web/org.openbravo.retail.discounts/js/promotion-manual.js
---
(0060187)
guilleaer (developer)
2013-07-23 17:50

verified
(0060518)
hgbot (developer)
2013-08-07 08:53

Repository: erp/pmods/org.openbravo.retail.discounts-col
Changeset: ec136579fce5678457076fc9979d65a54e331e23
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 18 11:18:50 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts-col/rev/ec136579fce5678457076fc9979d65a54e331e23 [^]

Fixed issue 24363. Discretionary discounts will work correctly with prices which do not include taxes

---
M web/org.openbravo.retail.discounts/js/promotion-manual.js
---
(0060525)
guilleaer (developer)
2013-08-07 11:49

reclosing

- Issue History
Date Modified Username Field Change
2013-07-18 09:32 jecharri New Issue
2013-07-18 09:32 jecharri Assigned To => marvintm
2013-07-18 09:32 jecharri File Added: discounts.png
2013-07-18 11:15 marvintm Note Added: 0060092
2013-07-18 11:19 hgbot Checkin
2013-07-18 11:19 hgbot Note Added: 0060093
2013-07-18 11:19 hgbot Status new => resolved
2013-07-18 11:19 hgbot Resolution open => fixed
2013-07-18 11:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/ec136579fce5678457076fc9979d65a54e331e23 [^]
2013-07-23 17:50 guilleaer Review Assigned To => guilleaer
2013-07-23 17:50 guilleaer Note Added: 0060187
2013-07-23 17:50 guilleaer Status resolved => closed
2013-07-23 17:50 guilleaer Fixed in Version => RMP25
2013-08-07 08:53 hgbot Checkin
2013-08-07 08:53 hgbot Note Added: 0060518
2013-08-07 08:53 hgbot Status closed => resolved
2013-08-07 08:53 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/ec136579fce5678457076fc9979d65a54e331e23 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts-col/rev/ec136579fce5678457076fc9979d65a54e331e23 [^]
2013-08-07 11:49 guilleaer Note Added: 0060525
2013-08-07 11:49 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker