Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024267
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-07-04 11:192013-07-23 18:39
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityhighResolutionfixedFixed in VersionRMP25
StatusclosedFix in branchFixed in SCM revision56e0a2379af9
ProjectionnoneETAnoneTarget VersionRMP25
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024267: Web POS is not loading all the taxes

DescriptionWeb POS is not loading all the taxes

If you go to java modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/master/TaxRate.java you will see that we are collecting only the taxes where the origin is the POS terminal location and the destination is the default BP location.
Steps To Reproduce-Configure one POS
-Configure the POS terminal in United States, region MM
-Configure default BP in United States, region MM
-Configure another BP in United States, region MN

-Create 2 taxes:
+one from MM to MM
+another one from MM to MN

Verify that the second tax is not loaded and also the BP can not make sales in Web POS due to a products have not got taxes
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059873)
hgbot (developer)
2013-07-04 19:50

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 56e0a2379af9500b788c7ec5190ad824d26ea6be
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 04 19:50:15 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/56e0a2379af9500b788c7ec5190ad824d26ea6be [^]

Fixed issue 24267. Removed filtering by destination country/region in the backend, as it doesn't make sense, because the business partner may be changed in the client side.

---
M src/org/openbravo/retail/posterminal/master/TaxRate.java
---
(0059920)
hgbot (developer)
2013-07-08 15:26

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 56e0a2379af9500b788c7ec5190ad824d26ea6be
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 04 19:50:15 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/56e0a2379af9500b788c7ec5190ad824d26ea6be [^]

Fixed issue 24267. Removed filtering by destination country/region in the backend, as it doesn't make sense, because the business partner may be changed in the client side.

---
M src/org/openbravo/retail/posterminal/master/TaxRate.java
---
(0060203)
guilleaer (developer)
2013-07-23 18:39

verified

- Issue History
Date Modified Username Field Change
2013-07-04 11:19 jecharri New Issue
2013-07-04 11:19 jecharri Assigned To => marvintm
2013-07-04 19:50 hgbot Checkin
2013-07-04 19:50 hgbot Note Added: 0059873
2013-07-04 19:50 hgbot Status new => resolved
2013-07-04 19:50 hgbot Resolution open => fixed
2013-07-04 19:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/56e0a2379af9500b788c7ec5190ad824d26ea6be [^]
2013-07-08 15:26 hgbot Checkin
2013-07-08 15:26 hgbot Note Added: 0059920
2013-07-08 15:26 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/56e0a2379af9500b788c7ec5190ad824d26ea6be [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/56e0a2379af9500b788c7ec5190ad824d26ea6be [^]
2013-07-23 18:39 guilleaer Review Assigned To => guilleaer
2013-07-23 18:39 guilleaer Note Added: 0060203
2013-07-23 18:39 guilleaer Status resolved => closed
2013-07-23 18:39 guilleaer Fixed in Version => RMP25


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker