Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023996
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-06-05 13:572013-06-20 02:07
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP24
StatusclosedFix in branchFixed in SCM revision916022030581
ProjectionnoneETAnoneTarget Version3.0MP24
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023996: Replace a business event handler with database constraints

DescriptionA business event handler (TableDataOriginEventHandler) made for the Datasource based tables project should be replace with a constraint. Using a constraint is more simple and easier to maintain.

Two new constraints are needed:
- If the data origin of the table if 'Datasource', the obserds_datasource_id column can not be null
- If the data origin of the table if 'Table', the classname column can not be null
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059184)
hgbot (developer)
2013-06-05 14:04

Repository: erp/devel/pi
Changeset: 742895bc82e39bc81343889a914fa757bc653d7e
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jun 05 14:03:22 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/742895bc82e39bc81343889a914fa757bc653d7e [^]

Fixes issue 23996: An event handler has been replaced with database constraints

The event handler TableDataOriginEventHandler has been replaced with database constraints. This is a better approach because it is simpler and easier to maint
ain.

The name of two of the messages has been updated so that it is the name as the constraint that throw them. The message used to warn the user that the table_name must be set if the data origin is 'Table' has been removed because now the table_name is mandatory again in the database.

---
M src-db/database/model/tables/AD_TABLE.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
R modules/org.openbravo.client.application/src/org/openbravo/client/application/event/TableDataOriginEventHandler.java
---
(0059185)
AugustoMauch (developer)
2013-06-05 14:07

Test plan:
- Test that the class name constraint works
- Open an existing table.
- Delete the classname field and try to save.

- Test that the datasource constraint works
- Create a new datasource in the application dictionary, check the Use as Table data origin
- Create a new Table. Set Data origin to 'Datasource'. Try to save the record leaving the datasource field empty.
(0059190)
hgbot (developer)
2013-06-05 15:58

Repository: erp/devel/pi
Changeset: 9160220305813321f47098adf51a02f0e3d838aa
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jun 05 15:57:57 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9160220305813321f47098adf51a02f0e3d838aa [^]

Fixes issue 23996: String is compared in constraint after being upper cased

---
M src-db/database/model/tables/AD_TABLE.xml
---
(0059191)
shankarb (developer)
2013-06-05 16:25

Code reviewed and tested in pi changeset 916022030581
(0059198)
hgbot (developer)
2013-06-05 18:06

Repository: erp/devel/api-checks
Changeset: 346b87db66a122176fee01e4f22b798216f65775
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jun 05 18:05:53 2013 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/346b87db66a122176fee01e4f22b798216f65775 [^]

Related to issue 0023996: Fixes API change

This API change is a false positive. Two contraints have been added to the AD_TABLE table, but all registers of all openbravo instances are going to comply with it, because nobody has created yet a Datasource Based Table.

---
M model/src-db/database/model/tables/AD_TABLE.xml
---
(0059200)
hgbot (developer)
2013-06-05 18:48

Repository: erp/devel/api-checks
Changeset: 63a874549bf3e899400ab7bfc2fc3c0577495476
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Wed Jun 05 18:48:35 2013 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/63a874549bf3e899400ab7bfc2fc3c0577495476 [^]

Related to issue 23996: ack 2nd part of false positive
Related to previous commit. A EventHandler was deleted.
As it was never published yet -> false positive.

---
M java/reference/java.japi.gz
---
(0059542)
hudsonbot (developer)
2013-06-20 02:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test
(0059543)
hudsonbot (developer)
2013-06-20 02:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-06-05 13:57 AugustoMauch New Issue
2013-06-05 13:57 AugustoMauch Assigned To => AugustoMauch
2013-06-05 13:57 AugustoMauch Modules => Core
2013-06-05 13:57 AugustoMauch Triggers an Emergency Pack => No
2013-06-05 13:59 AugustoMauch Issue Monitored: shankarb
2013-06-05 13:59 AugustoMauch Review Assigned To => shankarb
2013-06-05 14:04 hgbot Checkin
2013-06-05 14:04 hgbot Note Added: 0059184
2013-06-05 14:04 hgbot Status new => resolved
2013-06-05 14:04 hgbot Resolution open => fixed
2013-06-05 14:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/742895bc82e39bc81343889a914fa757bc653d7e [^]
2013-06-05 14:07 AugustoMauch Note Added: 0059185
2013-06-05 15:58 hgbot Checkin
2013-06-05 15:58 hgbot Note Added: 0059190
2013-06-05 15:58 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/742895bc82e39bc81343889a914fa757bc653d7e [^] => http://code.openbravo.com/erp/devel/pi/rev/9160220305813321f47098adf51a02f0e3d838aa [^]
2013-06-05 16:25 shankarb Note Added: 0059191
2013-06-05 16:25 shankarb Status resolved => closed
2013-06-05 16:25 shankarb Fixed in Version => 3.0MP24
2013-06-05 18:06 hgbot Checkin
2013-06-05 18:06 hgbot Note Added: 0059198
2013-06-05 18:48 hgbot Checkin
2013-06-05 18:48 hgbot Note Added: 0059200
2013-06-20 02:07 hudsonbot Checkin
2013-06-20 02:07 hudsonbot Note Added: 0059542
2013-06-20 02:07 hudsonbot Checkin
2013-06-20 02:07 hudsonbot Note Added: 0059543


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker