Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023991
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-06-05 12:272013-06-20 02:07
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP24
StatusclosedFix in branchFixed in SCM revision8c3c8557028d
ProjectionnoneETAnoneTarget Version3.0MP24
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023991: table_name column of ad_table table should be mandatory

DescriptionIn the Datasource Based Tables project [1] a new type of tables was introduced. This new tables were not based on actual database tables, but on user defined datasources.

At one point durint the project development the table_name column of the ad_table table was set not mandatory, because this field was meant to be left empty for tables based on datasources. Later in the project it was decided to use the column 'name' (the name column of the Table table) to set the 'table_name' column for datasource based tables. This was we avoided having to change the table identifier (table_name).

After this change the table_name column must be mandatory in the database.


[1] http://wiki.openbravo.com/wiki/How_to_Create_a_Table_Based_on_a_User_Defined_Datasource [^]
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059179)
hgbot (developer)
2013-06-05 12:37

Repository: erp/devel/pi
Changeset: 8c3c8557028deb50bd2101dded64d3d95e0cc47a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jun 05 12:36:15 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8c3c8557028deb50bd2101dded64d3d95e0cc47a [^]

Fixes issue 23991: table_name column of ad_table table is mandatory again

At one point durint the development of the Datasource Based Tables project the table_name column of the ad_table table was set not mandatory, because this field was meant to be left empty for tables based on datasources. Later in the project it was decided to use the column 'name' (the name column of the Table table) to set the 'table_name' column for datasource based tables. This was we avoided having to change the table identifier (table_name).

After this change the table_name column must be mandatory in the database.

---
M src-db/database/model/tables/AD_TABLE.xml
---
(0059181)
shankarb (developer)
2013-06-05 13:16

Code reviewed and tested in pi changeset 8c3c8557028d
(0059541)
hudsonbot (developer)
2013-06-20 02:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-06-05 12:27 AugustoMauch New Issue
2013-06-05 12:27 AugustoMauch Assigned To => AugustoMauch
2013-06-05 12:27 AugustoMauch Modules => Core
2013-06-05 12:27 AugustoMauch Triggers an Emergency Pack => No
2013-06-05 12:36 AugustoMauch Issue Monitored: shankarb
2013-06-05 12:36 AugustoMauch Review Assigned To => shankarb
2013-06-05 12:37 hgbot Checkin
2013-06-05 12:37 hgbot Note Added: 0059179
2013-06-05 12:37 hgbot Status new => resolved
2013-06-05 12:37 hgbot Resolution open => fixed
2013-06-05 12:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8c3c8557028deb50bd2101dded64d3d95e0cc47a [^]
2013-06-05 13:16 shankarb Note Added: 0059181
2013-06-05 13:16 shankarb Status resolved => closed
2013-06-05 13:16 shankarb Fixed in Version => 3.0MP24
2013-06-20 02:07 hudsonbot Checkin
2013-06-20 02:07 hudsonbot Note Added: 0059541


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker