Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023908
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-05-23 23:162013-06-06 11:52
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revisionb26a0a1c5fa5
ProjectionnoneETAnoneTarget VersionRMP24
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023908: Credit Invoices are not properly created in the cash up

DescriptionCredit Invoices are not properly created in the cash up

Steps To Reproduce-Do a cash up
-Create an order
-Mark the order as "invoice this order" and pay with credit.

Verify the that the invoice payment plan is properly created [fine.png]

-Create a new order
-Pay with credit
-Create a new one and pay with different BP
-Do a cash up

Verify that now the invoice is wrong [wrong.png]. Expected amount=0 and outstanding amount=0. Also the invoice is marked as payment complete = Yes
TagsNo tags attached.
Attached Filespng file icon fine.png [^] (112,133 bytes) 2013-05-23 23:16


png file icon wrong.png [^] (111,159 bytes) 2013-05-23 23:16

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059049)
hgbot (developer)
2013-05-29 17:16

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b26a0a1c5fa546d8c5151c64483bebf71313896a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 29 17:15:31 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b26a0a1c5fa546d8c5151c64483bebf71313896a [^]

Fixed issue 23908. If an order is paid on credit, an invoice will always be generated for it.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059050)
guilleaer (developer)
2013-05-29 17:49

Verified. To be included in RMP23
(0059148)
hgbot (developer)
2013-06-04 10:53

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: b26a0a1c5fa546d8c5151c64483bebf71313896a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 29 17:15:31 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/b26a0a1c5fa546d8c5151c64483bebf71313896a [^]

Fixed issue 23908. If an order is paid on credit, an invoice will always be generated for it.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059231)
guilleaer (developer)
2013-06-06 11:52

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-23 23:16 jecharri New Issue
2013-05-23 23:16 jecharri Assigned To => marvintm
2013-05-23 23:16 jecharri File Added: fine.png
2013-05-23 23:16 jecharri File Added: wrong.png
2013-05-29 17:16 hgbot Checkin
2013-05-29 17:16 hgbot Note Added: 0059049
2013-05-29 17:16 hgbot Status new => resolved
2013-05-29 17:16 hgbot Resolution open => fixed
2013-05-29 17:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b26a0a1c5fa546d8c5151c64483bebf71313896a [^]
2013-05-29 17:49 guilleaer Review Assigned To => guilleaer
2013-05-29 17:49 guilleaer Note Added: 0059050
2013-05-29 17:49 guilleaer Status resolved => closed
2013-05-29 17:49 guilleaer Fixed in Version => RMP23
2013-06-04 10:53 hgbot Checkin
2013-06-04 10:53 hgbot Note Added: 0059148
2013-06-04 10:53 hgbot Status closed => resolved
2013-06-04 10:53 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b26a0a1c5fa546d8c5151c64483bebf71313896a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/b26a0a1c5fa546d8c5151c64483bebf71313896a [^]
2013-06-06 11:52 guilleaer Note Added: 0059231
2013-06-06 11:52 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker