Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023779
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-05-09 13:222013-06-06 11:56
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision61e769550c1c
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP21SCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023779: Overpayments control

Descriptionwe should control the generated overpayments
Steps To Reproduce-Create a ticket which total is 10€
-choose a non cash payment method and pay 1000€

You will see that the application notice you that you are going to create an overpayment of 990€.

Sometimes the attendant does not notice and the consequence is that the payment and transaction are wrong.
Proposed SolutionI should display a popup telling that you are going to create an overpayment and we are sure about this action.

Also we can add a field telling the overpayments that we are going to accept.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031040 newRetail [RR15Q4] Small typo in overpayment pop up "an 10.00€ overpayment" 
related to defect 0031043 newRetail [RR15Q4] Redundant text in overpayment message 

-  Notes
(0058705)
hgbot (developer)
2013-05-20 17:28

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 61e769550c1c425420d98b086163022a034e0c1a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 20 17:28:02 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/61e769550c1c425420d98b086163022a034e0c1a [^]

Fixed issue 23779. A warning will be raised in case there is an overpayment when completing the ticket

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0058867)
hgbot (developer)
2013-05-23 07:52

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: 61e769550c1c425420d98b086163022a034e0c1a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 20 17:28:02 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/61e769550c1c425420d98b086163022a034e0c1a [^]

Fixed issue 23779. A warning will be raised in case there is an overpayment when completing the ticket

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0058931)
migueldejuana (developer)
2013-05-24 10:57

Testted and reviewed in 2c937f978d56
(0059029)
hgbot (developer)
2013-05-29 12:19

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 61e769550c1c425420d98b086163022a034e0c1a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 20 17:28:02 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/61e769550c1c425420d98b086163022a034e0c1a [^]

Fixed issue 23779. A warning will be raised in case there is an overpayment when completing the ticket

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0059235)
guilleaer (developer)
2013-06-06 11:56

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-09 13:22 jecharri New Issue
2013-05-09 13:22 jecharri Assigned To => marvintm
2013-05-20 17:28 hgbot Checkin
2013-05-20 17:28 hgbot Note Added: 0058705
2013-05-20 17:28 hgbot Status new => resolved
2013-05-20 17:28 hgbot Resolution open => fixed
2013-05-20 17:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/61e769550c1c425420d98b086163022a034e0c1a [^]
2013-05-23 07:52 hgbot Checkin
2013-05-23 07:52 hgbot Note Added: 0058867
2013-05-23 07:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/61e769550c1c425420d98b086163022a034e0c1a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/61e769550c1c425420d98b086163022a034e0c1a [^]
2013-05-24 10:57 migueldejuana Review Assigned To => migueldejuana
2013-05-24 10:57 migueldejuana Note Added: 0058931
2013-05-24 10:57 migueldejuana Status resolved => closed
2013-05-24 10:57 migueldejuana Fixed in Version => RMP23
2013-05-29 12:19 hgbot Checkin
2013-05-29 12:19 hgbot Note Added: 0059029
2013-05-29 12:19 hgbot Status closed => resolved
2013-05-29 12:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/61e769550c1c425420d98b086163022a034e0c1a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/61e769550c1c425420d98b086163022a034e0c1a [^]
2013-06-06 11:56 guilleaer Note Added: 0059235
2013-06-06 11:56 guilleaer Status resolved => closed
2015-10-05 12:32 plujan Relationship added related to 0031040
2015-10-05 13:23 plujan Relationship added related to 0031043


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker