Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023747
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-05-06 23:352013-06-06 11:58
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision763b38fe4d75
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP21SCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023747: Little problem with document sequence

DescriptionLittle problem with document sequence
Steps To Reproduce-Login in web pos
-verify that ticket documentno is XXX
-go to cash up window or cash management window and push in cancel
-verify that now the documentno sequence is XXX+1

If you logout and login, you will see again documentno XXX

The application should not increase the documentno if you navigate to the above windows.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058677)
hgbot (developer)
2013-05-16 19:06

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 763b38fe4d7520fc561a3369cc20afe3ed1752df
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu May 16 19:06:42 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]

Fixed issue 23747. Document sequence will not be increased every time the user navigates to the main window

---
M src/org/openbravo/retail/posterminal/term/Terminal.java
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0058864)
hgbot (developer)
2013-05-23 07:52

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: 763b38fe4d7520fc561a3369cc20afe3ed1752df
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu May 16 19:06:42 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]

Fixed issue 23747. Document sequence will not be increased every time the user navigates to the main window

---
M src/org/openbravo/retail/posterminal/term/Terminal.java
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0059001)
guilleaer (developer)
2013-05-28 17:51

verified
(0059026)
hgbot (developer)
2013-05-29 12:19

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 763b38fe4d7520fc561a3369cc20afe3ed1752df
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu May 16 19:06:42 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]

Fixed issue 23747. Document sequence will not be increased every time the user navigates to the main window

---
M src/org/openbravo/retail/posterminal/term/Terminal.java
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0059238)
guilleaer (developer)
2013-06-06 11:58

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-06 23:35 jecharri New Issue
2013-05-06 23:35 jecharri Assigned To => marvintm
2013-05-16 19:06 hgbot Checkin
2013-05-16 19:06 hgbot Note Added: 0058677
2013-05-16 19:06 hgbot Status new => resolved
2013-05-16 19:06 hgbot Resolution open => fixed
2013-05-16 19:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]
2013-05-23 07:52 hgbot Checkin
2013-05-23 07:52 hgbot Note Added: 0058864
2013-05-23 07:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]
2013-05-28 17:51 guilleaer Review Assigned To => guilleaer
2013-05-28 17:51 guilleaer Note Added: 0059001
2013-05-28 17:51 guilleaer Status resolved => closed
2013-05-28 17:51 guilleaer Fixed in Version => RMP23
2013-05-29 12:19 hgbot Checkin
2013-05-29 12:19 hgbot Note Added: 0059026
2013-05-29 12:19 hgbot Status closed => resolved
2013-05-29 12:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/763b38fe4d7520fc561a3369cc20afe3ed1752df [^]
2013-06-06 11:58 guilleaer Note Added: 0059238
2013-06-06 11:58 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker