Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023547
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-04-15 11:192013-06-06 12:03
ReporterjecharriView Statuspublic 
Assigned Toguilleaer 
PriorityurgentResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision4f4766052b61
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP21SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023547: Impossible to pay with credit

DescriptionImpossible to pay with credit

Currently in web POS you need to configure the BP credit limit higher than 0 but it can happen that the BP has created credit through a payment done.

In this case the current balance will be -1000 (for example) and the credit limit 0. In this case the BP it should be able to pay with generated credit
Steps To Reproduce-create a payment in whose amount is 1000 and associate to one BP

-go to web POS and verify that if you do not change the credit limit you are not going to be able to pay with credit
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058707)
hgbot (developer)
2013-05-20 19:14

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 4f4766052b613939a4ed9f2445138a64d78b389e
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon May 20 19:13:21 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]

fixed issue 23547: If a customer has credit, it can be used even with credit limit 0

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0058868)
hgbot (developer)
2013-05-23 07:52

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: 4f4766052b613939a4ed9f2445138a64d78b389e
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon May 20 19:13:21 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]

fixed issue 23547: If a customer has credit, it can be used even with credit limit 0

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0059030)
hgbot (developer)
2013-05-29 12:19

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 4f4766052b613939a4ed9f2445138a64d78b389e
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon May 20 19:13:21 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]

fixed issue 23547: If a customer has credit, it can be used even with credit limit 0

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0059243)
guilleaer (developer)
2013-06-06 12:03

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-04-15 11:19 jecharri New Issue
2013-04-15 11:19 jecharri Assigned To => migueldejuana
2013-04-15 12:06 migueldejuana Assigned To migueldejuana => guilleaer
2013-04-30 09:14 guilleaer Target Version RMP22 => RMP23
2013-05-20 19:14 hgbot Checkin
2013-05-20 19:14 hgbot Note Added: 0058707
2013-05-20 19:14 hgbot Status new => resolved
2013-05-20 19:14 hgbot Resolution open => fixed
2013-05-20 19:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]
2013-05-23 07:52 hgbot Checkin
2013-05-23 07:52 hgbot Note Added: 0058868
2013-05-23 07:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]
2013-05-28 11:55 marvintm Review Assigned To => marvintm
2013-05-28 11:55 marvintm Status resolved => closed
2013-05-29 12:19 hgbot Checkin
2013-05-29 12:19 hgbot Note Added: 0059030
2013-05-29 12:19 hgbot Status closed => resolved
2013-05-29 12:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/4f4766052b613939a4ed9f2445138a64d78b389e [^]
2013-06-06 12:03 guilleaer Note Added: 0059243
2013-06-06 12:03 guilleaer Status resolved => closed
2013-06-06 12:03 guilleaer Fixed in Version => RMP23


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker