Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023466
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2013-04-02 06:502013-07-23 18:24
ReportersureshbabuView Statuspublic 
Assigned Tomarvintm 
PriorityhighResolutionfixedFixed in VersionRMP24
StatusclosedFix in branchFixed in SCM revisionf35c1678b30d
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023466: When i try to apply a promotion pack which is already expired, at POS there is no warning or error message appears

DescriptionWhen i try to apply a promotion pack which is already expired, at POS there is no warning or error message appears
Steps To ReproduceWhen i try to apply a promotion pack which is already expired, at POS there is no warning or error message appears (Refer the screen shot for details)
TagsNo tags attached.
Attached Filespng file icon When i try to apply a promotion pack which is already expired, at POS there is no warning or error message appears.png [^] (327,335 bytes) 2013-04-02 06:50

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058070)
dmitry_mezentsev (developer)
2013-04-19 21:25

I propose even not to load expired packs (as any other discounts) in the POS or at least not to show them in the UI.
At the same time we need to verify if it is required technically to retrieve old orders info and doing returns (maybe should be some special option for it).
(0059404)
hgbot (developer)
2013-06-12 17:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f35c1678b30dba12da473a5b8b5b3c2caf270aa0
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Jun 12 17:39:22 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f35c1678b30dba12da473a5b8b5b3c2caf270aa0 [^]

fixed issue 23466: Packs which are not valid because the start/end date are not shown in product/categories browser

---
M src/org/openbravo/retail/posterminal/master/Category.java
M src/org/openbravo/retail/posterminal/master/Product.java
---
(0059531)
hgbot (developer)
2013-06-19 16:25

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: 4969943c8ee83c04ca96404e82732d62d00477cc
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Jun 19 16:25:36 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/4969943c8ee83c04ca96404e82732d62d00477cc [^]

related to issue 23466: Check the ending date of the pack in the client side

---
M web/org.openbravo.retail.discounts/js/promotion-pack.js
---
(0059598)
hgbot (developer)
2013-06-20 09:47

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: c087bd46d0673d77d27faa90c93a53baf153e0a9
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Jun 20 09:46:46 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/c087bd46d0673d77d27faa90c93a53baf153e0a9 [^]

related to issue 23466: get hardcoded messages from backend

---
M web/org.openbravo.retail.discounts/js/promotion-pack.js
---
(0059599)
hgbot (developer)
2013-06-20 09:47

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f7e70f4d37950f91a21eb8baef3fe679f421e254
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Jun 20 09:47:33 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f7e70f4d37950f91a21eb8baef3fe679f421e254 [^]

related to issue 23466: add messages

---
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0059746)
hgbot (developer)
2013-06-28 10:25

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: f35c1678b30dba12da473a5b8b5b3c2caf270aa0
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Jun 12 17:39:22 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/f35c1678b30dba12da473a5b8b5b3c2caf270aa0 [^]

fixed issue 23466: Packs which are not valid because the start/end date are not shown in product/categories browser

---
M src/org/openbravo/retail/posterminal/master/Category.java
M src/org/openbravo/retail/posterminal/master/Product.java
---
(0059762)
hgbot (developer)
2013-06-28 10:31

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: f7e70f4d37950f91a21eb8baef3fe679f421e254
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Jun 20 09:47:33 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/f7e70f4d37950f91a21eb8baef3fe679f421e254 [^]

related to issue 23466: add messages

---
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0060199)
guilleaer (developer)
2013-07-23 18:24

reclosing

- Issue History
Date Modified Username Field Change
2013-04-02 06:50 sureshbabu New Issue
2013-04-02 06:50 sureshbabu Assigned To => marvintm
2013-04-02 06:50 sureshbabu File Added: When i try to apply a promotion pack which is already expired, at POS there is no warning or error message appears.png
2013-04-19 21:25 dmitry_mezentsev Note Added: 0058070
2013-06-12 17:40 hgbot Checkin
2013-06-12 17:40 hgbot Note Added: 0059404
2013-06-12 17:40 hgbot Status new => resolved
2013-06-12 17:40 hgbot Resolution open => fixed
2013-06-12 17:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f35c1678b30dba12da473a5b8b5b3c2caf270aa0 [^]
2013-06-19 16:25 hgbot Checkin
2013-06-19 16:25 hgbot Note Added: 0059531
2013-06-20 09:47 hgbot Checkin
2013-06-20 09:47 hgbot Note Added: 0059598
2013-06-20 09:47 hgbot Checkin
2013-06-20 09:47 hgbot Note Added: 0059599
2013-06-20 10:30 marvintm Review Assigned To => marvintm
2013-06-20 10:30 marvintm Status resolved => closed
2013-06-20 10:30 marvintm Fixed in Version => RMP24
2013-06-28 10:25 hgbot Checkin
2013-06-28 10:25 hgbot Note Added: 0059746
2013-06-28 10:25 hgbot Status closed => resolved
2013-06-28 10:25 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f35c1678b30dba12da473a5b8b5b3c2caf270aa0 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/f35c1678b30dba12da473a5b8b5b3c2caf270aa0 [^]
2013-06-28 10:31 hgbot Checkin
2013-06-28 10:31 hgbot Note Added: 0059762
2013-07-23 18:24 guilleaer Note Added: 0060199
2013-07-23 18:24 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker