Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023157
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformminorN/A2013-02-25 13:012017-04-10 14:37
ReporteralostaleView Statuspublic 
Assigned Toplatform 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision970beef83a50
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023157: Allow to define different defaults in UserInfoWidgetActionHandler

DescriptionExtend UserInfoWidgetActionHandler to allow to set all defaults. This can be used by other applications to set their defaults.

Currently it is only possible to define default role, but not client, org, warehouse nor language.
Steps To Reproduce-
Tagsmobile
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0020868 closedalostale Allow to define different default role in UserInfoWidgetActionHandler 
related to defect 00232073.0MP21 closedAugustoMauch It is not possible to change default organization on Profile menu 

-  Notes
(0056835)
hgbot (developer)
2013-02-28 12:29

Repository: erp/devel/pi
Changeset: 970beef83a50e1ee9e3d8372acf5f23fcb6d84de
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 25 13:50:23 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/970beef83a50e1ee9e3d8372acf5f23fcb6d84de [^]

fixed issue 23157: Allow to define different defaults in UserInfoWidgetActionHandler

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/UserInfoWidgetActionHandler.java
---
(0056906)
AugustoMauch (developer)
2013-03-01 17:05

Reopened because it is causing a regression [1]

[1] https://issues.openbravo.com/view.php?id=23207 [^]
(0056907)
hgbot (developer)
2013-03-01 17:09

Repository: erp/devel/pi
Changeset: d626f6383b2770a85ee49284797a2c00ec2c0980
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Mar 01 17:07:46 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d626f6383b2770a85ee49284797a2c00ec2c0980 [^]

Fixes issue 23207, related to issue 23157. Backouts fix of 23157

The fix of 23157 [1] is causing 23207 and making the automated tests fail. That fix is backed out so that the automated tests get fixed.

[1] https://code.openbravo.com/erp/devel/pi/rev/970beef83a50e1ee9e3d8372acf5f23fcb6d84de [^]

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/UserInfoWidgetActionHandler.java
---
(0056929)
hudsonbot (developer)
2013-03-02 05:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f5db629e7058 [^]

Maturity status: Test
(0056951)
hudsonbot (developer)
2013-03-02 05:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f5db629e7058 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-02-25 13:01 alostale New Issue
2013-02-25 13:01 alostale Assigned To => alostale
2013-02-25 13:01 alostale Modules => Core
2013-02-25 13:01 alostale Triggers an Emergency Pack => No
2013-02-25 13:01 alostale Relationship added related to 0020868
2013-02-25 13:02 alostale Tag Attached: mobile
2013-02-25 13:02 alostale Review Assigned To => marvintm
2013-02-25 13:50 alostale Description Updated View Revisions
2013-02-28 12:29 hgbot Checkin
2013-02-28 12:29 hgbot Note Added: 0056835
2013-02-28 12:29 hgbot Status new => resolved
2013-02-28 12:29 hgbot Resolution open => fixed
2013-02-28 12:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/970beef83a50e1ee9e3d8372acf5f23fcb6d84de [^]
2013-03-01 17:04 AugustoMauch Relationship added related to 0023207
2013-03-01 17:05 AugustoMauch Note Added: 0056906
2013-03-01 17:05 AugustoMauch Status resolved => new
2013-03-01 17:05 AugustoMauch Resolution fixed => open
2013-03-01 17:09 hgbot Checkin
2013-03-01 17:09 hgbot Note Added: 0056907
2013-03-02 05:48 hudsonbot Checkin
2013-03-02 05:48 hudsonbot Note Added: 0056929
2013-03-02 05:48 hudsonbot Checkin
2013-03-02 05:48 hudsonbot Note Added: 0056951
2013-03-04 07:35 alostale Target Version 3.0MP21 =>
2017-04-10 14:37 alostale Assigned To alostale => platform


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker