Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023059
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-02-12 17:272013-04-03 12:55
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityhighResolutionfixedFixed in VersionRMP20
StatusclosedFix in branchFixed in SCM revisiond0341b9f40b3
ProjectionnoneETAnoneTarget VersionRMP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP19.1SCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023059: Problems when you pay with credit

DescriptionProblems when you pay with credit
Steps To Reproduce-Configure one "Pos terminal type" and one BP to use credit (credit limit 100)

-Go to the Web POS and create an order and invoice at the same time whose value is 80

-Now the BP balance is 80

-Again create a return order an invoice whose value is 80. You will see that you will get an error. This is wrong, when you are creating a return order you should return the balance to 0
TagsNo tags attached.
Attached Filespng file icon error.png [^] (63,290 bytes) 2013-02-12 17:27

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0056452)
hgbot (developer)
2013-02-14 17:23

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 5735c51fb1941fc4a44659327f5b0c734162999a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Feb 14 17:23:03 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]

Fixed issue 23059. Credit will be updated correctly on returns

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0056479)
hgbot (developer)
2013-02-15 09:08

Repository: erp/pmods/org.openbravo.retail.posterminal.layaways
Changeset: 5735c51fb1941fc4a44659327f5b0c734162999a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Feb 14 17:23:03 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.layaways/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]

Fixed issue 23059. Credit will be updated correctly on returns

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0056481)
migueldejuana (developer)
2013-02-15 09:42

Tested and reviewed.
(0056726)
jecharri (developer)
2013-02-22 09:08

Reopened because the problem is not solved.

Follow the steps to reproduce and you will get the same error
(0056750)
hgbot (developer)
2013-02-25 18:07

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d0341b9f40b33c1833d97cbb6ac1a9f8c404a304
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 25 17:55:45 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d0341b9f40b33c1833d97cbb6ac1a9f8c404a304 [^]

Fixed issue 23059. A different popup will be shown in case of returns.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/pointofsale/view/modals/modalcreditsales.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0056806)
migueldejuana (developer)
2013-02-27 12:58

Fixed and reviewed in b82775044b7a
(0057643)
hgbot (developer)
2013-04-02 20:07

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: 5735c51fb1941fc4a44659327f5b0c734162999a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Feb 14 17:23:03 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]

Fixed issue 23059. Credit will be updated correctly on returns

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0057654)
hgbot (developer)
2013-04-02 20:09

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: d0341b9f40b33c1833d97cbb6ac1a9f8c404a304
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 25 17:55:45 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/d0341b9f40b33c1833d97cbb6ac1a9f8c404a304 [^]

Fixed issue 23059. A different popup will be shown in case of returns.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/pointofsale/view/modals/modalcreditsales.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---

- Issue History
Date Modified Username Field Change
2013-02-12 17:27 jecharri New Issue
2013-02-12 17:27 jecharri Assigned To => adrianromero
2013-02-12 17:27 jecharri File Added: error.png
2013-02-14 13:28 marvintm Assigned To adrianromero => marvintm
2013-02-14 17:06 marvintm Review Assigned To => migueldejuana
2013-02-14 17:23 hgbot Checkin
2013-02-14 17:23 hgbot Note Added: 0056452
2013-02-14 17:23 hgbot Status new => resolved
2013-02-14 17:23 hgbot Resolution open => fixed
2013-02-14 17:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]
2013-02-15 09:08 hgbot Checkin
2013-02-15 09:08 hgbot Note Added: 0056479
2013-02-15 09:08 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.layaways/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]
2013-02-15 09:42 migueldejuana Note Added: 0056481
2013-02-15 09:42 migueldejuana Status resolved => closed
2013-02-15 09:42 migueldejuana Fixed in Version => RMP20
2013-02-22 09:08 jecharri Note Added: 0056726
2013-02-22 09:08 jecharri Status closed => new
2013-02-22 09:08 jecharri Resolution fixed => open
2013-02-22 09:08 jecharri Fixed in Version RMP20 =>
2013-02-25 18:07 hgbot Checkin
2013-02-25 18:07 hgbot Note Added: 0056750
2013-02-25 18:07 hgbot Status new => resolved
2013-02-25 18:07 hgbot Resolution open => fixed
2013-02-25 18:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.layaways/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d0341b9f40b33c1833d97cbb6ac1a9f8c404a304 [^]
2013-02-27 12:58 migueldejuana Note Added: 0056806
2013-02-27 12:58 migueldejuana Status resolved => closed
2013-02-27 12:58 migueldejuana Fixed in Version => RMP20
2013-04-02 20:07 hgbot Checkin
2013-04-02 20:07 hgbot Note Added: 0057643
2013-04-02 20:07 hgbot Status closed => resolved
2013-04-02 20:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d0341b9f40b33c1833d97cbb6ac1a9f8c404a304 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^]
2013-04-02 20:09 hgbot Checkin
2013-04-02 20:09 hgbot Note Added: 0057654
2013-04-02 20:09 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/5735c51fb1941fc4a44659327f5b0c734162999a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/d0341b9f40b33c1833d97cbb6ac1a9f8c404a304 [^]
2013-04-03 12:55 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker