Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022874
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformmajorhave not tried2013-01-23 15:472014-07-21 02:03
ReportermtaalView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionbdbc4e96cb77
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022874: Implement rich and masked text field

DescriptionSee these howtos:

http://wiki.openbravo.com/wiki/How_to_add_a_masked_text_field [^]

http://wiki.openbravo.com/wiki/How_to_add_a_rich_text_field_and_column [^]
Steps To ReproduceSee howtos:
http://wiki.openbravo.com/wiki/How_to_add_a_masked_text_field [^]
http://wiki.openbravo.com/wiki/How_to_add_a_rich_text_field_and_column [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0022933 closeddbaz Keypress and tab issue in rich text field 

-  Notes
(0055780)
hgbot (developer)
2013-01-24 00:30

Repository: erp/devel/pi
Changeset: bdbc4e96cb774e7776ee69ade87b12fb34505e76
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jan 24 00:29:43 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bdbc4e96cb774e7776ee69ade87b12fb34505e76 [^]

Related to issue 22874: Implement rich and masked text field
First implementation

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-text.js
M modules/org.openbravo.client.application/web/org.openbravo.userinterface.smartclient/openbravo/skins/Default/org.openbravo.client.application/ob-form-styles.js
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_REFERENCE.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_TAB.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_TABLE.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/OBCLKER_UIDEFINITION.xml
A modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-richtext.js
A modules/org.openbravo.client.kernel/src-db/database/model/tables/OBCLKER_REF_MASK.xml
A modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/MaskedStringUIDefinition.java
A modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/RichTextUIDefinition.java
---
(0055781)
hgbot (developer)
2013-01-24 00:30

Repository: erp/mods/org.openbravo.client.application.examples
Changeset: d8f2d9d8dd9f439f45715b34774a8114e4f65cba
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jan 24 00:30:24 2013 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.client.application.examples/rev/d8f2d9d8dd9f439f45715b34774a8114e4f65cba [^]

Related to issue 22874: Implement rich and masked text field

---
M src-db/database/model/modifiedTables/C_ORDER.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MODULE.xml
M src-db/database/sourcedata/AD_MODULE_DEPENDENCY.xml
M src-db/database/sourcedata/AD_REFERENCE.xml
---
(0055797)
hgbot (developer)
2013-01-24 10:58

Repository: erp/devel/pi
Changeset: 388822223199349f9b63feec2a8f48fc3decd9cc
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jan 24 10:58:21 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/388822223199349f9b63feec2a8f48fc3decd9cc [^]

Related to issue 22874: Implement rich and masked text field
Solved small db model issues

---
M modules/org.openbravo.client.kernel/src-db/database/model/tables/OBCLKER_REF_MASK.xml
---
(0055821)
hudsonbot (developer)
2013-01-24 21:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fbbe21bdfeff [^]

Maturity status: Test
(0055824)
hudsonbot (developer)
2013-01-24 21:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fbbe21bdfeff [^]

Maturity status: Test
(0055963)
mtaal (developer)
2013-01-30 10:03

Related issues reported to isomorphic:
http://forums.smartclient.com/showthread.php?t=25134 [^]
http://forums.smartclient.com/showthread.php?t=25173 [^]
(0055965)
mtaal (developer)
2013-01-30 10:09

Can be reviewed
(0055966)
mtaal (developer)
2013-01-30 10:10

Implemented
(0056035)
hgbot (developer)
2013-02-01 09:08

Repository: erp/devel/pi
Changeset: 0977425719fca36ab07f31cac664627f49aae618
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Fri Feb 01 09:08:22 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0977425719fca36ab07f31cac664627f49aae618 [^]

Related to issue 22874: Implement rich and masked text field
Solve db errors/issues

---
M modules/org.openbravo.client.kernel/src-db/database/model/tables/OBCLKER_REF_MASK.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_FIELD.xml
---
(0056106)
hudsonbot (developer)
2013-02-01 22:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test
(0056137)
AugustoMauch (developer)
2013-02-04 17:54

This issue has been reopened because the rich text fields do not work in Chrome (version 23.0.1271.64) using Linux
(0056353)
hgbot (developer)
2013-02-12 00:20

Repository: erp/devel/pi
Changeset: fda0bc8e8d8028906a3bf19ffda2a52a2f403653
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Feb 12 00:19:58 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fda0bc8e8d8028906a3bf19ffda2a52a2f403653 [^]

Related to issue 22874: Implement rich and masked text field
Added mask validation using reg exp

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-text.js
---
(0056572)
hudsonbot (developer)
2013-02-20 04:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d828167a9e83 [^]

Maturity status: Test
(0056831)
hgbot (developer)
2013-02-28 11:23

Repository: erp/devel/pi
Changeset: 73c383bd5cd8950a4f2fad637d2b95c9811655e4
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Feb 28 11:23:35 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/73c383bd5cd8950a4f2fad637d2b95c9811655e4 [^]

Related to issue 22874, Implement rich and masked text field

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-text.js
---
(0056927)
hudsonbot (developer)
2013-03-02 05:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f5db629e7058 [^]

Maturity status: Test
(0068741)
mtaal (developer)
2014-07-21 02:01

Resolved
(0068742)
mtaal (developer)
2014-07-21 02:03

resolved
(0068743)
mtaal (developer)
2014-07-21 02:03

Closing, was solved a long time back

- Issue History
Date Modified Username Field Change
2013-01-23 15:47 mtaal New Issue
2013-01-23 15:47 mtaal Assigned To => mtaal
2013-01-23 15:47 mtaal Modules => Core
2013-01-23 15:47 mtaal Triggers an Emergency Pack => No
2013-01-23 15:47 mtaal Review Assigned To => AugustoMauch
2013-01-24 00:30 hgbot Checkin
2013-01-24 00:30 hgbot Note Added: 0055780
2013-01-24 00:30 hgbot Checkin
2013-01-24 00:30 hgbot Note Added: 0055781
2013-01-24 10:58 hgbot Checkin
2013-01-24 10:58 hgbot Note Added: 0055797
2013-01-24 21:40 hudsonbot Checkin
2013-01-24 21:40 hudsonbot Note Added: 0055821
2013-01-24 21:40 hudsonbot Checkin
2013-01-24 21:40 hudsonbot Note Added: 0055824
2013-01-30 10:03 mtaal Note Added: 0055963
2013-01-30 10:09 mtaal Relationship added related to 0022933
2013-01-30 10:09 mtaal Status new => scheduled
2013-01-30 10:09 mtaal Note Added: 0055965
2013-01-30 10:09 mtaal fix_in_branch => pi
2013-01-30 10:10 mtaal Note Added: 0055966
2013-01-30 10:10 mtaal Status scheduled => resolved
2013-01-30 10:10 mtaal Fixed in Version => 3.0MP20
2013-01-30 10:10 mtaal Fixed in SCM revision => .
2013-01-30 10:10 mtaal Resolution open => fixed
2013-02-01 09:08 hgbot Checkin
2013-02-01 09:08 hgbot Note Added: 0056035
2013-02-01 22:29 hudsonbot Checkin
2013-02-01 22:29 hudsonbot Note Added: 0056106
2013-02-04 17:54 AugustoMauch Note Added: 0056137
2013-02-04 17:54 AugustoMauch Status resolved => new
2013-02-04 17:54 AugustoMauch Resolution fixed => open
2013-02-04 17:54 AugustoMauch Fixed in Version 3.0MP20 =>
2013-02-12 00:20 hgbot Checkin
2013-02-12 00:20 hgbot Note Added: 0056353
2013-02-20 04:49 hudsonbot Checkin
2013-02-20 04:49 hudsonbot Note Added: 0056572
2013-02-28 07:24 mtaal Target Version 3.0MP20 =>
2013-02-28 07:24 mtaal fix_in_branch pi =>
2013-02-28 11:23 hgbot Checkin
2013-02-28 11:23 hgbot Note Added: 0056831
2013-03-02 05:48 hudsonbot Checkin
2013-03-02 05:48 hudsonbot Note Added: 0056927
2014-07-21 02:01 mtaal Status new => scheduled
2014-07-21 02:01 mtaal Note Added: 0068741
2014-07-21 02:01 mtaal fix_in_branch => pi
2014-07-21 02:03 mtaal Note Added: 0068742
2014-07-21 02:03 mtaal Status scheduled => resolved
2014-07-21 02:03 mtaal Fixed in SCM revision . => .http://code.openbravo.com/erp/devel/pi/rev/bdbc4e96cb774e7776ee69ade87b12fb34505e76 [^]
2014-07-21 02:03 mtaal Resolution open => fixed
2014-07-21 02:03 mtaal Note Added: 0068743
2014-07-21 02:03 mtaal Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker