Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022801
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-01-15 12:012013-01-18 20:26
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP19
StatusclosedFix in branchFixed in SCM revision0c4ba1500f38
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2012-11-21
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/68caae8e955a [^]
Triggers an Emergency PackNo
Summary

0022801: ID shown when writing the whole name in Product selector

DescriptionID shown when writing the whole name in Product selector
Steps To ReproduceAs group admin role:
   Go to Sales Order window and create a header
   Create a new line and include the whole product name in the Product field (without selecting it from the combo box)
   Check that the product identifier appears
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00216763.0MP16 closedAugustoMauch Different behaviour in grid or form for product selector 
related to defect 00218823.0MP18 closedshankarb Business partner selector fails with display logic 
blocks defect 0022550 closedpramakrishnan Cannot modify product on g/l item transaction in financial account 

-  Notes
(0055516)
ngarcia (developer)
2013-01-15 12:03

I have been able to reproduce it in pi and in MP18.2 but not in MP17.2
(0055523)
AugustoMauch (developer)
2013-01-15 16:41

Test plan:

Check that issues 22801, 21882 and 21676 are no longer reproducible.
(0055524)
hgbot (developer)
2013-01-15 16:42

Repository: erp/devel/pi
Changeset: 0c4ba1500f38415746e9927d32c769071bd4b33d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Jan 15 16:39:56 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0c4ba1500f38415746e9927d32c769071bd4b33d [^]

Fixes issue 22801: ID of product not shown if the full product name is entered

The problem was that in the changed function the setElementValue was being called passing newValue as an argument. If the product name is not entered completely, then newValue will be the incomplete name and nothing wrong will happen. The problem is that if the full name is entered, newValue is the product ID, and when it is passed as an argument to setElementValue it is shown as is.

This has been fixed by passing the newValue to the mapValueToDisplay function. If newValue is a partial name the function will return the partial name, and if newValue is the product ID, it will return the product full name.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0055527)
hgbot (developer)
2013-01-15 18:29

Repository: erp/devel/pi
Changeset: 867383d4dab0d1d662ec3886e6d7e31ef4c5b306
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Jan 15 18:29:01 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/867383d4dab0d1d662ec3886e6d7e31ef4c5b306 [^]

Related to issue 22801: Refactors fix to prevent regression

The fix has been refactored, because the previous approach was causing a regression. Now, the mapValueToDisplay will only be used if the newValue is an UUID, and that function will not be used in the filterDataBoundPickList function (it was not needed).

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0055528)
shankarb (developer)
2013-01-15 18:39

Code Reviewed and tested in pi changeset 867383d4dab0
(0055625)
hudsonbot (developer)
2013-01-18 20:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4cd4a6cc38e0 [^]

Maturity status: Test
(0055626)
hudsonbot (developer)
2013-01-18 20:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4cd4a6cc38e0 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-01-15 12:01 ngarcia New Issue
2013-01-15 12:01 ngarcia Assigned To => dmiguelez
2013-01-15 12:01 ngarcia Modules => Core
2013-01-15 12:01 ngarcia Triggers an Emergency Pack => No
2013-01-15 12:02 ngarcia Regression level => Production - QA Approved
2013-01-15 12:02 ngarcia Issue Monitored: networkb
2013-01-15 12:03 ngarcia Note Added: 0055516
2013-01-15 12:14 ngarcia Assigned To dmiguelez => AugustoMauch
2013-01-15 12:14 ngarcia Category 07. Sales management => A. Platform
2013-01-15 12:44 AugustoMauch Target Version => 3.0MP20
2013-01-15 13:20 dmiguelez Relationship added blocks 0022550
2013-01-15 16:01 AugustoMauch Regression date => 2012-11-21
2013-01-15 16:01 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/68caae8e955a [^]
2013-01-15 16:31 AugustoMauch Relationship added related to 0021676
2013-01-15 16:31 AugustoMauch Relationship added related to 0021882
2013-01-15 16:41 AugustoMauch Note Added: 0055523
2013-01-15 16:41 AugustoMauch Issue Monitored: shankarb
2013-01-15 16:42 AugustoMauch Review Assigned To => shankarb
2013-01-15 16:42 hgbot Checkin
2013-01-15 16:42 hgbot Note Added: 0055524
2013-01-15 16:42 hgbot Status new => resolved
2013-01-15 16:42 hgbot Resolution open => fixed
2013-01-15 16:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0c4ba1500f38415746e9927d32c769071bd4b33d [^]
2013-01-15 18:29 hgbot Checkin
2013-01-15 18:29 hgbot Note Added: 0055527
2013-01-15 18:39 shankarb Note Added: 0055528
2013-01-15 18:39 shankarb Status resolved => closed
2013-01-15 18:39 shankarb Fixed in Version => 3.0MP19
2013-01-18 20:26 hudsonbot Checkin
2013-01-18 20:26 hudsonbot Note Added: 0055625
2013-01-18 20:26 hudsonbot Checkin
2013-01-18 20:26 hudsonbot Note Added: 0055626


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker