Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022771
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-01-10 17:542013-01-25 13:32
ReporterjecharriView Statuspublic 
Assigned Toguilleaer 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionfc99b4bed4f4
ProjectionnoneETAnoneTarget VersionRMP19
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022771: Impossible to create two times one business partner with the same name

DescriptionImpossible to create two times one business partner with the same name
Steps To Reproduce-Go to web POS
-create a BP with name "hola"
-create again a BP with name "hola"

You will see that it is impossible.

The problem is that we are creating a user every time and the table ad_user has the constraint:"CONSTRAINT ad_user_un_username UNIQUE (username)",
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055480)
hgbot (developer)
2013-01-11 12:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fc99b4bed4f4853edc97b4043752683ca5ad168f
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Jan 11 12:29:26 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fc99b4bed4f4853edc97b4043752683ca5ad168f [^]

Fixed issue 22771: BP with same name can be created without problems from Web POS.
Search key of created BP is now more readable trying to use the name of the customer (without spaces)
If the name of the BP is changed from Web POS the associated user first name is updated
Credit limit is not set to 0 when a BP is edited from web POS

---
M src/org/openbravo/retail/posterminal/CustomerLoader.java
M web/org.openbravo.retail.posterminal/js/model/businesspartner.js
---

- Issue History
Date Modified Username Field Change
2013-01-10 17:54 jecharri New Issue
2013-01-10 17:54 jecharri Assigned To => guilleaer
2013-01-11 12:33 hgbot Checkin
2013-01-11 12:33 hgbot Note Added: 0055480
2013-01-11 12:33 hgbot Status new => resolved
2013-01-11 12:33 hgbot Resolution open => fixed
2013-01-11 12:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fc99b4bed4f4853edc97b4043752683ca5ad168f [^]
2013-01-25 13:32 marvintm Review Assigned To => marvintm
2013-01-25 13:32 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker