Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022733
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-01-08 10:342013-01-25 14:19
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP19
StatusclosedFix in branchFixed in SCM revision8f21aefaae39
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022733: Impossible to work with product with non instantiable attributes

DescriptionImpossible to work with product with non instantiable attributes

Steps To Reproduce-create a product with attributes set and one of them as instantiable and mandatory.

-create a stock for this product.
-make a sale in the web POS
-you will see that it is impossible to synchronize the order.

The problem is that web POS is inserting only the product and not the attributeset-instance_id
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055373)
hgbot (developer)
2013-01-08 12:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 8f21aefaae39b6b8ce02fb2ab02981dbd2987c8b
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Jan 08 12:40:05 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8f21aefaae39b6b8ce02fb2ab02981dbd2987c8b [^]

Fixed issue 22733. Orders with products with attributes will work correctly.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0055865)
guilleaer (developer)
2013-01-25 14:19

verified

- Issue History
Date Modified Username Field Change
2013-01-08 10:34 jecharri New Issue
2013-01-08 10:34 jecharri Assigned To => marvintm
2013-01-08 12:40 hgbot Checkin
2013-01-08 12:40 hgbot Note Added: 0055373
2013-01-08 12:40 hgbot Status new => resolved
2013-01-08 12:40 hgbot Resolution open => fixed
2013-01-08 12:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8f21aefaae39b6b8ce02fb2ab02981dbd2987c8b [^]
2013-01-25 14:19 guilleaer Review Assigned To => guilleaer
2013-01-25 14:19 guilleaer Note Added: 0055865
2013-01-25 14:19 guilleaer Status resolved => closed
2013-01-25 14:19 guilleaer Fixed in Version => RMP19


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker