Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022690
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2012-12-27 17:572013-01-03 13:12
ReportersureshbabuView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisioncb19f41d5523
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browserGoogle Chrome
ModulesOpenbravo 3.0
Regression levelProduction - Confirmed Stable
Regression date2011-10-26
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f9b05776d657 [^]
Triggers an Emergency PackNo
Summary

0022690: [Reg] In Return to Vendor window, Save icon in tool bar is disabled in grid view

Description[Reg] In Return to Vendor window, at grid view, when an new record is inserted, Save icon in tool bar is disabled also when i click Ctrl + S to save the record there is no response.

Note: Above icon is enabled in Mp18
Steps To ReproduceLogin as Openbravo/openbravo
Change the role as QA Testing Admin
Navigate to Return to vendor window
Click Ctrl + I to insert new row in grid view
Then select BP: Vendor A

Defect: Click Ctrl + S to save the record, there is no response. Also the Save icon in Tool bar is disabled.(Above functionality is working fine in form view. )


Note: Also the above functionality is working fine in Mp18 release.
TagsNo tags attached.
Attached Filespng file icon Save icon not getting enabled in tool bar at Return to vendor window.png [^] (182,503 bytes) 2012-12-27 17:57

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055283)
dmitry_mezentsev (developer)
2012-12-28 19:14

For me it happens the same in the Return to Customer but I can also reproduce it in MP15.

So I am not sure that it is a regression or if it is - it might be very old one.

Also Save button is not always absent. For example, after I finally save a record (that does not have Save button) in a grid (for example by clicking on one of the existing records in grid) then the next record I create has the Save button.
(0055286)
hgbot (developer)
2012-12-31 11:41

Repository: erp/devel/pi
Changeset: cb19f41d5523ab127140d43d53c6f6e1baf02b3f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Dec 31 11:05:17 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cb19f41d5523ab127140d43d53c6f6e1baf02b3f [^]

Fixes issue 22690: Save button is enabled in Return to Vendor window

The save button was not being enabled because there was one mandatory field (grandTotalAmount) that was empty. The thing is that this field belongs to the status bar, so it is read only, and should not be taken into account when cheking if all the mandatory fields have been set.

The allRequiredFieldsSet function has been modified so that it doesn't take into account the fields that are not displayed in the form (i.e. the status bar fields)

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0055287)
shankarb (developer)
2012-12-31 12:03

Code Review done and Verified in pi @ changeset cb19f41d5523
(0055342)
hudsonbot (developer)
2013-01-03 13:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/792728467ed0 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-12-27 17:57 sureshbabu New Issue
2012-12-27 17:57 sureshbabu Assigned To => dmiguelez
2012-12-27 17:57 sureshbabu File Added: Save icon not getting enabled in tool bar at Return to vendor window.png
2012-12-27 17:57 sureshbabu Web browser => Google Chrome
2012-12-27 17:57 sureshbabu Modules => Openbravo 3.0
2012-12-27 17:57 sureshbabu Triggers an Emergency Pack => No
2012-12-27 18:00 sureshbabu Web browser Google Chrome => Google Chrome
2012-12-27 18:00 sureshbabu Regression level => QA functional test
2012-12-28 09:18 Sandrahuguet Web browser Google Chrome => Google Chrome
2012-12-28 09:18 Sandrahuguet Assigned To dmiguelez => AugustoMauch
2012-12-28 09:18 Sandrahuguet Category 03. Procurement management => A. Platform
2012-12-28 19:14 dmitry_mezentsev Note Added: 0055283
2012-12-29 17:49 sureshbabu Web browser Google Chrome => Google Chrome
2012-12-29 17:49 sureshbabu Regression level QA functional test =>
2012-12-31 11:05 AugustoMauch Issue Monitored: shankarb
2012-12-31 11:07 AugustoMauch Review Assigned To => shankarb
2012-12-31 11:07 AugustoMauch Web browser Google Chrome => Google Chrome
2012-12-31 11:07 AugustoMauch Regression level => Production - Confirmed Stable
2012-12-31 11:07 AugustoMauch Regression date => 2011-10-26
2012-12-31 11:07 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f9b05776d657 [^]
2012-12-31 11:41 hgbot Checkin
2012-12-31 11:41 hgbot Note Added: 0055286
2012-12-31 11:41 hgbot Status new => resolved
2012-12-31 11:41 hgbot Resolution open => fixed
2012-12-31 11:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cb19f41d5523ab127140d43d53c6f6e1baf02b3f [^]
2012-12-31 12:03 shankarb Note Added: 0055287
2012-12-31 12:03 shankarb Status resolved => closed
2012-12-31 12:03 shankarb Fixed in Version => pi
2013-01-03 13:12 hudsonbot Checkin
2013-01-03 13:12 hudsonbot Note Added: 0055342


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker