Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022521
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2012-12-11 17:102013-01-28 08:15
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revision98f945713fd4
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022521: In Pick&Execute windows the selection is removed when sorting the columns

DescriptionIn Pick&Execute windows the selection is removed when sorting the columns if the lines have been selected by clicking on the line instead of clicking on the checkbox
Steps To ReproduceAs group admin role:
   Go to Payment Proposal window and create a new record
   Click on the Select Expected Payments button
   Select a line by clicking on it (not in the checkbox)
   Order the lines by clicking on a column
   Notice that the selection disappears
   Select a line by clicking on its checkbox
   Order the lines by clicking on a column
   Notice that now the line remains selected
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00225223.0MP20 closedAugustoMauch In Pick&Execute windows a removed selection appears when sorting the columns 

-  Notes
(0055777)
AugustoMauch (developer)
2013-01-23 18:15

When a row is selected by clicking on the checkbox both selectionChanged and selectionUpdated functions are called. In selectionUpdated the list of selected records, stored in this.selectedIDs, is updated.

When a row is selected by clicking in a line but not in its checkbox, only the selectionChanged function is called, so the list this.selectedIDs is not updated.
(0055871)
hgbot (developer)
2013-01-25 15:27

Repository: erp/devel/pi
Changeset: 98f945713fd4a8b2a8471e2cbe52aaedb710c2db
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Jan 25 15:26:55 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/98f945713fd4a8b2a8471e2cbe52aaedb710c2db [^]

Fixes issue 22521: In P&E the selection is not removed when sorting the grid

When a record was selected by clicking on an area other than the checkbox, the record was deselected when a column was sorted. This was caused because the selectionUpdated function, that was in charge of keeping the list of selected records, was only being called when the record was clicked on its checkbox.

This has been fixed by executing that function inside the selectionChanged function, that is executed when a record is selected, regardless if the click has been done in the checkbox.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0055878)
hudsonbot (developer)
2013-01-26 02:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/81e70c75d9a8 [^]

Maturity status: Test
(0055892)
shankarb (developer)
2013-01-28 08:15

Code reviewed and verified in pi changeset 679181dff0eb

- Issue History
Date Modified Username Field Change
2012-12-11 17:10 ngarcia New Issue
2012-12-11 17:11 ngarcia Assigned To => AugustoMauch
2012-12-11 17:11 ngarcia Modules => Core
2012-12-11 17:11 ngarcia Triggers an Emergency Pack => No
2012-12-11 17:17 ngarcia Issue Monitored: networkb
2012-12-11 17:18 ngarcia Relationship added related to 0022522
2013-01-23 18:15 AugustoMauch Note Added: 0055777
2013-01-23 18:25 AugustoMauch Relationship deleted related to 0022522
2013-01-23 18:26 AugustoMauch Relationship added blocks 0022522
2013-01-25 15:22 AugustoMauch Issue Monitored: shankarb
2013-01-25 15:23 AugustoMauch Review Assigned To => shankarb
2013-01-25 15:27 hgbot Checkin
2013-01-25 15:27 hgbot Note Added: 0055871
2013-01-25 15:27 hgbot Status new => resolved
2013-01-25 15:27 hgbot Resolution open => fixed
2013-01-25 15:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/98f945713fd4a8b2a8471e2cbe52aaedb710c2db [^]
2013-01-26 02:22 hudsonbot Checkin
2013-01-26 02:22 hudsonbot Note Added: 0055878
2013-01-28 08:15 shankarb Note Added: 0055892
2013-01-28 08:15 shankarb Status resolved => closed
2013-01-28 08:15 shankarb Fixed in Version => 3.0MP20


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker