Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022417
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] 05. Production managementminoralways2012-11-28 16:192020-03-04 18:17
ReporteregoitzView Statuspublic 
Assigned ToTriage Finance 
PriorityurgentResolutionduplicateFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseOracleJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tongarcia
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022417: The Pareto Product Legacy reports takes long to show a big amount of data

DescriptionThe Pareto Product Legacy reports takes long to show a big amount of data. It takes arround 27 minutes to show 1300 lines.
Steps To Reproduce-On a production enviroment with a big amount of data execute the report
-It takes long to show the result and the cpu usage goes to 100% on a oracle process
Proposed SolutionFirst change proposed:

On the m_get_pareto_abc_legacy function
replace
  AND M_GET_PRODUCT_COST(MSD.M_PRODUCT_ID,TO_DATE(now()),null) IS NOT NULL
  AND M_GET_PRODUCT_COST(MSD.M_PRODUCT_ID,TO_DATE(now()),null) <> 0
with
  AND COALESCE(M_GET_PRODUCT_COST(MSD.M_PRODUCT_ID,TO_DATE(now()),null),0) <> 0

That change reduces the time to execute the reports, but it is not enough.
It reduces from 27 minutes to 20 minutes.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0043416 newTriage Finance PL-function m_get_product_cost could be made 2 * faster 
related to design defect 0032493 closedvmromanos Pareto Product Report takes too long in an environment with big amount of data 

-  Notes
(0054640)
egoitz (developer)
2012-11-28 18:09

When executing the report, on the java a temporary table should be crated a filled with the query done on the m_get_pareto_abc_legacy function
(0054641)
egoitz (developer)
2012-11-28 18:10

That problem applies also to the new report for the new costing engine
(0055498)
jonalegriaesarte (reporter)
2013-01-14 09:53

This report should be designed from scratch
(0093624)
plujan (manager)
2017-01-17 11:17
edited on: 2017-01-17 11:20

Fixing wrong assignee (was changed to empty)


- Issue History
Date Modified Username Field Change
2012-11-28 16:19 egoitz New Issue
2012-11-28 16:19 egoitz Assigned To => dmiguelez
2012-11-28 16:19 egoitz Modules => Core
2012-11-28 17:36 egoitz Proposed Solution updated
2012-11-28 18:09 egoitz Note Added: 0054640
2012-11-28 18:10 egoitz Note Added: 0054641
2012-12-10 09:32 dmiguelez Assigned To dmiguelez => jonalegriaesarte
2012-12-12 09:42 jonalegriaesarte Triggers an Emergency Pack => No
2012-12-12 09:42 jonalegriaesarte Priority immediate => urgent
2013-01-14 09:53 jonalegriaesarte Note Added: 0055498
2013-01-14 09:53 jonalegriaesarte Severity major => minor
2013-01-14 09:53 jonalegriaesarte Type defect => design defect
2016-08-02 13:38 ngarcia Review Assigned To => ngarcia
2016-08-02 13:38 ngarcia Relationship added duplicate of 0032493
2016-08-02 13:38 ngarcia Status new => closed
2016-08-02 13:38 ngarcia Resolution open => duplicate
2016-08-02 13:40 ngarcia Relationship deleted 0032493
2016-08-02 14:34 ngarcia Assigned To jonalegriaesarte =>
2016-08-02 14:34 ngarcia Status closed => new
2016-08-02 14:34 ngarcia Relationship added related to 0032493
2017-01-17 11:17 plujan Assigned To => Triage Finance
2017-01-17 11:17 plujan Note Added: 0093624
2017-01-17 11:20 plujan Note Edited: 0093624 View Revisions
2020-03-04 18:17 shuehner Relationship added related to 0043416


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker