Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022371
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-11-22 10:152012-11-23 23:13
ReporterpsanjuanView Statuspublic 
Assigned Todbaz 
PriorityurgentResolutionfixedFixed in Version3.0MP18
StatusclosedFix in branchFixed in SCM revisionc151e43463cd
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserMozilla Firefox
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022371: The user interface is not displayed properly in FF17

DescriptionThe user interface is not displayed properly. This only happens while using Firefox.
Steps To ReproduceOpen live builds and navigate through the application. You'll realize that the user interface is not OK.
TagsNo tags attached.
Attached Filespng file icon 22371_01.png [^] (45,807 bytes) 2012-11-22 10:19


png file icon 22371_02.png [^] (24,913 bytes) 2012-11-22 10:19


png file icon 22371_03.png [^] (135,422 bytes) 2012-11-22 10:19

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0054452)
dbaz (developer)
2012-11-22 14:49

The test review should include a "fast" test which includes: Classic windows, classic popups and Pick&Execute processes, in the following browsers:

* Firefox 17 Linux and Windows
* Chrome 23 Linux and Windows
* IE9 Windows
(0054453)
hgbot (developer)
2012-11-22 14:51

Repository: erp/devel/pi
Changeset: 6da2a9b84afa55a20edd15ccffbb6635848418d1
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Nov 22 14:50:57 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6da2a9b84afa55a20edd15ccffbb6635848418d1 [^]

Fixed issue 22371: Now OB renders ok in Firefox 17

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0054454)
dbaz (developer)
2012-11-22 14:54

The issue is in Smartclient side.

Isomorphic have been fixed the issue exactly @ SmartClient_v83p_2012-11-21_LGPL nightly build.

The exact code that fixes the issue has been included to our souces.
(0054464)
AugustoMauch (developer)
2012-11-22 18:10

This fix does not solve all the problems in windows, neither in Linux (Firefox 17). In Linux, the layout is still wrong, the same as the attached screenshots
(0054465)
dbaz (developer)
2012-11-22 19:48

It seems that to make all of them fixed, the change should be inside Smartclient library core.
(0054466)
hgbot (developer)
2012-11-22 19:48

Repository: erp/devel/pi
Changeset: 73891434fc3caff8eae1244158307a5260cd9c3d
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Nov 22 19:45:08 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/73891434fc3caff8eae1244158307a5260cd9c3d [^]

Related to issue 22371: Reverted previous push since it didn't fix
completly the issue

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0054467)
hgbot (developer)
2012-11-22 19:48

Repository: erp/devel/pi
Changeset: c151e43463cd0367fbd31adb308901ecbb25bb2a
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Nov 22 19:48:20 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c151e43463cd0367fbd31adb308901ecbb25bb2a [^]

Fixed issue 22371: Now OB renders ok in Firefox 17

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_Combined.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_History.js
---
(0054480)
AugustoMauch (developer)
2012-11-23 12:51

Code reviewed and verified in pi@c151e43463cd.

It has been tested in:
Linux: Firefox 17, Chrome 23
Windows: Firefox 17, IE9, IE10
(0054486)
hudsonbot (developer)
2012-11-23 23:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5ae348efc931 [^]

Maturity status: Test
(0054488)
hudsonbot (developer)
2012-11-23 23:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5ae348efc931 [^]

Maturity status: Test
(0054489)
hudsonbot (developer)
2012-11-23 23:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5ae348efc931 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-11-22 10:15 psanjuan New Issue
2012-11-22 10:15 psanjuan Assigned To => AugustoMauch
2012-11-22 10:15 psanjuan Web browser => Mozilla Firefox
2012-11-22 10:15 psanjuan Modules => Core
2012-11-22 10:19 psanjuan File Added: 22371_01.png
2012-11-22 10:19 psanjuan File Added: 22371_02.png
2012-11-22 10:19 psanjuan File Added: 22371_03.png
2012-11-22 10:46 AugustoMauch Assigned To AugustoMauch => dbaz
2012-11-22 14:48 dbaz Review Assigned To => AugustoMauch
2012-11-22 14:48 dbaz Web browser Mozilla Firefox => Mozilla Firefox
2012-11-22 14:48 dbaz Summary The user interface is not displayed properly. => The user interface is not displayed properly in FF17
2012-11-22 14:49 dbaz Note Added: 0054452
2012-11-22 14:50 dbaz Issue Monitored: AugustoMauch
2012-11-22 14:51 hgbot Checkin
2012-11-22 14:51 hgbot Note Added: 0054453
2012-11-22 14:51 hgbot Status new => resolved
2012-11-22 14:51 hgbot Resolution open => fixed
2012-11-22 14:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6da2a9b84afa55a20edd15ccffbb6635848418d1 [^]
2012-11-22 14:54 dbaz Note Added: 0054454
2012-11-22 18:10 AugustoMauch Note Added: 0054464
2012-11-22 18:10 AugustoMauch Status resolved => new
2012-11-22 18:10 AugustoMauch Resolution fixed => open
2012-11-22 19:48 dbaz Note Added: 0054465
2012-11-22 19:48 hgbot Checkin
2012-11-22 19:48 hgbot Note Added: 0054466
2012-11-22 19:48 hgbot Checkin
2012-11-22 19:48 hgbot Note Added: 0054467
2012-11-22 19:48 hgbot Status new => resolved
2012-11-22 19:48 hgbot Resolution open => fixed
2012-11-22 19:48 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/6da2a9b84afa55a20edd15ccffbb6635848418d1 [^] => http://code.openbravo.com/erp/devel/pi/rev/c151e43463cd0367fbd31adb308901ecbb25bb2a [^]
2012-11-23 12:51 AugustoMauch Note Added: 0054480
2012-11-23 12:51 AugustoMauch Status resolved => closed
2012-11-23 12:51 AugustoMauch Fixed in Version => 3.0MP18
2012-11-23 23:13 hudsonbot Checkin
2012-11-23 23:13 hudsonbot Note Added: 0054486
2012-11-23 23:13 hudsonbot Checkin
2012-11-23 23:13 hudsonbot Note Added: 0054488
2012-11-23 23:13 hudsonbot Checkin
2012-11-23 23:13 hudsonbot Note Added: 0054489


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker