Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022175
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2012-10-30 18:352013-04-03 12:53
ReporteradrianromeroView Statuspublic 
Assigned Tomigueldejuana 
PrioritynormalResolutionfixedFixed in VersionRMP21
StatusclosedFix in branchFixed in SCM revision3d595b7f23fb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022175: The payment dialogs do not work in android

DescriptionIf a payment method is associated with a payment provider that shows a dialog. When using this payment method the dialog does not work properly, it is closed immediately without executing any action.
Steps To Reproduce* Configure a payment method to show a dialog:
** in POS terminal, Go to the tab payment types and select "Cash"
** Go to the payment method window from here
** In Payment Provider select "Confirm payment dialog" and save the record
* Log in in Web POS
* Create a new receipt and add some items
* In the payment tab tab on the exact amount button. You will see that a green dialog appears for some instants and closes. The expected behaviour would be a message that shows the details of the payment that after pressing OK the payment is added.
Tagsmultibrowser
Attached Filesjpg file icon Screenshot_2012-11-14-12-19-13.jpg [^] (182,239 bytes) 2012-11-14 17:29


jpg file icon Screenshot_2012-11-14-12-09-24.jpg [^] (229,612 bytes) 2012-11-14 17:30

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0054247)
guilleaer (developer)
2012-11-14 17:32

Priority has been decreased because the modal pop up works as expected in android devices.

We have detected some style problems with some popups.

see attached files.
(0057202)
hgbot (developer)
2013-03-12 12:48

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 3d595b7f23fb6e2ad6355dafdea30d2e14c000c6
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Mar 12 12:48:29 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3d595b7f23fb6e2ad6355dafdea30d2e14c000c6 [^]

Fixed issue 22175: Payment dialog works well, UI is more clear now

---
M web/org.openbravo.retail.posterminal/js/components/mockpayments.js
---
(0057203)
migueldejuana (developer)
2013-03-12 12:50

It works well in RMP20. I have changed the appearance to be more clear.
(0057288)
guilleaer (developer)
2013-03-18 10:00

verified
(0057682)
hgbot (developer)
2013-04-02 20:11

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: 3d595b7f23fb6e2ad6355dafdea30d2e14c000c6
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Mar 12 12:48:29 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/3d595b7f23fb6e2ad6355dafdea30d2e14c000c6 [^]

Fixed issue 22175: Payment dialog works well, UI is more clear now

---
M web/org.openbravo.retail.posterminal/js/components/mockpayments.js
---

- Issue History
Date Modified Username Field Change
2012-10-30 18:35 adrianromero New Issue
2012-10-30 18:35 adrianromero Assigned To => adrianromero
2012-11-09 12:45 alostale Tag Attached: multibrowser
2012-11-09 12:45 alostale Assigned To adrianromero => guilleaer
2012-11-09 12:45 alostale Priority normal => urgent
2012-11-09 12:45 alostale Status new => scheduled
2012-11-14 17:29 guilleaer File Added: Screenshot_2012-11-14-12-19-13.jpg
2012-11-14 17:30 guilleaer File Added: Screenshot_2012-11-14-12-09-24.jpg
2012-11-14 17:31 guilleaer Priority urgent => normal
2012-11-14 17:32 guilleaer Note Added: 0054247
2013-03-12 12:43 migueldejuana Assigned To guilleaer => migueldejuana
2013-03-12 12:48 hgbot Checkin
2013-03-12 12:48 hgbot Note Added: 0057202
2013-03-12 12:48 hgbot Status scheduled => resolved
2013-03-12 12:48 hgbot Resolution open => fixed
2013-03-12 12:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3d595b7f23fb6e2ad6355dafdea30d2e14c000c6 [^]
2013-03-12 12:50 migueldejuana Note Added: 0057203
2013-03-18 10:00 guilleaer Review Assigned To => guilleaer
2013-03-18 10:00 guilleaer Note Added: 0057288
2013-03-18 10:00 guilleaer Status resolved => closed
2013-03-18 10:00 guilleaer Fixed in Version => RMP21
2013-04-02 20:11 hgbot Checkin
2013-04-02 20:11 hgbot Note Added: 0057682
2013-04-02 20:11 hgbot Status closed => resolved
2013-04-02 20:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3d595b7f23fb6e2ad6355dafdea30d2e14c000c6 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/3d595b7f23fb6e2ad6355dafdea30d2e14c000c6 [^]
2013-04-03 12:53 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker