Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022098
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-10-24 22:272012-10-30 11:40
ReporterplujanView Statuspublic 
Assigned Tomtaal 
PriorityurgentResolutionfixedFixed in Version3.0MP17
StatusclosedFix in branchpiFixed in SCM revision0d7d2c8be2bb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelAutomated tests
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022098: Filtering by partial contents has changed since inclusion of grouping feature

DescriptionWhen I tried to filter by a substring, changes did not take effect immediately as in previous releases. Furthermore, leaving the field had not effect neither. Only moving to a third field got the action I was looking for.
Steps To Reproduce1. Open Sales Invoice window (see screnshot 1)
2. Use a partial filter, like B for selecting all the "Customer B" business partners (see screenshot 2). Note that the filter is not applied immediately like it was in previous releases.
3. Move to another field (see screenshot 3). Note that the filter is not applied yet.
4. Move to a third field (see screenshot 4). Now the filter is applied.
TagsNo tags attached.
Attached Filespng file icon Openbravo Sales Invoice I 37 - 1.png [^] (108,200 bytes) 2012-10-24 22:27


png file icon Openbravo Sales Invoice 2.png [^] (74,706 bytes) 2012-10-24 22:27


png file icon Openbravo Sales Invoice 3.png [^] (70,249 bytes) 2012-10-24 22:27


png file icon Openbravo Sales Invoice 4.png [^] (93,415 bytes) 2012-10-24 22:27

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00221143.0MP17 closedmtaal Filtering behaviour in Product Selector has changed 

-  Notes
(0053669)
hgbot (developer)
2012-10-24 23:54

Repository: erp/devel/pi
Changeset: 0d7d2c8be2bbd47e65941ba9e00993686ddc27a4
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Wed Oct 24 23:53:31 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0d7d2c8be2bbd47e65941ba9e00993686ddc27a4 [^]

Fixes issue 22098: Filtering by partial contents has changed since inclusion of grouping feature
Filtering now happens when exiting the filter field, the grid is not filtered automatically on keypress
the suggestion box is filtered.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0053670)
mtaal (developer)
2012-10-24 23:55

Set reviewer
(0053672)
mtaal (developer)
2012-10-24 23:55

.
(0053673)
mtaal (developer)
2012-10-24 23:55

Resolved
(0053712)
hudsonbot (developer)
2012-10-25 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4a27e27689bc [^]

Maturity status: Test
(0053799)
dbaz (developer)
2012-10-30 11:40

Reviewed @ changeset: 18367 - 2c82168e2836

- Issue History
Date Modified Username Field Change
2012-10-24 22:27 plujan New Issue
2012-10-24 22:27 plujan Assigned To => mtaal
2012-10-24 22:27 plujan File Added: Openbravo Sales Invoice I 37 - 1.png
2012-10-24 22:27 plujan Modules => Core
2012-10-24 22:27 plujan File Added: Openbravo Sales Invoice 2.png
2012-10-24 22:27 plujan File Added: Openbravo Sales Invoice 3.png
2012-10-24 22:27 plujan File Added: Openbravo Sales Invoice 4.png
2012-10-24 22:28 plujan Regression level => Automated tests
2012-10-24 23:54 hgbot Checkin
2012-10-24 23:54 hgbot Note Added: 0053669
2012-10-24 23:54 hgbot Status new => resolved
2012-10-24 23:54 hgbot Resolution open => fixed
2012-10-24 23:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0d7d2c8be2bbd47e65941ba9e00993686ddc27a4 [^]
2012-10-24 23:55 mtaal Note Added: 0053670
2012-10-24 23:55 mtaal Status resolved => new
2012-10-24 23:55 mtaal Resolution fixed => open
2012-10-24 23:55 mtaal Review Assigned To => AugustoMauch
2012-10-24 23:55 mtaal Status new => scheduled
2012-10-24 23:55 mtaal Note Added: 0053672
2012-10-24 23:55 mtaal fix_in_branch => pi
2012-10-24 23:55 mtaal Note Added: 0053673
2012-10-24 23:55 mtaal Status scheduled => resolved
2012-10-24 23:55 mtaal Fixed in Version => 3.0MP17
2012-10-24 23:55 mtaal Resolution open => fixed
2012-10-25 12:39 hudsonbot Checkin
2012-10-25 12:39 hudsonbot Note Added: 0053712
2012-10-25 18:52 plujan Relationship added related to 0022114
2012-10-30 09:10 alostale Review Assigned To AugustoMauch => dbaz
2012-10-30 11:40 dbaz Note Added: 0053799
2012-10-30 11:40 dbaz Status resolved => closed
2017-10-30 19:01 caristu Relationship added related to 0037181
2017-10-31 12:34 caristu Relationship deleted related to 0037181


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker