Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021910
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-10-11 12:022012-10-16 09:45
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP17
StatusclosedFix in branchFixed in SCM revisionebea3541b581
ProjectionnoneETAnoneTarget Version3.0MP17
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2012-09-07
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d719d893fa76930495cfca884a31d15b1dfdc0d9 [^]
Triggers an Emergency Packyes
Summary

0021910: 'Show all' link of widgets only shows 76 registries

Description'Show all' link of widgets only shows 76 registries
Steps To ReproduceAs system admin role:
   Create a Widget
      Widget Superclass: Query/List
   In the Query tab:
      HQL: select documentNo as n from Invoice
   In the Column tab:
      Display Column Alias: n
      Reference: String
      Include In: Widget view
As group admin role:
   Add the widget to the workspace
      Number of rows: 5
      Show all data: NO
   Check that Showing 5 of X rows where X is greater than 76
   Navigate through the Show all link
   Realize that only 76 registries are shown
   
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0053317)
hgbot (developer)
2012-10-11 17:38

Repository: erp/devel/pi
Changeset: ebea3541b581cfd2d5ba3c5645af8a1db1c3c3e9
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Oct 11 17:36:43 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ebea3541b581cfd2d5ba3c5645af8a1db1c3c3e9 [^]

Fixes issue 21910: When a widget is opened in a window it shows all its records

This issue was caused by the fix of the issue 16622. In that issue the ReadOnlyDataSourceServeld was changed so that it kept count of the number of records if the NOCOUNT parameter was set to 'false', as it was done with other datasources. In this case, in order not to break existing calls to the datasource, the count will only be prevented if the parameter is set to 'true', so if the parameter does not have any value (as it is in this scenario of the issue), the count will be done.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0053333)
hudsonbot (developer)
2012-10-13 15:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/99e438a6f972 [^]

Maturity status: Test
(0053366)
shankarb (developer)
2012-10-16 09:45

Code verified in changeset 9cd004664cde

- Issue History
Date Modified Username Field Change
2012-10-11 12:02 ngarcia New Issue
2012-10-11 12:02 ngarcia Assigned To => AugustoMauch
2012-10-11 12:02 ngarcia Modules => Core
2012-10-11 12:04 ngarcia Issue Monitored: networkb
2012-10-11 17:31 AugustoMauch Regression level => Production - QA Approved
2012-10-11 17:31 AugustoMauch Regression date => 2012-09-07
2012-10-11 17:31 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d719d893fa76930495cfca884a31d15b1dfdc0d9 [^]
2012-10-11 17:37 AugustoMauch Issue Monitored: shankarb
2012-10-11 17:37 AugustoMauch Review Assigned To => shankarb
2012-10-11 17:38 hgbot Checkin
2012-10-11 17:38 hgbot Note Added: 0053317
2012-10-11 17:38 hgbot Status new => resolved
2012-10-11 17:38 hgbot Resolution open => fixed
2012-10-11 17:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ebea3541b581cfd2d5ba3c5645af8a1db1c3c3e9 [^]
2012-10-13 15:50 hudsonbot Checkin
2012-10-13 15:50 hudsonbot Note Added: 0053333
2012-10-16 09:45 shankarb Note Added: 0053366
2012-10-16 09:45 shankarb Status resolved => closed
2012-10-16 09:45 shankarb Fixed in Version => 3.0MP17


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker