Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021863
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2012-10-04 16:362012-10-11 07:50
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP17
StatusclosedFix in branchpiFixed in SCM revisionee9c755796d8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021863: If a field is set to be displayed in grid but not in form view, if it is part of a field group it will be shown in the form view

DescriptionIf a field is part of a field group and is set to be displayed in the grid but not in the form view, it will be displayed in the form view anyway.

This happens because there is some code that makes visible all the fields that belong to a field group when that field group is expanded, unless the field has the property hiddenInForm set to true.
Steps To ReproduceAs System Admin:
- Open Windows, Tabs and Fields
- Select the Sales Order Window
- Select the Header tab
- Open in form view the Sales Representative field.
- Set displayed = false and Show in Grid view = true
As F&B Admin:
- Open the Sales Order window
- Check that the column Sales Representative is shown in the grid
- Open a sales order in form view. Check that the Sales Representative field is displayed in the More Information group field, but it should not be displayed at all.
Proposed SolutionWhen a field is set to not be visible in the form view, set its hiddenInForm property to true.
TagsNo tags attached.
Attached Filesdiff file icon issue21863.diff [^] (657 bytes) 2012-10-04 16:37 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0053119)
hgbot (developer)
2012-10-08 17:23

Repository: erp/devel/pi
Changeset: ee9c755796d8c44962aa09ea9ce885cd3d60f485
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Oct 08 17:18:34 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ee9c755796d8c44962aa09ea9ce885cd3d60f485 [^]

Fixes issue 21863: Not displayed fields are not shown even if in field group

The problem was that if a field was displayed in the grid but not in the form, it would be shown in the form if it was included in a field group. This has been fixed by setting to 'Y' the property hiddenInForm of these fields.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0053120)
AugustoMauch (developer)
2012-10-08 17:24

Reopened to enter Closed by field
(0053168)
dbaz (developer)
2012-10-09 13:16

Reviewed @ changeset: 18169 - dcd825463870
(0053264)
hudsonbot (developer)
2012-10-11 07:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63dfc135f2a1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-10-04 16:36 AugustoMauch New Issue
2012-10-04 16:36 AugustoMauch Assigned To => AugustoMauch
2012-10-04 16:36 AugustoMauch Modules => Core
2012-10-04 16:37 AugustoMauch File Added: issue21863.diff
2012-10-04 16:37 AugustoMauch Status new => scheduled
2012-10-04 16:37 AugustoMauch fix_in_branch => pi
2012-10-04 17:21 maria_perez Issue Monitored: maria_perez
2012-10-05 08:26 roklenardic Issue Monitored: roklenardic
2012-10-08 17:23 hgbot Checkin
2012-10-08 17:23 hgbot Note Added: 0053119
2012-10-08 17:23 hgbot Status scheduled => resolved
2012-10-08 17:23 hgbot Resolution open => fixed
2012-10-08 17:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ee9c755796d8c44962aa09ea9ce885cd3d60f485 [^]
2012-10-08 17:24 AugustoMauch Note Added: 0053120
2012-10-08 17:24 AugustoMauch Status resolved => new
2012-10-08 17:24 AugustoMauch Resolution fixed => open
2012-10-08 17:24 AugustoMauch Issue Monitored: dbaz
2012-10-08 17:24 AugustoMauch Review Assigned To => dbaz
2012-10-08 17:24 AugustoMauch fix_in_branch pi =>
2012-10-08 17:24 AugustoMauch Status new => scheduled
2012-10-08 17:24 AugustoMauch fix_in_branch => pi
2012-10-08 17:25 AugustoMauch Status scheduled => resolved
2012-10-08 17:25 AugustoMauch Resolution open => fixed
2012-10-09 13:16 dbaz Note Added: 0053168
2012-10-09 13:16 dbaz Status resolved => closed
2012-10-09 13:16 dbaz Fixed in Version => 3.0MP17
2012-10-11 07:50 hudsonbot Checkin
2012-10-11 07:50 hudsonbot Note Added: 0053264


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker