Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021264
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 06. Material requirement planning (MRP)majoralways2012-07-31 13:132012-08-09 13:07
ReporterVictorVillarView Statuspublic 
Assigned Tojecharri 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionb0701ee55593
ProjectionnoneETAnoneTarget Version3.0MP14
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP13SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2012-04-02
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/367f4c3538f72d90e2461a213f4795f3a9b5e72f [^]
Triggers an Emergency Packyes
Summary

0021264: Module script DeleteInventoryLines is incomplete and the processes related

DescriptionModule script DeleteInventoryLines is incomplete because it is deleting m_storage_detail records but is not taking into account that these lines can be referenced in table m_stock_proposed.
Also the processes related to this attempt to erase the m_storage_detail registers with m_attributeset_id = 0
Steps To ReproduceAs group admin role,
Go to Attribute window,
   Org: España
   Name: Color
   List: YEs
   Mandatory: No
Go to Attribute Set window,
 Org: España
 Name: lote
 Require At Least One Value: NO

   Assigned Attribute tab
      Attribute: Color

Go to Planning method window,
   create new register
      Org: España
      name: taka
    Go to Lines tab: create:
       Pending Purchase Order
       Material requirement
       Sales Forecast
       Pending Sales Order
Go to Product window,
Create a new one with an attribute set: Lote
    name: test
  Go to Price tab:
     two new registers: for Tarifa de Ventas and Tarifas Bebidas Alegres
  Go to Purchasing plan:
     Business Partner: Bebidas Alegres
  Go to Manufacturing plan:
     Organization: España
     Storage bin: RN-0-0-0
     Planning method: taka
     Safety Stock: 20
Go to Goods Receipt window,
     create a new register
        Org: españa
      Lines tab:
         Product: test
         Qty: 10
Go to Purchasing plan window,
     Create a new register:
       Org: España
       name: propuesta
       Product: test
  Process Purchase Plan

Go to Goods Shipment window,
    Create new register
      Lines tab,
        Product: test
        qty: 10
Complete it

Go to Attribute window,
   select Color register
   List: YEs
   Mandatory: YEs
Go to Attribute Set window,
 select lote register
 Require At Least One Value: YES

Go to Goods Shipment window,
    Create new register
     Org: España
      Lines tab,
        Product: test
        qty: 10
Save it. try to select the Attribute.
This record cannot be deleted because it is associated with other existing elements. Please see Linked Items.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00211993.0MP14 closedjecharri Module script DeleteInventoryLines is incomplete 
related to defect 00201593.0MP11 closedjecharri Product with mandatory attribute should not generate lines without attribute in m_storage_detail 
related to defect 0021285 closedmirurita Creating Inventory count process in Physical Inventory does not create Lines 

-  Notes
(0051048)
hgbot (developer)
2012-08-01 10:55

Repository: erp/devel/pi
Changeset: b0701ee555932c6795648df10054f3610dbba6cf
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Wed Aug 01 10:54:53 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b0701ee555932c6795648df10054f3610dbba6cf [^]

Fixes issue 21264: Module script DeleteInventoryLines is incomplete and the processes related

---
M src-db/database/model/functions/M_INVENTORY_LISTCREATE.xml
M src-db/database/model/functions/M_UPDATE_INVENTORY.xml
M src-db/database/model/functions/M_UPDATE_STOCKAUX.xml
M src-util/modulescript/build/classes/org/openbravo/modulescript/DeleteInventoryLinesData.class
M src-util/modulescript/src/org/openbravo/modulescript/DeleteInventoryLines_data.xsql
---
(0051050)
hgbot (developer)
2012-08-01 12:12

Repository: erp/devel/pi
Changeset: dfffc79d08765b906d8618928f7d74c1b9ae79b1
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Wed Aug 01 12:11:25 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dfffc79d08765b906d8618928f7d74c1b9ae79b1 [^]

issue 21264: Module script DeleteInventoryLines is incomplete and the processes related

---
M src-db/database/model/functions/M_INVENTORY_LISTCREATE.xml
---
(0051051)
gorkaion (developer)
2012-08-01 12:23

code review done
(0051067)
VictorVillar (developer)
2012-08-01 14:37

Verified steps to reproduce and done test cases related to it, as launch physical inventory
(0051205)
hudsonbot (developer)
2012-08-09 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ef9a070edd19 [^]

Maturity status: Test
(0051207)
hudsonbot (developer)
2012-08-09 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ef9a070edd19 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-07-31 13:13 VictorVillar New Issue
2012-07-31 13:13 VictorVillar Assigned To => jecharri
2012-07-31 13:13 VictorVillar Modules => Core
2012-07-31 13:13 VictorVillar Issue Monitored: networkb
2012-07-31 13:26 VictorVillar Regression level => Production - QA Approved
2012-07-31 13:28 VictorVillar Relationship added related to 0021199
2012-07-31 13:29 VictorVillar Relationship added related to 0020159
2012-07-31 13:35 VictorVillar Regression level Production - QA Approved => Production - Confirmed Stable
2012-07-31 13:51 eintelau Issue Monitored: eintelau
2012-08-01 10:55 hgbot Checkin
2012-08-01 10:55 hgbot Note Added: 0051048
2012-08-01 10:55 hgbot Status new => resolved
2012-08-01 10:55 hgbot Resolution open => fixed
2012-08-01 10:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b0701ee555932c6795648df10054f3610dbba6cf [^]
2012-08-01 12:12 hgbot Checkin
2012-08-01 12:12 hgbot Note Added: 0051050
2012-08-01 12:23 gorkaion Note Added: 0051051
2012-08-01 14:37 VictorVillar Note Added: 0051067
2012-08-01 14:37 VictorVillar Status resolved => closed
2012-08-02 08:54 jecharri Status closed => new
2012-08-02 08:54 jecharri Resolution fixed => open
2012-08-02 08:54 jecharri Regression date => 2012-04-02
2012-08-02 08:54 jecharri Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/367f4c3538f72d90e2461a213f4795f3a9b5e72f [^]
2012-08-02 08:54 jecharri Status new => scheduled
2012-08-02 08:54 jecharri fix_in_branch => pi
2012-08-02 08:54 jecharri Status scheduled => resolved
2012-08-02 08:54 jecharri Resolution open => fixed
2012-08-02 08:55 jecharri Status resolved => closed
2012-08-09 13:07 hudsonbot Checkin
2012-08-09 13:07 hudsonbot Note Added: 0051205
2012-08-09 13:07 hudsonbot Checkin
2012-08-09 13:07 hudsonbot Note Added: 0051207
2012-09-04 13:06 shuehner Relationship added related to 0021285


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker