Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021212
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2012-07-25 18:582012-08-30 10:06
ReporterVictorVillarView Statuspublic 
Assigned Tojecharri 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5940c0deb9b5
ProjectionnoneETAnoneTarget Version3.0MP15
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP13SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021212: Problems in match statement process if the user does not allow charge the data

Descriptionwe have tested that if the users uncheck "hide transactions after statement date" flag before the data has been shown, then, the matched lines proposed and others are going to be included in a reconciliation with and without bank statement lines associated and then the user could not open again the match statement window because the mixing reconciliation error.
The same problem happens if the users check "Cleared" flag before the data has been loaded.
Steps To ReproduceAs system admin role,
Install the Advanced Matching algorithm module.

As group admin role,
Financial account,
Import a large number of bank statement lines (it would be fine to have a bank statement file for the client F&B) It is tested with 170 bank statement lines.
Process it

click in Match Statement button.
BEFORE the lines appear, uncheck "hide transactions after statement date" flag, then try to handle the information. The same problem happens if the users check "Cleared" flag before the data has been loaded.
Check or uncheck the lines proposed, and we realise that suddenly some lines are included in the reconciliation and if you click Cancel Button a Null Pointer Exception error appear.
It would no be possible to open again the match statement window because the mixing reconciliation error.

If you see the lines of the reconciliation we realise that there are mixed lines reconciled, with and without bank statement line associated.
Proposed SolutionDisabled the "hide transactions after statement date" flag till all the data has been charged.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0051152)
hgbot (developer)
2012-08-08 08:33

Repository: erp/devel/pi
Changeset: 5940c0deb9b516395f32ec4ef87c7506a20a5535
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Wed Aug 08 08:31:32 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5940c0deb9b516395f32ec4ef87c7506a20a5535 [^]

Fixes issue 21212: Problems in match statement
process if the user does not allow charge the data

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/MatchTransaction.html
---
(0051664)
VictorVillar (developer)
2012-08-30 10:06

Verified

- Issue History
Date Modified Username Field Change
2012-07-25 18:58 VictorVillar New Issue
2012-07-25 18:58 VictorVillar Assigned To => mirurita
2012-07-25 18:58 VictorVillar Modules => Core
2012-07-25 18:59 VictorVillar Issue Monitored: networkb
2012-07-25 19:01 VictorVillar Steps to Reproduce Updated View Revisions
2012-07-26 13:41 mirurita Assigned To mirurita => jonalegriaesarte
2012-07-30 09:43 VictorVillar Description Updated View Revisions
2012-07-30 09:43 VictorVillar Steps to Reproduce Updated View Revisions
2012-08-02 10:45 jonalegriaesarte Assigned To jonalegriaesarte => jecharri
2012-08-08 08:33 hgbot Checkin
2012-08-08 08:33 hgbot Note Added: 0051152
2012-08-08 08:33 hgbot Status new => resolved
2012-08-08 08:33 hgbot Resolution open => fixed
2012-08-08 08:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5940c0deb9b516395f32ec4ef87c7506a20a5535 [^]
2012-08-30 10:06 VictorVillar Note Added: 0051664
2012-08-30 10:06 VictorVillar Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker