Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020677
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2012-06-05 09:122012-06-30 05:10
ReporteregoitzView Statuspublic 
Assigned ToioritzCia 
PriorityurgentResolutionfixedFixed in Version3.0MP13
StatusclosedFix in branchpiFixed in SCM revision3b4adfb72e90
ProjectionnoneETAnoneTarget Version3.0MP13
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP11SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020677: The system is collapsed when adding a payment when there are a lof of document to selected (12.000)

DescriptionThe system is collapsed when adding a payment when there are a lof of documednts to selected (12.000).
When opening the addpayment popup without filtering anything and having about 12.000 documents to select all the memory is used.


Steps To Reproduce-On a server with a lot of invoices or gl/item go to payment in window
-Click on add detail button and try to select one.
*The system is collapsed
Proposed SolutionA partial solution is to not show nothing by default on loading but if then you don't add filter to search the problem is the same.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0020710 closedioritzCia The system is collapsed when adding a payment when there are a lof of document to selected (12.000) 

-  Notes
(0050244)
hgbot (developer)
2012-06-28 09:15

Repository: erp/devel/pi
Changeset: 3b4adfb72e907a71ef11b89022eeea29dbafc5c4
Author: Ioritz Cia <ioritz.cia <at> openbravo.com>
Date: Wed Jun 27 10:28:01 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3b4adfb72e907a71ef11b89022eeea29dbafc5c4 [^]

Fixes issue 20677: The system is collapsed when adding orders or invoices
to a payment when there are a lof of document to selected (12.000).
Performance improvements.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/AddOrderOrInvoice.html
---
(0050273)
egoitz (developer)
2012-06-29 10:08

verified
(0050290)
hudsonbot (developer)
2012-06-30 05:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ce760b148e29 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-06-05 09:12 egoitz New Issue
2012-06-05 09:12 egoitz Assigned To => mirurita
2012-06-05 09:12 egoitz Modules => Core
2012-06-05 09:13 egoitz Tag Attached: Performance
2012-06-05 19:11 mirurita Assigned To mirurita => jonalegriaesarte
2012-06-07 12:35 jonalegriaesarte Assigned To jonalegriaesarte => egoitz
2012-06-08 08:23 jecharri Assigned To egoitz => jecharri
2012-06-08 11:09 jecharri Status new => scheduled
2012-06-08 11:09 jecharri fix_in_branch => pi
2012-06-11 16:12 jecharri Assigned To jecharri => ioritzCia
2012-06-28 09:15 hgbot Checkin
2012-06-28 09:15 hgbot Note Added: 0050244
2012-06-28 09:15 hgbot Status scheduled => resolved
2012-06-28 09:15 hgbot Resolution open => fixed
2012-06-28 09:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3b4adfb72e907a71ef11b89022eeea29dbafc5c4 [^]
2012-06-29 10:08 egoitz Note Added: 0050273
2012-06-29 10:08 egoitz Status resolved => closed
2012-06-29 10:08 egoitz Fixed in Version => 3.0MP13
2012-06-30 05:10 hudsonbot Checkin
2012-06-30 05:10 hudsonbot Note Added: 0050290


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker