Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020649
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] E. Translationminoralways2012-05-30 16:542012-06-22 10:14
ReporterVictorVillarView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiondbb3d43517a8
ProjectionnoneETAnoneTarget Version3.0MP13
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP11SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020649: Not translation of selector fields for Business Partner selector in Sales Invoice window

DescriptionAfter install the Spanish translation module of Openbravo we can see that does not exist any translation of selector fields for Business Partner selector in Sales Invoice window.

After solve this problem it is necessary to launch a new version of the Spanish translation pack
Steps To ReproduceBefore the following steps install the Spanish translation module for Openbravo.

As Group Admin role and Spanish as language,
Go to Sales Invoice (Factura (Cliente)) window,
Create a new register
 open Business Partner selector
we can see that the Selectors fields are not translated
Proposed SolutionConfigure the translation checks to YES for all the business partner selector fields.

After solve this problem it is necessary to launch a new version of the Spanish translation pack
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0049543)
vmromanos (developer)
2012-05-31 15:51

In 3.0MP10.1 we updated the es_ES translation for all the modules included into the distribution; no untranslated string were pending.

However I have tested it and the fields are not translated, example "Customer Balance".
Digging into the XML exported by Openbravo I see that this string is always translated:
$ fgrep -r "Customer Balance" *
AD_ELEMENT_TRL_es_ES.xml: <value column="Name" isTrl="Y" original="Customer Balance">Crédito usado</value>
AD_ELEMENT_TRL_es_ES.xml: <value column="PrintName" isTrl="Y" original="Customer Balance">Crédito usado</value>
AD_ELEMENT_TRL_es_ES.xml: <value column="Help" isTrl="Y" original="The Customer Balance indicates the total amount of open or unpaid invoices for this Business Partner.">

Indica la suma total de las facturas entregadas a este tercero que permanecen sin&nbsp;haber sido pagadas.

</value>
AD_MESSAGE_TRL_es_ES.xml: <value column="MsgText" isTrl="Y" original="Customer Balance">Crédito usado</value>
org.openbravo.advpaymentmngt/AD_TEXTINTERFACES_TRL_es_ES.xml: <value column="Text" isTrl="Y" original="Customer Balance">Balance del Cliente</value>
org.openbravo.advpaymentmngt/AD_TEXTINTERFACES_TRL_es_ES.xml: <value column="Text" isTrl="Y" original="Customer Balance">Balance del Cliente</value>


However I can't find the record inside the OBUISEL_SELECTOR_FIELD_TRL_es_ES.xml. It looks like the export process is not properly exporting this table.

Moving back to platform to check if the export process is working properly or not.
(0049605)
alostale (developer)
2012-06-04 13:36

The problem is these fields are marked as centrally maintained.

When a parent field is centrally maintained, its translation is not exported.

For centrally maintained selector fields, info is taken from the element associated with the column (property) in the field. It is only possible to associate a column for selectors of type table but not for custom query ones. Latter case is the one of Business Partner selector. In this case, centrally maintained option shouldn't be shown and it should always be set to N, forcing to write all UI info directly in the field and not in the element.


Proposed solution:
-Hide centrally maintained option for custom query selectors.
-In case of custom query selector, force centrally maintenance to be false
-Fix current values in OB distribution of centrally maintenance to follow this new rule
-Communicate this rule to other module owners to fix their modules
-Fix translation modules to include missing fields
(0049702)
hgbot (developer)
2012-06-08 10:01

Repository: erp/devel/pi
Changeset: dbb3d43517a8294bbeed4ce1d8931da600fa449f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jun 08 09:59:25 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dbb3d43517a8294bbeed4ce1d8931da600fa449f [^]

fixed bug 20649: Some selector fields were not translated

 Forcing fields of custom query selectors to be set as not centrally maintained

---
M modules/org.openbravo.userinterface.selector/src-db/database/sourcedata/AD_FIELD.xml
A modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorFieldHandler.java
---
(0049703)
hgbot (developer)
2012-06-08 10:01

Repository: erp/devel/pi
Changeset: 58e057ead4fb7c58af92e0d3917e267a675b9c01
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jun 08 09:59:53 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/58e057ead4fb7c58af92e0d3917e267a675b9c01 [^]

related to bug 20649: Fix existent data

---
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0050021)
VictorVillar (developer)
2012-06-22 10:00

Verified: Another issue is opened for monitoring the translation fields when the translation pack will be launched
(0050026)
VictorVillar (developer)
2012-06-22 10:14

Related to the folling issue:

https://issues.openbravo.com/view.php?id=20834 [^]

- Issue History
Date Modified Username Field Change
2012-05-30 16:54 VictorVillar New Issue
2012-05-30 16:54 VictorVillar Assigned To => alostale
2012-05-30 16:54 VictorVillar Modules => Core
2012-05-30 16:55 VictorVillar Issue Monitored: networkb
2012-05-31 15:16 alostale Assigned To alostale => vmromanos
2012-05-31 15:51 vmromanos Note Added: 0049543
2012-05-31 15:51 vmromanos Assigned To vmromanos => alostale
2012-06-04 13:36 alostale Note Added: 0049605
2012-06-08 10:01 hgbot Checkin
2012-06-08 10:01 hgbot Note Added: 0049702
2012-06-08 10:01 hgbot Status new => resolved
2012-06-08 10:01 hgbot Resolution open => fixed
2012-06-08 10:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dbb3d43517a8294bbeed4ce1d8931da600fa449f [^]
2012-06-08 10:01 hgbot Checkin
2012-06-08 10:01 hgbot Note Added: 0049703
2012-06-22 10:00 VictorVillar Note Added: 0050021
2012-06-22 10:00 VictorVillar Status resolved => closed
2012-06-22 10:14 VictorVillar Note Added: 0050026


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker