Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020598
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalalways2012-05-24 10:452012-05-31 13:10
ReporterioritzCiaView Statuspublic 
Assigned ToioritzCia 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond321f8c1371a
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS VersionUbuntu 10.04Database version8.4Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browserGoogle Chrome
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020598: Issue 15290 causes an API fail.

DescriptionDue to this issue,

- https://issues.openbravo.com/view.php?id=20399 [^]

I have to make an api change. I have pushed the change to try and this is the failure:

- http://builds.openbravo.com/view/try/job/try-api/835/console [^]

The change is the following:

APRM_PENDING_PAYINV_PAYMENT foreign key of table APRM_PENDING_PAYMENTINVOCE changes from on delete do nothing to on delete cascade.

The change is needed due to the following reason:

This foreign key defines a relation between FIN_PAYMENT and APRM_PENDING_PAYMENTINVOCE. It is used to advise the system that automatically created payments need to be executed. But this makes the system unable to delete one of this payments because there is a foreign key defined.

The risk of this api change is very low. In fact, we have not been able to identify any risk.
Steps To Reproducenone
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0049365)
iciordia (manager)
2012-05-28 13:32

Approved.

Ismael
(0049368)
hgbot (developer)
2012-05-28 13:43

Repository: erp/devel/api-checks
Changeset: d321f8c1371a55dab319205043183d2aca9a00e1
Author: Ioritz Cia <ioritz.cia <at> openbravo.com>
Date: Mon May 28 11:02:39 2012 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/d321f8c1371a55dab319205043183d2aca9a00e1 [^]

Fixes issue 20598: Issue 15290 causes an API fail.

---
M model/modules/org.openbravo.advpaymentmngt/src-db/database/model/tables/APRM_PENDING_PAYMENTINVOICE.xml
---

- Issue History
Date Modified Username Field Change
2012-05-24 10:45 ioritzCia New Issue
2012-05-24 10:45 ioritzCia Assigned To => iciordia
2012-05-24 10:45 ioritzCia Web browser => Google Chrome
2012-05-24 10:45 ioritzCia Modules => Advanced Payables and Receivables Mngmt
2012-05-28 09:17 ioritzCia Status new => feedback
2012-05-28 13:32 iciordia Note Added: 0049365
2012-05-28 13:32 iciordia Assigned To iciordia => ioritzCia
2012-05-28 13:43 hgbot Checkin
2012-05-28 13:43 hgbot Note Added: 0049368
2012-05-28 13:43 hgbot Status feedback => resolved
2012-05-28 13:43 hgbot Resolution open => fixed
2012-05-28 13:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/d321f8c1371a55dab319205043183d2aca9a00e1 [^]
2012-05-31 13:10 ioritzCia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker