Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020485
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-05-14 11:232012-05-25 12:12
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0MP12
StatusclosedFix in branchFixed in SCM revision7924a2a98a3b
ProjectionnoneETAnoneTarget Version3.0MP12
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020485: Slow OBCriteria

DescriptionOBCriteria performs worse than OBQuery. For the same query, OBCriteria consumes x4 time in additional overhead.
Steps To Reproduce-
TagsPerformance
Attached Filesdiff file icon issue-20485.diff [^] (1,601 bytes) 2012-05-14 11:25 [Show Content]
zip file icon org.openbravo.issue20485.zip [^] (2,890 bytes) 2012-05-15 16:29

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0020515 closedalostale OBCriteria creates contention at JVM 

-  Notes
(0048609)
alostale (developer)
2012-05-14 11:25

Attaching patch. Pending to prepare test case to check real improvement.
(0048655)
alostale (developer)
2012-05-15 16:35
edited on: 2012-05-15 17:16

Attached file can be unzipped under modules directory.

Executing "ant test" executes 5000 times an OBCriteria and 5000 times OBQuery.

Before the fix:
 -Time for OBCriteria 165246, time for OBQuery 6498. Note OBCriteria time hugely differs when executed as ant task or within tomcat context, ~24k ms in latter case. Might be due to different classpath/classloader?

After the fix:
 -OBCriteria 12352, OBQuery 6450. Times are very similar within Tomcat

After the fix overhead of OBCriteria over OBQuery has been reduced from x4 to x2

(0048660)
hgbot (developer)
2012-05-15 17:40

Repository: erp/devel/pi
Changeset: 7924a2a98a3be2066f229c3f7ac6f9209c1f337a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue May 15 17:21:13 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7924a2a98a3be2066f229c3f7ac6f9209c1f337a [^]

fixed bug 20485: Slow OBCriteria

  Do not calculate mappedClass each time its requiered but use cached one, which
  is present in super PojoEntityTuplizer.

---
M src/org/openbravo/dal/core/OBTuplizer.java
---
(0048727)
mtaal (developer)
2012-05-17 12:06

Reviewed
(0049136)
hudsonbot (developer)
2012-05-25 12:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-05-14 11:23 alostale New Issue
2012-05-14 11:23 alostale Assigned To => alostale
2012-05-14 11:23 alostale Modules => Core
2012-05-14 11:25 alostale File Added: issue-20485.diff
2012-05-14 11:25 alostale Note Added: 0048609
2012-05-14 12:52 shuehner Issue Monitored: shuehner
2012-05-15 12:22 alostale Tag Attached: Performance
2012-05-15 16:29 alostale File Added: org.openbravo.issue20485.zip
2012-05-15 16:35 alostale Note Added: 0048655
2012-05-15 17:15 alostale Description Updated View Revisions
2012-05-15 17:16 alostale Note Edited: 0048655 View Revisions
2012-05-15 17:18 alostale Relationship added related to 0020515
2012-05-15 17:40 hgbot Checkin
2012-05-15 17:40 hgbot Note Added: 0048660
2012-05-15 17:40 hgbot Status new => resolved
2012-05-15 17:40 hgbot Resolution open => fixed
2012-05-15 17:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7924a2a98a3be2066f229c3f7ac6f9209c1f337a [^]
2012-05-17 12:06 mtaal Note Added: 0048727
2012-05-17 12:06 mtaal Status resolved => closed
2012-05-17 12:06 mtaal Fixed in Version => 3.0MP12
2012-05-25 12:12 hudsonbot Checkin
2012-05-25 12:12 hudsonbot Note Added: 0049136


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker