Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020337
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] I. Performancemajorhave not tried2012-04-24 16:222012-05-29 03:27
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0MP12
StatusclosedFix in branchFixed in SCM revisionff800550e531
ProjectionnoneETAnoneTarget Version3.0MP12
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020337: Direct navigation should be filtered by record

DescriptionDirect navigation to a concrete record is slow when destination table has big amount of data.

The problem is because, even we are filtering by a known BP id, we need to know which is its position in grid. So basically, we do query for the known BP (fast), then query for all BPs in the system sorted in the same way they are sorted in grid, and loop over this resultset to find out the position of this BP to know the offset in the grid (slow).
Steps To Reproduce-In an instance with ~600K business partners
-Select an invoice an navigate to its BP through link in invoice header -> it takes ~15s to open BP window consuming CPU.
Proposed SolutionIn most of the cases, when navigating to a known record, user is interested just in that record and not in the rest of them. Furthermore, it is opened in form view so in many cases user won't navigate to grid. For all these cases all the slow part is just an overhead that doesn't provide any benefit to user.

The proposal is to filter for this case just for the known ID having a kind of "implicit filter". The flow would be: when navigating to a known record, it is opened in form view (as it is now); if user goes to grid, only current record is shown and the blue message about "implicit filter by current record" is shown so he's aware he can clean it up to show all the records. In this case he might have the same problem described above.

This change would affect to:
-Direct navigation to a referenced record through link
-Navigation from "linked items"

Note in case of navigating to a subtab, this should be filtered as well as all its ancestors.
TagsPerformance
Attached Files? file icon issue-20337.export [^] (21,327 bytes) 2012-04-24 17:06

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026640pi closedguillermogil On clicking a record from Recent Documents it should open just its record, not the whole window 

-  Notes
(0047926)
alostale (developer)
2012-04-24 17:01

Test plan for this issue is described in TestLink (http://tools.openbravo.com:8891/testlink [^]) under 3.0 Test Suite > Direct Navigation

Regression risk of this fix is medium as it modifies navigation and datasources which are very central components of Openbravo 3. Though all use cases should be covered by defined test plan.

The code will be pushed to pi within mp12.
(0048326)
hgbot (developer)
2012-05-03 13:15

Repository: erp/devel/pi
Changeset: e258509138aca1a444146c7d37d628c76cd38b3d
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Apr 24 17:05:19 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e258509138aca1a444146c7d37d628c76cd38b3d [^]

fixed issue 020337: Direct navigation should be filtered by record

 Direct and linked items navigation is now filtered by the selected record, this
 improves perfomance because it is not needed to retrieve all records in grid to
 calculate selected recod position in grid.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_REF_LIST.xml
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form-linked-items.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-view-manager.js
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0048327)
hgbot (developer)
2012-05-03 13:15

Repository: erp/devel/pi
Changeset: 5b9a10923e6bdd3fda91305168291d2b62b0bb06
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 25 16:34:47 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5b9a10923e6bdd3fda91305168291d2b62b0bb06 [^]

related to issue 020337: Don't show and hide message when navigating

 The grid view is shown briefly first (with the blue message) and is then
 quickly replaced by the form view.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0049002)
hudsonbot (developer)
2012-05-25 12:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049003)
hudsonbot (developer)
2012-05-25 12:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049345)
AugustoMauch (developer)
2012-05-28 11:39

Code review:
- In the setSingleRecordFilterMessage function, OBUIAPP_SingleRecordFilterMsg message is being shown regardless of the value of the OBUIAPP_ShowSingleRecordFilterMsg property.
(0049351)
hgbot (developer)
2012-05-28 12:24

Repository: erp/devel/pi
Changeset: ff800550e531852e8aa94f79442e00ebccfae1d2
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon May 28 12:22:58 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ff800550e531852e8aa94f79442e00ebccfae1d2 [^]

Fixes issue 20337: Message shown if OBUIAPP_ShowSingleRecordFilterMsg is true

Now, before showing the message, the value of the OBUIAPP_ShowSingleRecordFilterMsg property is checked.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0049353)
AugustoMauch (developer)
2012-05-28 12:29

Code review and verified in pi@ff800550e531
(0049389)
hudsonbot (developer)
2012-05-29 03:27

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ced2fdfb9aee [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-04-24 16:22 alostale New Issue
2012-04-24 16:22 alostale Assigned To => shuehner
2012-04-24 16:22 alostale Modules => Core
2012-04-24 17:01 alostale Note Added: 0047926
2012-04-24 17:06 alostale File Added: issue-20337.export
2012-04-24 17:07 alostale Assigned To shuehner => alostale
2012-04-24 17:12 alostale Tag Attached: Performance
2012-05-03 13:15 hgbot Checkin
2012-05-03 13:15 hgbot Note Added: 0048326
2012-05-03 13:15 hgbot Status new => resolved
2012-05-03 13:15 hgbot Resolution open => fixed
2012-05-03 13:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e258509138aca1a444146c7d37d628c76cd38b3d [^]
2012-05-03 13:15 hgbot Checkin
2012-05-03 13:15 hgbot Note Added: 0048327
2012-05-25 12:09 hudsonbot Checkin
2012-05-25 12:09 hudsonbot Note Added: 0049002
2012-05-25 12:09 hudsonbot Checkin
2012-05-25 12:09 hudsonbot Note Added: 0049003
2012-05-28 11:39 AugustoMauch Note Added: 0049345
2012-05-28 11:39 AugustoMauch Status resolved => new
2012-05-28 11:39 AugustoMauch Resolution fixed => open
2012-05-28 12:24 hgbot Checkin
2012-05-28 12:24 hgbot Note Added: 0049351
2012-05-28 12:24 hgbot Status new => resolved
2012-05-28 12:24 hgbot Resolution open => fixed
2012-05-28 12:24 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e258509138aca1a444146c7d37d628c76cd38b3d [^] => http://code.openbravo.com/erp/devel/pi/rev/ff800550e531852e8aa94f79442e00ebccfae1d2 [^]
2012-05-28 12:29 AugustoMauch Note Added: 0049353
2012-05-28 12:29 AugustoMauch Status resolved => closed
2012-05-28 12:29 AugustoMauch Fixed in Version => 3.0MP12
2012-05-29 03:27 hudsonbot Checkin
2012-05-29 03:27 hudsonbot Note Added: 0049389
2014-05-23 12:49 guillermogil Relationship added related to 0026640


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker