Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020089
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminoralways2012-03-22 11:182012-04-02 06:12
ReporterxabiermerinoView Statuspublic 
Assigned Tojecharri 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisioncb5cc787ce23
ProjectionnoneETAnoneTarget Version3.0MP10
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP8.1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020089: It is possible select a purchase price list in the product selector of sales invoice

DescriptionIt is possible select a purchase price list in the product selector of sales invoice
Steps To Reproduce-As admin go to sales invoice >> lines
-Select product
-realize that It is possible select a purchase price list in the product selector of sales invoice
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00201683.0MP11 closedjecharri It is possible select a products from price list with different currency to the header price list 
blocks backport 00201092.50MP41 closedjecharri It is possible select a purchase price list in the product selector of sales invoice 
causes defect 0028426 closedumartirena Cannot add a product to a commission if it doesn't have a sales price defined 

-  Notes
(0046684)
jonalegriaesarte (reporter)
2012-03-23 13:21

The user may wrongly select the sales price list of different currency and use it in the sales order. Please review it.
(0046727)
hgbot (developer)
2012-03-26 12:15

Repository: erp/devel/pi
Changeset: cb5cc787ce23462f96bff2aa4780993597440bbb
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Mon Mar 26 12:14:33 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cb5cc787ce23462f96bff2aa4780993597440bbb [^]

Fixes issue 20089: It is possible select a purchase price list in the product selector of sales invoice.
Now you have the posibilitie to select the price list but if it sales price list and you are creating a purchase, you will see that you are not able to select any product because the grid is empty

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0046957)
xabiermerino (developer)
2012-03-30 10:01

verified
(0047231)
hudsonbot (developer)
2012-04-02 06:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7814864461ac [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-03-22 11:18 xabiermerino New Issue
2012-03-22 11:18 xabiermerino Assigned To => vmromanos
2012-03-22 11:18 xabiermerino Modules => Core
2012-03-22 11:19 xabiermerino Issue Monitored: networkb
2012-03-22 16:24 jonalegriaesarte Assigned To vmromanos => jonalegriaesarte
2012-03-22 20:11 jonalegriaesarte Assigned To jonalegriaesarte => jecharri
2012-03-23 13:21 jonalegriaesarte Note Added: 0046684
2012-03-26 12:15 hgbot Checkin
2012-03-26 12:15 hgbot Note Added: 0046727
2012-03-26 12:15 hgbot Status new => resolved
2012-03-26 12:15 hgbot Resolution open => fixed
2012-03-26 12:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cb5cc787ce23462f96bff2aa4780993597440bbb [^]
2012-03-26 12:21 xabiermerino Relationship added blocks 0020109
2012-03-30 10:01 xabiermerino Note Added: 0046957
2012-03-30 10:01 xabiermerino Status resolved => closed
2012-03-30 11:51 jecharri Relationship added related to 0020168
2012-04-02 06:12 hudsonbot Checkin
2012-04-02 06:12 hudsonbot Note Added: 0047231
2015-01-22 13:09 AtulOpenbravo Relationship added causes 0028426


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker