Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019730
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2012-02-10 22:192012-03-02 15:37
ReportermtaalView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP9
StatusclosedFix in branchFixed in SCM revisioncde4b46243eb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019730: Focus should start in first filter editor field

DescriptionWhen opening a window the focus/cursor should initially be placed in the first field of the filtereditor. This is much better for usability.
Steps To ReproduceOpen for example the product category window, it is not clear where the focus is, it needs to be placed in the first filter field.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0045110)
hgbot (developer)
2012-02-14 15:12

Repository: erp/devel/pi
Changeset: cdcbb0c7f47915c3cfb6b265458f36cd16463da3
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 14 15:10:03 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cdcbb0c7f47915c3cfb6b265458f36cd16463da3 [^]

Fixes issue 19730: Focus now stars in first filter editor field

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0045112)
AugustoMauch (developer)
2012-02-14 15:24

There was already a function to focus the first filter editor field, but it was not working properly, because the field being focused was the first of filterEditor.getEditForm().getItems(), which is the checkbox field to select and deselect registers.

The item focused should be one that the user can actually use to filter (e.g., whose editorType is not 'StaticTextItem').

It was needed to call the focusInFirstFilterEditor from ob-view-grid.setViewState to ensure that after applying a saved view the proper item was focused.

If a view is in form view and it is switched to grid view, the focus goes to the register that was opened in form view, no to the first filter editor field. I think this is the expected behaviour.
(0045113)
AugustoMauch (developer)
2012-02-14 15:28

Test Plan:
- Open any window. The item focused should be the first filter editor field.
- Open any window, modify the filters and save the view. After loading the view the item focused should be the first filter editor field, regardless of the open view type (grid or form).
- Open any window and double click on a register. The form view should open. Close that view. The grid view should open, and the register that selected should be focused.

I think this is not a risky fix.
(0045115)
hgbot (developer)
2012-02-14 16:16

Repository: erp/devel/pi
Changeset: 215fbb471eaa1a6ddf4cb214d6510c05756c91f5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 14 16:15:19 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/215fbb471eaa1a6ddf4cb214d6510c05756c91f5 [^]

Related to issue 19730: Removes fix because a defect was detected

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0045121)
AugustoMauch (developer)
2012-02-14 17:43

After further investigation I have found that the fix had not caused a problem, but just shown a prior strange underlying behaviour.

Try this:
- Open the window Business Partner (the focused item is nowhere to be seen)
- Select the first register
- Click on the title of the subtab Customer
- Click on the title of the header tab.

Apparently the focus is on the selected register, but it actually is not (try using the arrow keys to move among the registers). The focus is on the same hidden item where it was when opening the window.

After my fix is applied, when a window is opened the focus goes to the first filter item. After following the steps stated before, the focus goes again to this same item.

I have been talking with Ivan and we have agreed that the correct behaviour would be to focus the selected register after clicking on the header tab title. I am going to implement this functionality, and after I have finished I will enable again the code to select the first filter item when a window is opened.
(0045133)
dbaz (developer)
2012-02-14 21:43

It still fails
(0045136)
hgbot (developer)
2012-02-15 09:51

Repository: erp/devel/pi
Changeset: fd30d7d690723b2efb97928c1112f4f6c9f58d23
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Feb 15 09:46:47 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fd30d7d690723b2efb97928c1112f4f6c9f58d23 [^]

Related to issue 19730: The focus goes to the selected record after clicking on a tab title

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0045140)
hgbot (developer)
2012-02-15 10:53

Repository: erp/devel/pi
Changeset: cde4b46243eb91b970911291f032d088fc3fe730
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Feb 15 10:25:57 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cde4b46243eb91b970911291f032d088fc3fe730 [^]

Fixes issue 19730: Focus now stars in first filter editor field

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0045152)
dbaz (developer)
2012-02-15 14:05

Reviewed @ changeset: 15482 - 6b84612a26a3
(0045848)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045849)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045851)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045852)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-02-10 22:19 mtaal New Issue
2012-02-10 22:19 mtaal Assigned To => AugustoMauch
2012-02-10 22:19 mtaal Modules => Core
2012-02-14 15:12 hgbot Checkin
2012-02-14 15:12 hgbot Note Added: 0045110
2012-02-14 15:12 hgbot Status new => resolved
2012-02-14 15:12 hgbot Resolution open => fixed
2012-02-14 15:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cdcbb0c7f47915c3cfb6b265458f36cd16463da3 [^]
2012-02-14 15:24 AugustoMauch Note Added: 0045112
2012-02-14 15:28 AugustoMauch Note Added: 0045113
2012-02-14 16:16 hgbot Checkin
2012-02-14 16:16 hgbot Note Added: 0045115
2012-02-14 17:43 AugustoMauch Note Added: 0045121
2012-02-14 21:43 dbaz Note Added: 0045133
2012-02-14 21:43 dbaz Status resolved => new
2012-02-14 21:43 dbaz Resolution fixed => open
2012-02-15 09:51 hgbot Checkin
2012-02-15 09:51 hgbot Note Added: 0045136
2012-02-15 10:53 hgbot Checkin
2012-02-15 10:53 hgbot Note Added: 0045140
2012-02-15 10:53 hgbot Status new => resolved
2012-02-15 10:53 hgbot Resolution open => fixed
2012-02-15 10:53 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/cdcbb0c7f47915c3cfb6b265458f36cd16463da3 [^] => http://code.openbravo.com/erp/devel/pi/rev/cde4b46243eb91b970911291f032d088fc3fe730 [^]
2012-02-15 14:05 dbaz Note Added: 0045152
2012-02-15 14:05 dbaz Status resolved => closed
2012-02-15 14:05 dbaz Fixed in Version => 3.0MP9
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045848
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045849
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045851
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045852


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker