Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019644
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-02-02 18:542012-03-02 15:34
Reporterdmitry_mezentsevView Statuspublic 
Assigned Tojecharri 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision0c038709d04d
ProjectionnoneETAnoneTarget Version3.0MP8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019644: Product complete selector does not work properly

DescriptionFor the Sales Transaction windows it filters by default products with Stocked=No while should do with Stocked=Yes.
Steps To Reproducelive.builds.pi / main, default user.

1. New Goods Movement.
2. Create new Line. Go to Product selector and mention that except of the product name there is no any other information associated to it (Storage Bin, Quantities and so on).
3. Open selector and check that Stocked=No filter is applied.
TagsRegression QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00193883.0MP8 closedjecharri Wrong product selector in Work Requirement window 

-  Notes
(0044834)
alostale (developer)
2012-02-03 08:17
edited on: 2012-02-03 08:45

The problem was introduced by fix for 0019388 when replacing product selector stocked default property:

     2.7 -<!--FF8080812E77708D012E7796A94B0017--> <DEFAULT_EXPRESSION><![CDATA[if (OB.isSalesTransaction() == true) { true } else { false }]]></DEFAULT_EXPRESSION>
     2.8 +<!--FF8080812E77708D012E7796A94B0017--> <DEFAULT_EXPRESSION><![CDATA[if (OB.isSalesTransaction() === true) { true } else {false} ]]></DEFAULT_EXPRESSION>


This is how isSalesTransactions is evaluated by js engine:

Sales trx
  OB.isSalesTransaction()->true
  if (OB.isSalesTransaction() == true) { true } else {false} ->true
  if (OB.isSalesTransaction() === true) { true } else {false} ->false
Purchase trx
  OB.isSalesTransaction()->false
  if (OB.isSalesTransaction() == true) { true } else {false} ->false
  if (OB.isSalesTransaction() === true) { true } else {false} ->false


Therefore stocked property is always defaulted to false after the fix.

(0044844)
hgbot (developer)
2012-02-03 10:26

Repository: erp/devel/pi
Changeset: 0c038709d04d9bd5dc58e52f99db94fa09bf0eba
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Fri Feb 03 10:25:42 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0c038709d04d9bd5dc58e52f99db94fa09bf0eba [^]

Fixes issue 19644: Product complete selector does not work properly.
I revert the change because with '===' equals is not working as it is expected.

---
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0044847)
ioritzCia (developer)
2012-02-03 11:06

Verified.
(0045747)
hudsonbot (developer)
2012-03-02 15:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-02-02 18:54 dmitry_mezentsev New Issue
2012-02-02 18:54 dmitry_mezentsev Assigned To => alostale
2012-02-02 18:54 dmitry_mezentsev Modules => Core
2012-02-02 18:55 dmitry_mezentsev Tag Attached: Regression QA
2012-02-02 18:55 dmitry_mezentsev Relationship added related to 0019388
2012-02-03 08:17 alostale Note Added: 0044834
2012-02-03 08:45 alostale Note Edited: 0044834 View Revisions
2012-02-03 08:45 alostale Assigned To alostale => jecharri
2012-02-03 10:26 hgbot Checkin
2012-02-03 10:26 hgbot Note Added: 0044844
2012-02-03 10:26 hgbot Status new => resolved
2012-02-03 10:26 hgbot Resolution open => fixed
2012-02-03 10:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0c038709d04d9bd5dc58e52f99db94fa09bf0eba [^]
2012-02-03 11:06 ioritzCia Note Added: 0044847
2012-02-03 11:06 ioritzCia Status resolved => closed
2012-03-02 15:34 hudsonbot Checkin
2012-03-02 15:34 hudsonbot Note Added: 0045747


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker